locked
Login into sharepoint with email address without forms authentication RRS feed

  • Question

  • I have an install of Sharepoint Services 3.0 presently for users to access they need to login with domain use name format [domain\username].

    Looking to have users login with there email address instead user@company.com. Authentication is handled by AD.

    Can it be done? If so can you point me in to a good article or tech note on procedure.

    I do not want to use forms based authentication at this point as i have tried that and the trade off to use it is not desirable.

    Thursday, May 19, 2011 4:25 PM

Answers

  • If all the users are active directory users, by default, users should be able to login with

    • Email address
    • Domain Name\UserName

    I don't think there are any additional settings to configure it.


    V
    • Marked as answer by Seven M Friday, May 27, 2011 3:36 AM
    Thursday, May 19, 2011 4:30 PM
  • Hi,

    As V284 mentioned, there are two user logon name:

    username@domain.com

    domain\username

    You can check them from AD > select a user > properties > account tab.

    Generally, emails for users will use username@domain.com format.

    But if users use other emails, i don't think they will be working.

    Regards,

    Seven

    • Marked as answer by Seven M Friday, May 27, 2011 3:36 AM
    Friday, May 20, 2011 2:14 AM

All replies

  • If all the users are active directory users, by default, users should be able to login with

    • Email address
    • Domain Name\UserName

    I don't think there are any additional settings to configure it.


    V
    • Marked as answer by Seven M Friday, May 27, 2011 3:36 AM
    Thursday, May 19, 2011 4:30 PM
  • Hi,

    As V284 mentioned, there are two user logon name:

    username@domain.com

    domain\username

    You can check them from AD > select a user > properties > account tab.

    Generally, emails for users will use username@domain.com format.

    But if users use other emails, i don't think they will be working.

    Regards,

    Seven

    • Marked as answer by Seven M Friday, May 27, 2011 3:36 AM
    Friday, May 20, 2011 2:14 AM