Defrag Tool Not Functioning in XP SP3 RC2


  • Since installing SP3 RC2, the Defrag tool will load, but will not perform an Analysis or a Defragment.  If I unistall XP SP3 it is fine.  Any thoughts on how to keep this working while still running this otherwise good package.

    Friday, February 29, 2008 1:45 AM


  • Hi Dave,

    Running RC2 release 3311 and Defrag tool is running fine for me.

    Which release are you running?  If prior to 3311, try uninstalling and then using 3311 instead.


    Friday, February 29, 2008 1:59 AM

All replies

  • Hi Dave,

    Running RC2 release 3311 and Defrag tool is running fine for me.

    Which release are you running?  If prior to 3311, try uninstalling and then using 3311 instead.


    Friday, February 29, 2008 1:59 AM
  • David,


    My defrag is working perfectly in build 3311. Can you try this command in build 3311. Follow the steps below.


    1) Open command prompt (cmd.exe) by going to Start, and Run field.

    2) Type "cmd.exe", type "defrag G: -f -v" without quotes, and hit enter.

    3) (Change bold letter "G" to your drive letter.)

    4) Disk Defragmenter should run at this point


    If defrag doesn't run, do a check disk command (chkdsk G: /R /F /X) in command prompt. Try to defrag again, and if it still doesn't run properly, do you want to try repairing defrag utility? There's an article on this topic at this url (






    Friday, February 29, 2008 2:26 AM

  •    Hey David,
      hopfully you were able to reinstall defrag. I lost defrag once along tmie ago and search for the dfrg.inf file to re-install it. I am using windows x86 or 32 bit version of Windows xp2 Another problem way I have seen in the past is if any other program that removed defrag prior to installing the SP RC2 have have removed the file. Since this is cros filed with RC@ and you are going to eventually remove it. Just letting you know another way defrag may have been removed. If it woprked prior then it is as Thomas has said and the thread will help you re-install the tool
      So summerized what I did
      start sear, dfrg.inf in hidden and system folders opened that directory after running cmd. pointing to that directory and opening that .inf
    Hope this helps


    Not a Microsoft employee
    Tuesday, March 04, 2008 8:56 AM

    Hey every one.

     I can confirm there was a uninstall problem with V3311 RC2 prior to the refresh. 

      The text of the merror message I received is

     Line 1:" MMC cannot open the C:\windows\system\dfrg.mmc"

      Line 2" This may because the file does not exist, is not in the MMC console, or was created by a later versio of MMC.

      This may because you do not have sufficient access rights to the file"



     Just letting you know an issued exists. If you are not aware of it already. This was post un-install of the RC2, the second version. *No there were no other programs installed that removed dfrg.* Prior to installing Sp2 v3311 dfrg worked properly. Post v3311 dfrg worked properly. *Post uninstall v3311 from the control panel ADD/Remove programs is when the fault appeared.

       This was a completely clean install of Sp2 Professional. In the proper order. Nforce 4 chipset from Nvidia 6.86 WHQL signed.  Xp2, then dot net 1.1 and sp1 2.0, Direct x Noiv 07. WHQL Nvidia 165.25 video card, Then VS2k8.


    Reprooduced here is my dfrg.inf showing the supposed .inf for the dfrg tool. Please feel free to contact me for any more additional information. If my prof does not have my life copntact information. I am on MSlive currently.There are not eventviewer errors in application, security or anything relating to the console.


      I am currently at sp2 level. Does not seem to be any other functional problems. Unless the suba program fix to the registery needs to be re applied.  Currenlt This is only a minor annoyance. Since I can reinstall windows xp sp2 from CD with the /Integrated  drivers I need for the system

    Signature = "$Windows NT$"

    AddReg = DF.AddReg
    ProfileItems = DefragInstallItems

    Name       = %DEFRAG_SNAPIN%
    CmdLine    = 11,, dfrg.msc
    SubDir     = %SystemTools_GROUP%
    WorkingDir = 11
    IconPath   = 11,,DfrgRes.dll
    IconIndex  = 0
    InfoTip    = "@%SystemRoot%\system32\shell32.dll,-22539"

    HKLM,"SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction","OptimizeError",0x00000000,"Not Run"


    HKLM,"SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\DefragPath","",0x00020000,"%systemroot%\system32\dfrg.msc %c:"


    shell32.dll is the proper sp2 version (xpsp gdr_071025-12-48

    dfrgfat.ext is sp2

    dfrgntfs.exe is sp2

    dfrgres.dll is sp2

    dfsnap.dll is sp2

    dfgui.dll is sp2

    dfrg.msc has no version information, creation date Feb 2006. Probabluy rorginal cd creation date


    Friday, March 28, 2008 3:56 AM