none
IE 11 as the default browser over Edge RRS feed

  • Question

  • I set IE 11 as the default browser but every time I click on a link in an email I still get the question of which browser I want to open the link in.  I click Internet Explorer and select the "Always open with this app" and click ok.  The next time I click on a link in an email I am again asked to select a browser to open. 

    How do I fix this permanently so that IE opens instead of edge?

    Friday, August 21, 2015 3:25 PM

All replies

  • How do I fix this permanently so that IE opens instead of edge?

    Good question, as it will lead ultimately to a clearer understand of how Edge has been implemented as "default browser".  FWIW supposedly I still have Edge as my default browser and don't want to change it.  I have no difficulty using one or the other browser.  So, since you have "set IE 11 as the default browser" please start  computerdefaults.exe  from an Administrator command prompt  and say what you see under  Choose a default web browser:  

    FWIW I see only one item:  Internet Explorer  so where is Edge going to be specified?  Does picking Internet Explorer change it (e.g. away from Edge) or just perform the conventional repair of it?

    Anyway, that is where we normally go to change or repair the default browser, especially if others are involved which have made switching problematic.  Is that what you used to make your change?

    However, I would also look at the Options, Programs tab and see if anything changes there if you reset Internet Explorer the first way.  Strangely there is still an option in there referring to "tiles on the Desktop".  A sign of WIP?   <eg>

    Note that there is also a link in there which supposedly allows IE to become the default browser, so I suppose it is possible that that goes somewhere else entirely.  Further, we can still use the Set Programs button on that tab as an indirect way of getting into the same dialog that computerdefaults.exe leads to (and other conventional Control Panel versions about related information).

    Interesting that in a cmd window this gives me nothing.

    C:\>ftype | find /i "edge"

    while this gives me seemingly a full set

    C:\>ftype | find /i "iexpl"

    Also compare what you see in Default Apps (launched by Win-i  Def  Enter), and see what it says for Web browser.  FWIW I do not see Internet Explorer in there as an alternative.

    So how is Edge as default browser implemented?

    FWIW I would try using ProcMon to help answer this question.  Or if that diagnostic is being obscured I would try to find an appropriate  netsh trace  provider to give us clues.  I may try this myself if I can get my W10 VM working better.

     

    HTH



    Robert Aldwinckle
    ---

    • Proposed as answer by Fahadking07 Saturday, August 22, 2015 5:41 PM
    Saturday, August 22, 2015 5:06 PM
    Answerer
  • Hi,

    Firstly, please follow the steps below to set the default brower.

    1. In Search box, type “default program”, then click it > “Set your default programs”.
    2. Select Internet Explorer in the left list, and choose “Set this program as default”.
    3. Click “Choose defaults for this program” > “Select all”.

    We have test it by the steps above in our machine and we haven’t receive the option to select a browser. If the steps above do not work, you can make a screenshot on the link that you opened in your email and send it to us. We doubt that the link is not a common link, and We can help you better.

    Monday, August 24, 2015 10:12 AM
  • Hi Simon,

    The directions you indicated above is how I originally set the default program and as you can see below IE11 is set as the default browser.  I have also added the Edge screen shot to show that it is no longer the default.

    When I click on any link (it doesn't matter what kind) this is what happens:

    The like in the email was what was clicked on and even if I click the "Always use this app" this box Always comes up.  Does outlook have a default browser setting?  If I copy the link to Word the link launches in IE, also if I click on a link in any other program IE launches.

    Thursday, August 27, 2015 11:55 PM
  • Hi,

    Thanks for your feedback.

    Have you try set associations to the file type? Just open “Control Panel” > “Programs” > “Default Programs” > “Associate a file type or protocol with a specific program”. Then choose “.html”, “.htm”, “.url” and other link type, change their default program to “Internet Explorer”. You can try the steps for test.

    In addition to that, I would like to know whether you are using a 3rd party software. If the steps above doesn’t work, I infer there is some settings in your email box which you are using that leads to the issue, or the Windows cannot detect the URL due to the 3rd party email box. I suggest you can copy a link and paste it to the Word and open the link in the word to check if it can open directly by Internet Explorer. If it does, it may be the 3rd party email box problem.   

    Wish you have a nice experience in Windows.

     

    Best Regards

    Simon

     



    • Edited by _Charles_ Wednesday, September 2, 2015 1:00 AM
    Wednesday, September 2, 2015 12:56 AM
  • Simon,

    Thanks for the suggestions, however, if you look at the screenshots in my last posting you will see that internet explorer is the default, along with the having all of the file associations.  I am not using any 3rd party email programs (only outlook).  You will also note that in my posting I also stated that if I copy the link to another office program (word, excel, powerpoint) internet explorer launches.   Guess Ill have to keep digging for an answer.

    Monday, September 7, 2015 6:13 AM
  • I set IE 11 as the default browser but every time I click on a link in an email I still get the question of which browser I want to open the link in.  I click Internet Explorer and select the "Always open with this app" and click ok.  The next time I click on a link in an email I am again asked to select a browser to open. 

    How do I fix this permanently so that IE opens instead of edge?

    Hi!

    Since I can not post links yet then this is how to get solution: Google "You are prompted to specify Internet Explorer when you click a link in Outlook 2010 or Outlook 2007" and first link is Microsoft support article which offers solution.

    I had same issue and it seems to be specific to Windows 10, IE 11 and Outlook 2007/2010 combination.

    Friday, September 7, 2018 7:37 AM