locked
AlwaysOn Management Pack not functioning - SCOM 2007R2 RRS feed

  • Question

  • Hi all

    I am a DBA but am new to SCOM and have been trying to get the AlwaysOn Management pack to work.  I manually installed some agents on the 2 boxes I want to manage and can see they are being monitored in the inventory.

    The management pack was already pre-installed by another employee but when I looked into the Administration > Management Packs and clicked on Import I could see that for that particular pack the AlwaysOn features were not installed.  Thinking this was the reason why it was not working I installed them.

    I can now see when I go to Discovered Inventory and Change Target Type the AlwaysOn components however they are not monitoring anything.  The only one with an entry is the AlwaysOn seed which shows the 2 boxes, but in a not monitored state.

    Does anyone have any suggestions about how to get this to work?

    Many thanks


    • Edited by Thomas Rhea Wednesday, January 23, 2013 2:56 PM
    Wednesday, January 23, 2013 2:56 PM

All replies

  • Hi all - I take it no one has come across a similar situation before?   If anyone can point me in a direction of SCOM things to check I would be grateful.   The SCOM servers are in a different domain to the ones being monitored if there is any extra config I need to do for that?

    Thursday, January 24, 2013 1:57 PM
  • Hi

    SQL needs Run As Accounts and Profiles configuring:

    http://blogs.technet.com/b/kevinholman/archive/2010/09/08/configuring-run-as-accounts-and-profiles-in-r2-a-sql-management-pack-example.aspx

    Is the SQL DBEngine discovered and do you see discovered databases on the server. I suspect you do as it seems to have discovered the Always On components but just want to check.

    Also have you enabled the Agent Proxy setting - Admininstration, Agent Managed, double click - security tab.

    Have you run through page 43 onwards from the guide:

    http://www.microsoft.com/en-us/download/details.aspx?id=10631

    Cheers

    Graham


    Regards Graham New System Center 2012 Blog! - http://www.systemcentersolutions.co.uk
    View OpsMgr tips and tricks at http://systemcentersolutions.wordpress.com/

    Thursday, January 24, 2013 4:49 PM
  • Hi there, some good info there thanks.  I am running through the creation of run as accounts.  One thing though, do I need to manually add teh account to AD and also grant it permission in SQL.  I assume I need to however it doesn't mention it that I can see in the blog post?

    To answer your other question yes the DBEngine is discovered.  I assume this is cause SYSTEM has public access so basic monitoring can happen.

    Friday, January 25, 2013 11:43 AM
  • Hello again

    I have run through the Blog.  I have added a Run As account and assigned it to the AlwaysOn profiles.  I have also made sure the Agent Proxy setting was on., however still nothing is appearing under AlwaysOn discovered in the inventory.

    I added the Run As account to AD and also granted it Admin access to the server and also SA access in SQL.

    Am a bit stuck again am afraid.

    Friday, January 25, 2013 1:54 PM
  • Has agent proxy been enabled on these two machines that you installed manually? Agent proxy usually helps a management pack work better. In the admin console tab, select Agent Managed, find one of the servers in the list right click on it, and go to properties, click the security tab, and make sure the check box is checked in the agent proxy screen is checked. click ok to save changes.

    Hope this helps.


    Scott Moss MVP (Operations Manager) President - System Center Virtual Users Group |Vice President - Atlanta Southeast Management Users Group (ATL SMUG)
    Please remember to click “Mark as Answer” on the post that helps you!
    my new blog om2012.wordpress.com

    Monday, January 28, 2013 5:45 PM
  • Hi - yes I had already applied that config.

    Thanks

    Tuesday, January 29, 2013 1:17 PM
  • Did anyone ever figure this out? I am running into something similar on my environment. DB and Agent are picked up, but nothing else.
    Thursday, March 21, 2013 6:45 PM
  • Make sure you follow all the requirements in the SQL MP Guide. Also note that Always On monitors do not generate alerts by default, you have to create an override to enable them.

    Hope that helps


    • Edited by stooney Friday, May 9, 2014 8:00 PM
    Friday, May 9, 2014 7:59 PM