none
Steady state unable to activate disk protection RRS feed

  • Question

  • Ok, I need something else to go on now.

    Thing is, we've been running with steady state here on 14 clients for about a year I'd say. Working fine, and using cmd line tool to activate and deactivate it across all clients.

    As in:
    Deactivate steady state disk protection.
    Install games, updates, drivers etc whatever needed at the time.
    Clean for temp files etc, defrag
    Clone the disk with Symantec ghost
    Activate steady state.

    About 3 weeks ago now, I did as mentioned above. Only thing I didn't get to do was the last reboot before cloning. I was just about to open the shop, so was in bit of a hurry, and wanted to save this last reboot in time. After the ghosting process when they booted back up I ran the cmd line tool for activating steady state disk protection. At first I just thought machines rebooted very quick, but later I realised that the cmd line tool had failed and disk protection hadn't enabled.

    It was a bit weird session with updating. It was primarely windows updates. Among those was the NET 3,5 package. As I recall, for some odd reason, this update failed among about 1/3 of the machines, had to reboot and start again etc. I then ran a tool called updateclean when everything was finally installed, wich removes the uinstall info etc for windows updates.

    Now the really really weird thing is that ONE client of the 14 is still able to enable disk protection as always. The rest fails. But the systems are alike, I can't find any diffence to the others. It's fully updated, and has had all the update info erased with the tools like all the other machines. Yet it still works here. The other 13 clients gives this error when trying to activate it via the programs GUI.
    screenshot
    The same error is displayed in the dos window when trying to run the cmd line tool (and no rebooting occurs)

    Now, what i've tried so far.

    I obv tried recreating the images that I had cloned. But unfortunately, these images contains whatever annoys steady state. Still it's only the one client, and the image for it that works.

    I've tried uninstalling steady state, reinstalling it and still it cannot activate disk protection.

    Today I tried using the remove NET package tool posted in another thread to totally remove NET, then reinstall it, but to no luck.

    At this moment, I can live with it, seing as I have these images I can just recreate all the time on the clients from when it all went wrong. But before my next updating/install round, I'd like to find out what triggered steady state from not working before I mess up the images/systems even more.

    Is there some way I, or someone who developed this software can drag out more info from my system other than the pretty unusefull info that "it was not successfull" some kind of log somewhere someone could analyze and see if there was specific reasoning for this error?

    If it's any help, the error msg in the GUI comes right after the window with a load bar that says "installing driver" is either done, or almost done.

    Friday, March 20, 2009 3:58 PM

Answers

All replies

  •  

    Hi OrosAraba, had you disabled WDP before making the image? Also, please let me know if you have tried the following steps on the 13 computers.

     

    Check disk:

    -------------------

    1. Click Start and then Run.

    2. Type in cmd and press Enter.

    3. Type in chkdsk and press Enter.

     

    Please check if there is error or bad block on the hard drive.

     

    When problem occurs, please also check if there is a cache file (Cache.WDP) under drive C: As the cache file was hidden by default, we need to show the hidden files with the following steps:

    -------------------

    1. Click Start, then click Control Panel, and then click Folder Options.

    2. Click the View tab. Under Hidden files and folders, click "Show hidden files and folders."

    3. Clear the "Hide protected operating system files (Recommended)" check box.

    4. Clear the "Hide extensions for known file type" check box. Click OK.

     

    If Cache.WDP exists, we can manually delete it with the following steps:

    -------------------

    1. Restart your computer and start pressing the F8 key on your keyboard.

    2. When the Windows Advanced Options menu appears, select Safe Mode, and then press Enter.

    3. Log onto Windows by using the Administrator account or any user account with the Administrator privileges.

    4. Delete the Cache.WDP file under drive C. Restart the computer.

    5. Start SteadyState, “Cache File Is Corrupted” windows will appear.

    6. Select “Uninstall Windows Disk Protection and delete the corrupted cache file” and click OK.

     

    After that, please check whether WDP can be enabled without error or not.  


    Sean Zhu - MSFT
    Monday, March 23, 2009 9:15 AM
    Moderator
  • Odd, I never got the email telling me someone answered my post. Anyway. Yes. WDP was disabled across all clients. I then started updating them, then cleaned them out flushing all temp stuff etc, lastly I ran the tool to remove all leftover data from windows updates. In fact, there was about 30-40 updates wich I flushed since it had been a short while since I did that last. So I cleaned some updates from previous updates also, not just ones I had done this round. The tool reported on attempt to remove some of those that it couldn't read the harddrive. I don't know hom commen that is, but again, it has to have done the same thing on the computer still working. The tool I used is this http://www.pc-shareware.com/update.htm

    Back to the issue at hand. After the updating and then cleaning. I proceeded to defrag the C drive. After that, I didn't do a final reboot as I would normally do, but proceeded to make the image using ghost starting the image process remotely. After the image had been created and the client was rebooted I then tried running the WDP enable from console command remotely. And this is where 13 failed, and only one proceeded to actually activate it. Rest stated in the DOSwindow that it was not successfull.

    Since then. I've tried some things. Everytime I tried something new, I made a fresh install from the ghost, because it seems that something gets messed up as soon as I try to enable WDP, as in, it seems the computer thinks it's activated, allthou it's not. For example, when I deploy the image I have of the clients at the moment. I can start defrag without problems. When I try to enable WDP just once, and it fails, defragging is no longer an option. It just doesn't start as if WDP is enabled and running. But what I've tried is the chkdisk on a fresh image, still it fails to activate WDP afterwards. I have tried chkdisk and defragging once more without luck. I have looked for the cache file and found nothing on the system. As mentioned I also tried running the remove NET 3.5 package as I was hoping that to be the culprit, and being the only thing from the updates I could uinstall as I have removed uinstall data for the other ones. (is there a better tool for flushing those update install packages?)

    Is there no way to debug what actually goes wrong in the process in any kind of log anywhere?
    Thursday, March 26, 2009 7:07 AM
  •  

    Hi OrosAraba, unfortunately, there is no such log file to troubleshoot WDP related issues. I suggest you check the detail steps in the following threads on how to make image and deploy Windows SteadyState with system:

     

    Successful Cloning Strategy - Zero Touch Installation

    http://social.microsoft.com/forums/en-US/windowssteadystate/thread/85c1a249-e530-4592-b3ba-cd9bc27e1b5c/  

     

    do you have to run sysprep when making an image

    http://social.microsoft.com/forums/en-US/windowssteadystate/thread/fd6943fd-bced-47d2-bf2a-3e79c1f1a786/

     


    Sean Zhu - MSFT
    Friday, March 27, 2009 3:34 AM
    Moderator
  • Ok, first post tells about doing this stuff remotely, as mentioned, I had already been doing this for about a year with no problems.
    The second post is about building new clients, cloning etc and then running steady state.
    As written, I had this environment up and running fine on my own for about a year when suddenly WDP couldn't be turned back on after a couple of windows updates, cleaning the trash from those and defragging the system drive. For some very odd reason, one computer does in fact still work, and I have not been able to either think of a reason, or find one with my eyes when comparing that machine to another that fails in the process of activating WDP. Those machines are in every way identical. Same OS, same hardware, same software. But apparantly one little thing is diff. wich I'm not able to figure out as of yet. The error msg "was not successfull" is really joyfull to work with, if only it could point me in some sort of direction what it is unhappy about on those machines it would be awesome. Cuss atm I'm searching for a needle in the haystack for some reason.

    It isn't able to activate WDP, neither from command line, or from the actual GUI. If I deploy my fresh image I can do all of the following. Defrag, run chkdsk, uinstall steady state completely, reinstall run chkdsk one more, defrag once more - but still activating WDP is not successfull. And no, there is no old imagefile on the system.

    I can only hit myself hard on the head that I managed to make a new image overwriting the old images that worked without problems before actually testing that WDP still worked. I know now if I ever get it running again, not to make a new image without testing it first. Even thou it will make the update-process that much longer activating it, then deactivating it before doing the new images. Allthou I'm very tempted to just put it behind me, and try some of the other software solutions out there doing the same job.
    Friday, March 27, 2009 1:19 PM
  • For shits and giggles, I tried taking the image of the one client that can still activate WDP, and deploy it to one of the other clients that refuses to start WDP. It was able to enable WDP just fine, so guess I can rule out it being hardware related (anything with the actual disk). Now I just gotta figure out what I left out on this one machine still working with WDP when updating, cuss apparantly I must have missed some part on it, compared to all the other machines.
    Friday, March 27, 2009 4:04 PM
  • Ok, guess I should just be happy I have one system of 14 still working. I'll now look into deploying that image to the other computers. Seing as they are all identical (or at least should be?) It's most likely just a few minor things I have to do to them. Change computername, email accounts etc. Hopefully that'll work. When trying to make another round of updating - with the flawed images not able to activate disk protection, I realised that some of the clients needed som NET language pack to 3.0 or something, wich they refused to properly install, so I'm just gonna go with the one image that works, and is fully updated. I cba finding the solution, from now I just know to test that the function still works before creating a new ghost image of the system.
    Friday, April 3, 2009 1:02 PM