Exchange 2010 ECP: Problem with Automatic Replies using OWA


  • Hi all,

    Got a strange problem here and struggling to find anyone who has had the same problem.

    Bit of background - running a simple Exchange 2010 server on one box, about 200 mailboxes. All working fine, using a wildcard certificate for access to OWA and autodiscover when using Outlook 2010 over HTTPS.

    The problem is on OWA when the user tries to set automatic replies. I understand this transfers them to the Exchange control panel. The problem is that the screen appears but then shows no options and the screen freezes. This is happening on all browsers, both XP and Win7Pro, on both internal and external PCs (Internal use a DNS to point to internal server IP). Even on the server itself if I try to go to the main ECP page. I am getting no error messages, permission messages/logons or any event IDs to report on. The only error is on the page itself and shows as:

    Message: 'EcpProfile' is undefined
    Line: 134
    Char: 5
    Code: 0
    URI: https://localhost/ecp/The problem started off as certain people getting the problem but now it seems to be everyone.

    I have tried 'Reset Virtual Directory' to no avail.

    Any help would be appreciated.


    Chris Snape

    Thursday, June 20, 2013 9:30 AM

All replies

  • You can check if there is any HTTP redirect on the ECP virtual directort. If it is then remove it.

    Don't Let go..

    Thursday, June 20, 2013 9:51 AM
  • No, all greyed out. Thanks.
    Thursday, June 20, 2013 11:28 AM
  • Seems to be the Web.Config file for ecp is having some problem. Do you have any other exchange 2010 server with same SP and RU to copy the web.config file and see if it clicks?

    Don't Let go..

    Thursday, June 20, 2013 12:10 PM
  • Unfortunately not.

    Are there any cmdlets I could run in powershell to help diagnose?

    Thursday, June 20, 2013 12:53 PM
  • Hello,

    I suggest you use EXBPA against your exchange server health.

    I suggest you use the test-servicehealth to check whether World Wide Web Publishing Service is started.

    Cara Chen
    TechNet Community Support

    Sunday, June 23, 2013 3:22 AM
  • Thanks for the advice, do you have a link for one that works with Exchange 2010? Th one I have jus downloaded gives me an unknown schema meaning that it doesn't recognise 2010.

    Tuesday, June 25, 2013 8:24 AM
  • Nevermind! I have just found it built into my EMC... Will run some tests and come back to you.

    Tuesday, June 25, 2013 1:56 PM
  • Ok, I ran the Best Practices Analyser on both the server directly and my domain workstation logged in as a Domain\Exchange Administrator.

    Both times the result was:

    Exchange server *** is down or unreachable. This could be the result of a network or permissions problem. Error: The network path was not found

    I then subsequently ran the Permissions Check (passed) and the Connectivity Test (Failed) with the following errors:

    WMI cannot be accessed

    Registry cannot be accessed

    Performance data cannot be accessed

    Any ideas?

    Tuesday, June 25, 2013 2:15 PM