locked
SCCM 2012 R2 Software Update deployment Query RRS feed

  • Question

  • Hello,

        Using my new SCCM 2012 R2 environment, I have created a collection (with only one win 2012 R2 Server) and a software update Group (there are 17 Critical & security updates for Win server 2012 R2).

    Some of the updates are already installed in client machine.

    I hve made this deployment yesterday night with the deadline asap and client local time.

    But till now (12 hours) I dont see any action on this deployment. its still showing under Unknown 

    I have checked Client local time, its perfectly matching with SCCM

    I refreshed the policies in client as well (by default 60 minutes)

    I Checked under monitoring tab all the site status are in Green and content status SMS_Client_config_manager and SMS_Inventory_Software_Processor are in warning state.

    Can someone help with the further proceedings?

    Wednesday, April 9, 2014 5:24 AM

Answers

  • 0x87d00692 = Group policy conflict
    So make sure that there are no conflicting GPOs (WUAHandler in place).

    Torsten Meringer | http://www.mssccmfaq.de

    • Marked as answer by Juliesmiley Thursday, April 10, 2014 12:46 PM
    Wednesday, April 9, 2014 9:26 AM
  • You might have wsus server points to server please check group policy settings.
    • Marked as answer by Juliesmiley Thursday, April 10, 2014 12:47 PM
    Wednesday, April 9, 2014 9:31 AM
  • Straight from the log above: "Group policy settings were overwritten by a higher authority (Domain Controller)"


    Jason | http://blog.configmgrftw.com

    • Marked as answer by Juliesmiley Thursday, April 10, 2014 12:46 PM
    Wednesday, April 9, 2014 5:00 PM

All replies

  • You might required to reinstall sccm 2012 client.
    Wednesday, April 9, 2014 5:39 AM
  • Was the ConfigMgr client installed on that server at all? Is it running (service: SMS Agent Host)? Do you see current timestamps in the lower part of the console when highlighting the server? Can you start Resource Explorer and does it display inventory data?

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, April 9, 2014 6:35 AM
  • I did the reinstallation from Console and refreshed the policy couple of times. (01 hour before)

    The client also in same subnet as my SCCM.

    Still now I don't see any progress on the same.

    Wednesday, April 9, 2014 6:44 AM
  • Please refer ccmsetup.log from the any client machine.and check is it successfully update or not.
    Wednesday, April 9, 2014 7:05 AM
  • Please answer the questions above.

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, April 9, 2014 7:08 AM
  • Torsten,

    I checked the Following things (Servers are in IST, Current time 09-04-2014 12:38)

    01. SMS agent host is running

    02. Policy request : 9th apr 2014 12:34

    Heratbeat DDR : 9th apr 2014 01:13

    Hardware SCAN: 9th apr 2014 01:13

    Software SCAN:  9th apr 2014 01:13

    03. Resource explorer showing data


    • Edited by Juliesmiley Wednesday, April 9, 2014 7:25 AM
    Wednesday, April 9, 2014 7:08 AM
  • Please check

    UpdatesDeployment.log


    UpdatesHandler.log

    from client machines.
    Wednesday, April 9, 2014 7:30 AM
  • Updates Handlers Log:

    No Errors are there

    01. Successfully initiated the SCAN

    02. Update scan completion received (date & time are recent)

    Updatesdeployment.log:

    few errors are there

    Job error received for assignment (latest time)

    Updates will not made available

    Wednesday, April 9, 2014 7:55 AM
  • Could you share those errors?
    Wednesday, April 9, 2014 8:15 AM
  • Yes please find the same.

    <![LOG[Message received: '<?xml version='1.0' ?><SoftwareUpdatesMessage MessageType='EvaluateAssignments'><UseCachedResults>False</UseCachedResults></SoftwareUpdatesMessage>']LOG]!><time="12:34:28.822-330" date="04-09-2014" component="UpdatesDeploymentAgent" context="" type="1" thread="3748" file="cdeploymentagent.cpp:189">
    <![LOG[Removing scan history to force non cached results]LOG]!><time="12:34:28.822-330" date="04-09-2014" component="UpdatesDeploymentAgent" context="" type="1" thread="3748" file="assignmentsmanager.cpp:1214">
    <![LOG[Assignment {DC0F7145-6AD5-435B-A9B6-AB9E82BEBCB8} has total CI = 17]LOG]!><time="12:34:28.868-330" date="04-09-2014" component="UpdatesDeploymentAgent" context="" type="1" thread="3748" file="updatesassignment.cpp:161">
    <![LOG[Detection job ({E2955DD6-417B-4F59-8B10-DCF5EFFB9546}) started for assignment ({DC0F7145-6AD5-435B-A9B6-AB9E82BEBCB8})]LOG]!><time="12:34:28.880-330" date="04-09-2014" component="UpdatesDeploymentAgent" context="" type="1" thread="3748" file="updatesassignment.cpp:1196">
    <![LOG[Started evaluation for assignment ({DC0F7145-6AD5-435B-A9B6-AB9E82BEBCB8})]LOG]!><time="12:34:28.882-330" date="04-09-2014" component="UpdatesDeploymentAgent" context="" type="1" thread="3748" file="updatesassignment.cpp:834">
    <![LOG[Evaluation initiated for (1) assignments.]LOG]!><time="12:34:28.882-330" date="04-09-2014" component="UpdatesDeploymentAgent" context="" type="1" thread="3748" file="assignmentsmanager.cpp:1105">
    <![LOG[Job error (0x87d00692) received for assignment ({DC0F7145-6AD5-435B-A9B6-AB9E82BEBCB8}) action]LOG]!><time="12:36:29.216-330" date="04-09-2014" component="UpdatesDeploymentAgent" context="" type="3" thread="3912" file="updatesassignment.cpp:2214">
    <![LOG[Updates will not be made available]LOG]!><time="12:36:29.217-330" date="04-09-2014" component="UpdatesDeploymentAgent" context="" type="2" thread="3912" file="updatesassignment.cpp:2216">

    Wednesday, April 9, 2014 8:48 AM
  • 0x87d00692 = Group policy conflict
    So make sure that there are no conflicting GPOs (WUAHandler in place).

    Torsten Meringer | http://www.mssccmfaq.de

    • Marked as answer by Juliesmiley Thursday, April 10, 2014 12:46 PM
    Wednesday, April 9, 2014 9:26 AM
  • You might have wsus server points to server please check group policy settings.
    • Marked as answer by Juliesmiley Thursday, April 10, 2014 12:47 PM
    Wednesday, April 9, 2014 9:31 AM
  • I chekced the Group policy, there is no rule defined for the machine

    I checked the local computer policy in that the WSUS has been correctly mentioned as http://SCCMSERVER:8530

    :) 

    Wednesday, April 9, 2014 1:35 PM
  • The error code though is exactly as Torsten says though. Have you reviewed wuahandler.log on the client?

    Jason | http://blog.configmgrftw.com

    Wednesday, April 9, 2014 1:47 PM
  • Yes, Error=0x80070002 is there.

    I understood it's a GPO conflict, but I donno how to resolve that because, i checked the local setting of windows update the URL was Right.

    I was tried to get the GPO which is causing this issue, but couldn't get any GPO with the windows update.

    I created a new GPO with this WSUS URL and enabled it.

    Still the issue persist :(

    Wednesday, April 9, 2014 2:13 PM
  • I have created new OU and moved the test machine to that OU and disabled all Group policy.

    Still the issue persist.

    Wednesday, April 9, 2014 3:03 PM
  • Well, given that we've asked you about wuahandler.log a couple of times, maybe you start by checking it and posting the relevant snippet?

    Jason | http://blog.configmgrftw.com

    Wednesday, April 9, 2014 3:52 PM
  • <![LOG[Its a WSUS Update Source type ({508E7B21-0DA1-4AED-B1FA-03AD7D9A49DD}), adding it.]LOG]!><time="20:13:20.083-330" date="04-09-2014" component="WUAHandler" context="" type="1" thread="2508" file="sourcemanager.cpp:1232">
    <![LOG[Unable to read existing resultant WUA policy. Error = 0x80070002.]LOG]!><time="20:13:20.083-330" date="04-09-2014" component="WUAHandler" context="" type="2" thread="2508" file="sourcemanager.cpp:920">
    <![LOG[Enabling WUA Managed server policy to use server: http://SCCM.ABC.in:8530]LOG]!><time="20:13:20.083-330" date="04-09-2014" component="WUAHandler" context="" type="1" thread="2508" file="sourcemanager.cpp:948">
    <![LOG[Waiting for 2 mins for Group Policy to notify of WUA policy change...]LOG]!><time="20:13:20.108-330" date="04-09-2014" component="WUAHandler" context="" type="1" thread="2508" file="sourcemanager.cpp:954">
    <![LOG[Timed out waiting for Group Policy notification.]LOG]!><time="20:15:20.109-330" date="04-09-2014" component="WUAHandler" context="" type="1" thread="2508" file="sourcemanager.cpp:95">
    <![LOG[Unable to read existing WUA resultant policy. Error = 0x80070002.]LOG]!><time="20:15:20.109-330" date="04-09-2014" component="WUAHandler" context="" type="2" thread="2508" file="sourcemanager.cpp:958">
    <![LOG[Group policy settings were overwritten by a higher authority (Domain Controller) to: Server  and Policy NOT CONFIGURED]LOG]!><time="20:15:20.112-330" date="04-09-2014" component="WUAHandler" context="" type="3" thread="2508" file="sourcemanager.cpp:1013">
    <![LOG[Failed to Add Update Source for WUAgent of type (2) and id ({508E7B21-0DA1-4AED-B1FA-03AD7D9A49DD}). Error = 0x87d00692.]LOG]!><time="20:15:20.113-330" date="04-09-2014" component="WUAHandler" context="" type="3" thread="2508" file="cwuahandler.cpp:2325">

    Please find the same.

    Wednesday, April 9, 2014 4:53 PM
  • Straight from the log above: "Group policy settings were overwritten by a higher authority (Domain Controller)"


    Jason | http://blog.configmgrftw.com

    • Marked as answer by Juliesmiley Thursday, April 10, 2014 12:46 PM
    Wednesday, April 9, 2014 5:00 PM