none
Resource Pool Issue RRS feed

  • Question

  • All,

    I'm having a major issue with using a my resource pool. In theory, when you open the resource pool and go to resource usage, it is showing that some of my resources are allocated to zero hours. If i open all of the individual projects that are linked to the resource pool, they will show that they are allocated. I was thinking maybe it was a corrupt file with one or two of the project files but here's where it get really confusing. It will show tasks allocated from every single project to the resources in my resource pool (meaning every project is showing up), but there are just certain resources that show as allocated for zero hours. Here's the other weird thing: If i close everything out and open up the resource pool again, it randomly chooses different resources to be allocated to zero hours, but the rest are fine. What could possibly be going on? I tried breaking the links to all of the projects, deleting the resource pool file, and re-linking all of them back together twice just to make sure I didn't do anything wrong. I'm still having the same issue. Any ideas?

    Monday, November 4, 2013 8:57 PM

All replies

  • What release of Project?  I'm guessing you are not using Project Server?  What service packs and/or cumulative updates are installed?
    Monday, November 4, 2013 11:04 PM
    Moderator
  • Microsoft Project 2013 15.0.4420.1017
    Wednesday, November 6, 2013 1:42 PM
  • Project Server?  Do the assignments show under the Resource's names in the Resource Usage view - but no hours?  I cannot reproduce what you report.  Have projects connected to the pool been moved or copied?  How many sharer files?
    Wednesday, November 6, 2013 2:37 PM
    Moderator
  • Please download and install the October 2013 cumulative update for Microsoft Project 2013 and check if it helps to resolve the issue. Other than that is the resource pool shared over the network, could latency be an issue.


    Sapna Shukla

    Wednesday, November 6, 2013 2:39 PM
    Moderator
  • No project server, but the files are stored on the shared network drive. No assignments or anything show up for 3 or 4 resources untill I open up the master file that has all of the project files as sub-projects. In other words, once I open the project it will only then show the true resource allocation.
    Wednesday, November 6, 2013 3:03 PM
  • Can you explain exactly what you mean by a latency issue? Do you mean the network could be slow right now? The files are stored on a shared network drive.
    Wednesday, November 6, 2013 3:05 PM
  • Then Network Latency could be an issue. Just for my clarity, I m asking this - you have a resource pool (shared over network) then you have a Master Project (with some sub-projects) , unless you open the Master Project you don't see the resource assignments for individual projects? Correct?

    Sapna Shukla

    Wednesday, November 6, 2013 3:07 PM
    Moderator
    • Yes, the resource pool along with the individual projects and the master project file, are stored on the shared network drive.
    • It shows most of them, but not all of them. That's what is weird about it. There are just a select resources that don't show any task assignments, thus showing 0 hours/% allocated. When I open the master file (I could open all of the projects indivudually and get the same result), only then can I see the true numbers. Does that make sense?
    • I've had it working for a long time and it worked flawlessly. When I tried to change the spelling of some the resource names, I started having issues. I'm wondering if this had something to do with it.
    Wednesday, November 6, 2013 3:29 PM
  • Changing resource names in the sharer file may be causing the issue depending upon your setting for whether the pool take precedence or the sharer file takes precedence.  I can duplicate what you report (resources with zero hours that I know are assigned to different tasks) when I have one of the files set as "Sharer takes precedence and change the name of the resource.  The renamed resource appears twice in the pool file - once under the original name (with zero hours) and once under the new name.

    If I then open one of the sharer files where the setting is "Pool takes precedence" assignments are switched back to the original resource and the second resource (renamed) shows up with only one assignment.

    Wednesday, November 6, 2013 3:47 PM
    Moderator
  • Interesting... Well I think we're getting closer to the culprit. I just broke the links from the resource pool to the sharer files and deleted the resource pool. I'm going to save the files locally, then delete the files and the folder they were stored in on the shared network drive, then create a new folder, move the individual files into that folder, create a new resource pool, and start try to link them again.

    Is there anything else I need to do to ensure the individual project files are "clean", so to speak? In other words, to make sure there will be no problems when sharing resources?


    Wednesday, November 6, 2013 4:16 PM
  • Just try this simple option if not done yet, before you proceed for anything - File -> Options -> Schedule -> Calculate Project after each edit - turn it ON. This will resolve 0 work hours for resources which are assigned on tasks.

    Sapna Shukla

    Wednesday, November 6, 2013 4:31 PM
    Moderator
  • Make sure before you re-create the pool file that all of the names are consistent.

    As you "Share resources" ensure all sharer files are set as "Pool takes precedence".

    All resource updates should be done through the pool with the pool open in full read/write mode with only the editor in the pool.

    Wednesday, November 6, 2013 4:35 PM
    Moderator
  • Ok thanks to both of you. I am in the process of re-structuring everything. I'll update you when I'm finished.
    Wednesday, November 6, 2013 5:50 PM
  • Great.  Let us know how you get along.
    Wednesday, November 6, 2013 5:53 PM
    Moderator
  • Just an update... I just spent the past two days rebuilding everything and I still have the same issue. I feel like I've tried everything so I'm not really sure what to do except to just open the master everytime. If I find the solution, I'll be sure to let you all know. Thanks for sticking with me on this.

    Friday, November 8, 2013 5:12 PM
  • Hi,

    I re-live this nightmare I had with Project 98 (!!!), exactly the same thing.

    Got out of the mess as follows:

    Correct your pool, save it UNDER A DIFFERENT NAME. Sounds ridiculous but that was the trick. Not just a different address, a different name.

    Then one by one connect the sharer files.

    Greetings,

    Friday, November 8, 2013 7:14 PM
    Moderator
  • Thanks for the reply,

    I have actually drawn this conclusion as well. There are so many little things that can cause anomalies of some sort, and I don't know that I'll ever stop finding them. So for anyone who is trying to do the same thing, I think it's most important to find a reliable way of backing up your files so that if corruption does occur, you won't have to go through this mess.

    Monday, November 11, 2013 3:56 PM