locked
Clients Not Installing After Upgrade RRS feed

  • Question

  • I recently took down my SCCM 2007 deployment (was just a single site) and did a fresh install (not migration) of SCCM 2012. I was told in this thread:

    http://social.technet.microsoft.com/Forums/en-us/configmanagermigration/thread/9da4e2ee-b586-43d2-b44e-24d06a9ed7ea

    that I wouldn't have to worry about the old clients. This does not seem to be the case, however. I have tried multiple times over the last few days to push out the client install to All Systems and to individuals. I have tried with and without the "Always Install" option. Nothing has taken except on the primary site and the SQL server.

    All the 2007 clients are still on our machines. I went in to one of them in control panel and noticed it was still showing the site code for my 2007 site. I tried putting in the new site code and hitting discover but that failed.

    I also checked the Systems Management container in ADSI edit and it looked like there was nothing hanging around from the 2007 deployment, there was only the stuff pertaining to my new 2012 deployment.

    Is there a way I can remove the old clients? I noticed they don't show up in Add/Remove programs. Or is there anything else I can do to get these client installs to take?'

    I also just noticed under Monitoring->Distribution Status->Content Status->There is a package called "Configuration Manager Client Upgrade Package" with a ID of SC100003. Now when I go to Software Library->Application Management->Packages there is only one package called "Configuration Manager Client Package" with an ID of SC100002.

    Where is SC100003? I havent been able to find any trace of it anywhere except where I first found it under Monitoring.  And yet in there I am unable to do anything with it as it is just monitoring! I dont even see the SC100002 when I right click a collection and go to Deploy Application or Program.

    I feel if I was just able to push SC100003 out to everything it would remove the old client and install the new one.

    Any help on removing old clients or finding my mystery package SC100003 would be much appreciated!


    • Edited by Sam Edson Tuesday, October 2, 2012 3:26 PM
    Tuesday, October 2, 2012 3:23 PM

Answers

  • Definitely access denied.

    By default, ConfigMgr uses the computer account of the site server. Using this is what I generally recommend because it eliminates having to manage another service-type account and is more secure also. Thus, you should add this account as a local admin of all of your target systems.

    If you want to manage another account (or already have one), you configure it in the console: http://technet.microsoft.com/en-us/library/gg712298.aspx (How to Install Configuration Manager Clients by Using Client Push -> To configure the site to automatically use client push for discovered computers)


    Jason | http://blog.configmgrftw.com

    • Marked as answer by Sam Edson Tuesday, October 2, 2012 7:16 PM
    Tuesday, October 2, 2012 4:55 PM

All replies

  • Have you reviewed ccm.log on the site server? It will explicitly tell you if the clients are reachable by the new site server and whether it is able to initiate the client setup.

    The 03 package is a hidden package, you can only really see it in the console if you go to the Monitoring workspace.


    Jason | http://blog.configmgrftw.com

    Tuesday, October 2, 2012 4:05 PM
  • Looks like its this:

    Received request: "2097152025" for machine name: "MOON" on queue: "Incoming".  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:01.389+240><thread=2792 (0xAE8)>
    Stored request "2097152025", machine name "MOON", in queue "Processing".  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:01.390+240><thread=2792 (0xAE8)>
    Execute query exec [sp_CP_SetPushRequestMachineStatus] 2097152025, 1~  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:01.391+240><thread=2792 (0xAE8)>
    ----- Started a new CCR processing thread. Thread ID is 0x19e8. There are now 1 processing threads  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.393+240><thread=2792 (0xAE8)>
    Submitted request successfully  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.397+240><thread=2792 (0xAE8)>
    Getting a new request from queue "Incoming" after 100 millisecond delay.  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.398+240><thread=2792 (0xAE8)>
    Waiting for change in directory "C:\Program Files\Microsoft Configuration Manager\inboxes\ccr.box" for queue "Incoming", (30 minute backup timeout).  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.398+240><thread=2792 (0xAE8)>
    ======>Begin Processing request: "2097152025", machine name: "MOON"  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.399+240><thread=6632 (0x19E8)>
    Execute query exec [sp_IsMPAvailable] N'SC1'~  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.400+240><thread=6632 (0x19E8)>
    ---> Trying each entry in the SMS Client Remote Installation account list~  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.402+240><thread=6632 (0x19E8)>
    ---> Warning: no remote client installation account found  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.402+240><thread=6632 (0x19E8)>
    ---> Attempting to connect to administrative share '\\MOON\admin$' using machine account.~  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.403+240><thread=6632 (0x19E8)>
    ---> Failed to connect to \\MOON\admin$ using machine account (5)  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.414+240><thread=6632 (0x19E8)>
    ---> ERROR: Failed to connect to the \\MOON\admin$ share using account 'Machine Account'  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.415+240><thread=6632 (0x19E8)>
    ---> Trying each entry in the SMS Client Remote Installation account list~  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.415+240><thread=6632 (0x19E8)>
    ---> Warning: no remote client installation account found  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.415+240><thread=6632 (0x19E8)>
    ---> Attempting to connect to administrative share '\\MOON.domain.com\admin$' using machine account.~  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.416+240><thread=6632 (0x19E8)>
    ---> Failed to connect to \\MOON.domain.com\admin$ using machine account (5)  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.426+240><thread=6632 (0x19E8)>
    ---> ERROR: Failed to connect to the \\MOON.domain.com\admin$ share using account 'Machine Account'  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.427+240><thread=6632 (0x19E8)>
    ---> Trying each entry in the SMS Client Remote Installation account list~  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.427+240><thread=6632 (0x19E8)>
    ---> Warning: no remote client installation account found  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.427+240><thread=6632 (0x19E8)>
    ---> Attempting to connect to administrative share '\\MOON\admin$' using machine account.~  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.427+240><thread=6632 (0x19E8)>
    ---> Failed to connect to \\MOON\admin$ using machine account (5)  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.435+240><thread=6632 (0x19E8)>
    ---> ERROR: Failed to connect to the \\MOON\admin$ share using account 'Machine Account'  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.436+240><thread=6632 (0x19E8)>
    ---> Trying each entry in the SMS Client Remote Installation account list~  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.436+240><thread=6632 (0x19E8)>
    ---> Warning: no remote client installation account found  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.437+240><thread=6632 (0x19E8)>
    ---> Attempting to connect to administrative share '\\192.168.1.70\admin$' using machine account.~  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.437+240><thread=6632 (0x19E8)>
    ---> Failed to connect to \\192.168.1.70\admin$ using machine account (5)  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.463+240><thread=6632 (0x19E8)>
    ---> ERROR: Failed to connect to the \\192.168.1.70\admin$ share using account 'Machine Account'  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.464+240><thread=6632 (0x19E8)>
    ---> ERROR: Unable to access target machine for request: "2097152025", machine name: "MOON",  access denied or invalid network path.  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.465+240><thread=6632 (0x19E8)>
    Execute query exec [sp_CP_SetLastErrorCode] 2097152025, 5~  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.466+240><thread=6632 (0x19E8)>
    Stored request "2097152025", machine name "MOON", in queue "Retry".  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.468+240><thread=6632 (0x19E8)>
    Execute query exec [sp_CP_SetPushRequestMachineStatus] 2097152025, 2~  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.469+240><thread=6632 (0x19E8)>
    Execute query exec [sp_CP_SetLatest] 2097152025, N'10/02/2012 16:14:03', 28~  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.472+240><thread=6632 (0x19E8)>
    <======End request: "2097152025", machine name: "MOON".  $$<SMS_CLIENT_CONFIG_MANAGER><10-02-2012 12:14:03.473+240><thread=6632 (0x19E8)>

    Looks like a permissions issue, although I haven't seen anywhere to set up for permissions for the "remote client installation account"

    Tuesday, October 2, 2012 4:21 PM
  • Definitely access denied.

    By default, ConfigMgr uses the computer account of the site server. Using this is what I generally recommend because it eliminates having to manage another service-type account and is more secure also. Thus, you should add this account as a local admin of all of your target systems.

    If you want to manage another account (or already have one), you configure it in the console: http://technet.microsoft.com/en-us/library/gg712298.aspx (How to Install Configuration Manager Clients by Using Client Push -> To configure the site to automatically use client push for discovered computers)


    Jason | http://blog.configmgrftw.com

    • Marked as answer by Sam Edson Tuesday, October 2, 2012 7:16 PM
    Tuesday, October 2, 2012 4:55 PM
  • Got it, thanks!
    Tuesday, October 2, 2012 7:17 PM