locked
FatalError: User cannot be found. (Importing a site) RRS feed

  • Question

  • I saw a similar thread that was posted two years ago but had no solution.  So I'm hoping someone now has an answer.  I'm importing a site and getting the FatalError: User cannot be found.  Here is a section of my import log.  Anyone have any suggestions or ideas???  I

    [7/21/2012 5:13:31 PM]: Progress: Importing Role Assignment for sites/Ops/Sped KPIs.
    [7/21/2012 5:13:32 PM]: Progress: Importing Role Assignment for sites/Ops/GAP.
    [7/21/2012 5:13:32 PM]: Progress: Importing Role Assignment for sites/Ops/Sped KPIs/HR KPI.xlsx.
    [7/21/2012 5:13:32 PM]: Progress: Importing Role Assignment for sites/Ops/Sped KPIs/Fin KPI.xlsx.
    [7/21/2012 5:13:32 PM]: FatalError: User cannot be found.
       at Microsoft.SharePoint.SPUserCollection.GetByID(Int32 id)
       at Microsoft.SharePoint.Deployment.WebSerializer.SetObjectData(Object obj, SerializationInfo info, StreamingContext context, ISurrogateSelector selector)
       at Microsoft.SharePoint.Deployment.XmlFormatter.ParseObject(Type objectType, Boolean isChildObject)
       at Microsoft.SharePoint.Deployment.XmlFormatter.DeserializeObject(Type objectType, Boolean isChildObject, DeploymentObject envelope)
       at Microsoft.SharePoint.Deployment.XmlFormatter.Deserialize(Stream serializationStream)
       at Microsoft.SharePoint.Deployment.ObjectSerializer.Deserialize(Stream serializationStream)
       at Microsoft.SharePoint.Deployment.ImportObjectManager.ProcessObject(XmlReader xmlReader)
       at Microsoft.SharePoint.Deployment.SPImport.DeserializeObjects()
       at Microsoft.SharePoint.Deployment.SPImport.Run()
    [7/21/2012 5:13:47 PM]: Progress: Import Completed.
    [7/21/2012 5:13:47 PM]: Finish Time: 7/21/2012 5:13:47 PM.
    [7/21/2012 5:13:47 PM]: Completed with 42 warnings.
    [7/21/2012 5:13:47 PM]: Completed with 1 errors.

    Tuesday, July 24, 2012 7:10 PM

All replies

  • Does anyone know the solution for this?

    I am experiencing the same issue whenever im trying to import a subsite to another site collection. I have also tried importing in the recovery server but "User cannot be found" error prompting the same.
    Wednesday, September 5, 2012 7:43 AM