locked
Mail sent from mobile device (Droid) converted to plain text. Why? RRS feed

  • Question

  • I am trying to add a company wide signature to all outgoing E-mails which I have working just fine, other than when the mail is originated on a mobile device.  It appears that when the mail is sent from an Android device (from an iPad works just fine), Exchange is converting it to plain text and then sending it on its way.  When it arrives at it's destination, it looks horrible.  Does anyone know why Exchange is doing this and what to do to correct it?
    - Exchange Server 2007 SP3
    - Using CodeTwo Exchange Server Rules for signatures (however with this turned off I get the same results).

    Thanks
    -Bryan

    Tuesday, January 31, 2012 6:22 PM

Answers

  • FINALLY RESOLVED!

    OK, I finally broke down and spent $279 and called Microsoft.  After spending a good part of 5 days with a tier 1 tech, I was finally given to tier 2 who solved it in about 10 minutes (sorry, I'm venting).  Here is what fixed it:

    The default domain content type was set to "MimeText".  We changed it to "MimeHtmlText" and now all html e-mail leaves my organization as html!

    Here is the command to see what yours is set to:   get-remotedomain | fl
    <Look for "ContentType">

    Here is the command to set it to the different content type:  set-remotedomain "default" -ContentType MimeHtmlText

    Here is an MS related article: http://technet.microsoft.com/en-us/library/aa997857.aspx

    Hope that this will help someone else.
    Thanks,
    -Bryan

    • Marked as answer by RunBMC Wednesday, March 28, 2012 5:05 PM
    Wednesday, March 28, 2012 5:04 PM

All replies

  • I think if it were exchange it should be doing the same for all mobile devices.  

    Does it only happen to the company wide signature and emails too?


    Where Technology Meets Talent
    Tuesday, January 31, 2012 7:11 PM
  • Yes, it happens to E-mail too.  I've taken the CodeTwo signature package out of the equation and just sent an html E-mail (with a smiley) and it does the same thing; converts it to plain text.  I agree with you that it is a little odd that it correctly handles the E-mail from an iPad, but not an Android device.  I'm going to try another Android device to see what it does.
    Tuesday, January 31, 2012 7:34 PM
  • I use myself an Android and didn't face this issue. 
    What version of Android. If you are using any version1.x then I'd expect his and you must upgrade it to 2.x versions. I have so many users with Android and never got this type of complain. I am very sure there is nothing wrong with your Exchange Setup. 
    Where Technology Meets Talent
    Tuesday, January 31, 2012 7:39 PM
  • Thanks for your responses btw!

    I'm using Android 2.3.4 on a Bionic.   I also just sent a test E-mail from a Droid X running 2.3.3 and same results.
    Anyone have anything to try or look at for me?

    edit:  I just tried a new iPhone 4s that I just got in today and it does the exact same thing. Which made me then try my iPad and it is doing it too.  So it doesn't seem to matter which device I use, they all do the same thing.

    • Edited by RunBMC Tuesday, January 31, 2012 8:20 PM
    Tuesday, January 31, 2012 7:55 PM
  • Hi,

    Please verify if the issue would occur when you send email via OWA or Outlook.

    Please try to download Windows Mobile Emulator and then test the issue again.

    Windows Mobile 6.1.4 Emulator Images

    http://www.microsoft.com/download/en/details.aspx?id=9263

    Besides, please try to remove the signature and then test the issue.

    You can try to send the email outside and inside both and then check the message header.

     


    Xiu Zhang

    TechNet Community Support

    Thursday, February 2, 2012 7:51 AM
  • Hi Xiu,
    Thanks for your response.    This issue does NOT happen when I send E-mail via OWA and Outlook.  I've already removed the signature and tested and it still sends the E-mail as plain text.  In fact, if I send the message through my Droid to an inside and outside address at the same time, it arrives in html format to my inside account, but plain text to my outside account.

    Does that make sense?
    Thanks,
    -Bryan

    Thursday, February 2, 2012 1:36 PM
  • Is it happening to a single user?

    Do you have more mobile devices configured for the ActiveSync?

    Can you if there is any ActiveSync Policy or made modification in the default policy?


    Where Technology Meets Talent
    Thursday, February 2, 2012 3:06 PM
  • Vim,
    Thanks again for trying to help me out on this, I really appreciate it (that doesn't get said enough in these forums).

    This is happening on the 3 or 4 accounts that I have tried it on.  It seems to happen on iPad, iPhone, Droid X and Droid Bionic as that is all that I've tested it on.

    I don't have an ActiveSync Policy in place other than the default, which has never been touched.  "Allow HTML formatted E-mail" is checked in the default policy.
    Thanks!

    -Bryan

    Thursday, February 2, 2012 4:12 PM
  • seems anything other Microsoft is having issue. did you try Windows Mobile Emulator, setup on of the problematic account on this emulator and see the results.  
    Where Technology Meets Talent
    Thursday, February 2, 2012 4:21 PM
  • I was hoping to avoid that, but I'll give it a try and let you all know.  Thanks!
    Thursday, February 2, 2012 4:34 PM
  • OK, I can't get the emulator to connect to my server at all.  I'm using the Windows Mobile 6.1.4 Standard Image and no luck.  No matter which server name/e-mail address I use, it says it can't connect.  Do we really think that the emulator is going to show us anything different?
    Thanks in advance!
    -Bryan


    EDIT:  I evidently have to install Virtual PC 2007 for this to work...this is becoming way too time intensive for something that I think is going to show the same results.  Thoughts?
    • Edited by RunBMC Thursday, February 2, 2012 5:11 PM
    Thursday, February 2, 2012 5:06 PM
  • OK, I can't get the emulator to connect to my server at all.  I'm using the Windows Mobile 6.1.4 Standard Image and no luck.  No matter which server name/e-mail address I use, it says it can't connect.  Do we really think that the emulator is going to show us anything different?
    Thanks in advance!
    -Bryan


    EDIT:  I evidently have to install Virtual PC 2007 for this to work...this is becoming way too time intensive for something that I think is going to show the same results.  Thoughts?


    Hi,

    We can narrow down the issue if we can use windows mobile emulator to send email and check the message body.

    For this issue, you can try to use other windows mobile series operation system to test the issue.

    Please ensure that you have "Allow HTML formatted e-mail " related configured on your mobile.

    Besides, I also recommend you to contact the mobile support to get more help.

    https://forums.motorola.com/pages/home

    http://www.motorola.com/staticfiles/Support/Support%20Homepage/Country-Selector/supportcountryselector.htm


    Xiu Zhang

    TechNet Community Support

    Monday, February 6, 2012 3:01 AM
  • Hi again Xiu,
    OK, I've installed the MS Virtual PC 2007, am connected to my network, however I cannot get my SSL certificates to play nicely.  I've been at this now for about 4 hours...

    I keep getting "The security certificate on the server is not valid" when using Activesync.   I have an SSL cert from Godaddy that expires in 2014.  I can get to OWA through the emulator's browser so it has to be the cert on the phone right?  I have a personal, intermediate and root certs installed.  What am I missing?

    Thanks in advance!
    -Bryan

    Friday, February 10, 2012 4:28 PM
  • Hi,

    Please try to get-exchangecertificate |fl name,services* to see if you have enable certificate on activesync.

    Please make sure that you have enable SSL on activesync virtual directory.

    By the way, is it a wildcard?


    Xiu Zhang

    TechNet Community Support

    Monday, February 13, 2012 5:21 AM
  • Thanks for hanging in there with me Xiu!   It is a UCC certificate if that is what you were referring to, not a wildcard, but the results of the get-exchangecertificate command yielded this, which doesn't look to include activesync:

    Services : IMAP, POP, UM, IIS, SMTP
    Services : UM

    However if I try setting up activesync on the phone without SSL, I get this:  "your account in microsoft exchange server does not have permission to synchronize with your current settings."  I believe this is an SSL issue.  I do have "Require SSL" on my activesync virtual directory.   So with that the case and not having enabled a cert on activesync, how are my other phones syncing?

    What do I do to resolve this and not break the production phones?

    Thanks!
    -Bryan

    Monday, February 13, 2012 5:45 PM
  • Hi,

    I find that you have enable certificate on IIS service. So if we have ticked "require SSL" on activesync VD, then the certificate is playing with your activesync service.

    Besides, what is the authentication on your activesync virtual direcotry? Basic or certificate based authentication?

    By the way, what is the result when you enable SSL on the phone?


    Xiu Zhang

    TechNet Community Support

    Wednesday, February 15, 2012 6:05 AM
  • Basic authentication on the activesync VD.   The result when I enable active sync is:

    "The security certificate on the server is not valid".   I have an SSL cert from Godaddy that expires in 2014.  I can get to OWA through the emulator's browser so it has to be the cert on the phone right?  I have a personal, intermediate and root certs installed on the phone.

    Wednesday, February 15, 2012 2:02 PM
  • Do you have anti virus installed on the server?

    "

    I am trying to add a company wide signature to all outgoing E-mails which I have working just fine, other than when the mail is originated on a mobile device.  It appears that when the mail is sent from an Android device (from an iPad works just fine), Exchange is converting it to plain text and then sending it on its way.  When it arrives at it's destination, it looks horrible.  Does anyone know why Exchange is doing this and what to do to correct it?
    - Exchange Server 2007 SP3
    - Using CodeTwo Exchange Server Rules for signatures (however with this turned off I get the same results).

    Thanks

    "


    Where Technology Meets Talent

    Wednesday, February 15, 2012 6:00 PM
  • Yes, Symantec Endpoint Protection and (more importantly) SMSMSE (Mail Security for Exchange).
    Wednesday, February 15, 2012 6:39 PM
  • is it possible for you to disable or remove that user and then you try. I believe it is your antivirus causing the issue.

    Where Technology Meets Talent

    Wednesday, February 15, 2012 7:42 PM
  • You may be on to something...I'll try to figure out a way to bypass our AV to see if that helps.  I'll let you know and thanks for the suggestion!
    -Bryan
    Wednesday, February 15, 2012 7:43 PM
  • Vim:
    Unfortunately, after disabling all Symantec products on my Exchange server (Mail Security/antispam/antivirus), E-mails send via my mobile device were still getting scrambled.

    Does anyone else have any ideas what would be causing this?
    Thanks!
    -Bryan
    Wednesday, February 29, 2012 6:47 PM
  • Bump.
    Tuesday, March 6, 2012 4:25 PM
  • Hey, I am having the same issue and have been working on it for hours now.

    My situation is exchange 2003 with codetwo exchange rules. My android's email is being received correctly (html with company logo), BUT three iphones and one other android's emails are being received in plain text. The issue does not happen when sending from outlook or browser based OWA. going to check my activesync policy now. I have question sent to codetwo about it. I cant figure out what the problem is. Watching this thread closely.

    Brian



    • Edited by bdscorvette Wednesday, March 7, 2012 12:09 AM
    Wednesday, March 7, 2012 12:03 AM
  • Hey Brian,

    Glad to have someone joining me!   I have worked with CodeTwo and this is what they concluded (and I think they are right):

    "Another thing is the email format. In the sample email you sent - Test 1 Droid - the signature is HTML format, while the email is Plain Text format. My theory is that when sending an email from your Droid device, it is sent in HTML format, as a result CodeTwo Exchange Rules 2007 adds an HTML signature, but somewhere on the way between your Exchange and the recipient's Inbox the email is converted to Plain Text, which ruins the signature.  Please check your server for any email suppressing format, or a third party application forcing emails to Plain Text format."

    So Brian, are you running any antivirus on your Exchange server?   I just can't figure out what would be converting my mail to plain text.  It is obviously going through an extra process to be sent outside my organization because like you said, it doesn't happen to mail sent within my organization from a mobile device.

    Let me know if you find anything out!
    -Bryan

    Wednesday, March 7, 2012 1:56 PM
  • Bryan,

    Here is what CodeTwo has told me: "CodeTwo Exchange Rules recognizes email format, and adds a consecutive signature - for example, if a mobile device send a Plain Text formatted email, a Plain Text signature will be added; for HTML emails - an HTML signature is applied. It works the same in the situation you are presenting - most probably your mobile devices are configured to send Plain Text emails. In order to change this, please modify the mobiles' settings."

    I Cannot change the message format on our devices (it is greyed out) and from what ive been finding reading is that it is because it is exchange 2003. Support for HTML through ActiveSync was added to exchange 2007, which doesnt explain why I am able to do it!! (my device is greyed out and wont let me switch it away from plain text either) In fact I am the only one able to do it here which leads me to belive it is partly device related. I wish there was another HTC Thunderbolt here (and same android version) so I could test that theory. Im just confused.

    You are on exchange 2007 which supposedly added the HTML support. Our situations may or may not be related. What is the message format on your devices? plain text or HTML? and is it greyed out?

    We do run Mcafee Endpoint Protection here. we also use Microsoft Forefront which is cloud spam filtering (our email gets routed through their servers) which may be a factor now that I think it through.

    I dont want to tell the boss we have to upgrade to Exchange 2007!! And then on top of that, it doesnt fix the issue!!!

    Brian

    Wednesday, March 7, 2012 6:19 PM
  • Brian,

    I can safely say that I can send html E-mails from any one of my devices, just so long as the E-mail stays within our organization.  Once it hits the outside world, it gets converted to plain text.   We run Microsoft Forefront Threat Management Gateway, but it just processes incoming mail and has nothing to do with outgoing mail.   So mail is being "sent" through activesync, is hitting my mail server and CodeTwo, where CodeTwo is seeing it as html.  After that, something (I'm assuming Exchange) is converting it to plain text on the way out.

    Yeah, I don't think upgrading to Exchange 2007 will help you, but it does offer support for html E-mail which 2003 activesync didn't do.   So that might be your problem, but can't say for sure!

    -Bryan

    Wednesday, March 7, 2012 6:46 PM
  • FINALLY RESOLVED!

    OK, I finally broke down and spent $279 and called Microsoft.  After spending a good part of 5 days with a tier 1 tech, I was finally given to tier 2 who solved it in about 10 minutes (sorry, I'm venting).  Here is what fixed it:

    The default domain content type was set to "MimeText".  We changed it to "MimeHtmlText" and now all html e-mail leaves my organization as html!

    Here is the command to see what yours is set to:   get-remotedomain | fl
    <Look for "ContentType">

    Here is the command to set it to the different content type:  set-remotedomain "default" -ContentType MimeHtmlText

    Here is an MS related article: http://technet.microsoft.com/en-us/library/aa997857.aspx

    Hope that this will help someone else.
    Thanks,
    -Bryan

    • Marked as answer by RunBMC Wednesday, March 28, 2012 5:05 PM
    Wednesday, March 28, 2012 5:04 PM
  • Thanks Brain.

    Running: set-remotedomain "default" -ContentType MimeHtmlText from the Exchange Management Shell resolved our issue!

    Sunday, March 10, 2013 4:40 PM
  • Our setting is set to MimeHtmlText and when we send a message from an Android device or Ios device the signature appears text based not HTML and all of the images are not there they show as links.

    our custom signature looks great via Outlook :-( Any advice so we can use the transport rule 


    Jessica Cochran

    Thursday, November 14, 2013 3:17 PM
  • Similar to lzbit2011, our setting is set to MimeHtmlText as well.  Signatures show up as the HTML format when Email is generated from Android devices, both internally and externally.   Signatures show up as plain text when sent from iOS devices, both internally and externally.   Has everyone given up on this thread?   
    • Proposed as answer by Rick Rood Friday, December 27, 2013 8:33 PM
    • Unproposed as answer by Rick Rood Friday, December 27, 2013 8:33 PM
    Friday, December 27, 2013 7:57 PM
  • Actually, this is what fixed the issue for us:

    "We are facing the same issue.  We have a transport rule that grabs the user's info out of Active Directory and populates the fields we tell it to and then adds an image of our company logo at the bottom.  We have looked at how other companies have done it and it seems like they are attaching several images to each message.  I would rather avoid that kind of overhead.

    The signature works fine in Outlook, but when Apple users send a message, the link for the image shows up as a link instead of the image.  If you use any html formatting in the email, it gets sent as html and the signature shows up fine.  I tested this by just changing some text to bold.  Several of our execs use iPhones and Macs and asking them to do this just to 'trick' it into html format isn't going to work."

    "I know this is an old thread but I've got the same issue with my Exchange system. Your comment solved it for me. We simply bold the signature in the iPhone Mail preferences. This causes the iPhone to send every message as rich text automatically and the Exchange system then attaches the disclaimer in full html format with logo and text formatting the same as the desktop machines."

     

    It's a little bit of a pain at first to get everyone to change their signature in the iPhone but after that, all corporate email sent via the iPhones has the same look to the Exchange disclaimer.

    • Proposed as answer by Rick Rood Friday, December 27, 2013 8:37 PM
    Friday, December 27, 2013 8:37 PM
  • Worked like a charm. We had a a legacy group policy rule from 2007 that the carried over the setting.
    Friday, September 23, 2016 7:09 PM
  • Thanks a lot for this fix.  It resolved my issues with using Code Two Pro for exchange 2010!
    Monday, March 27, 2017 5:41 PM