locked
Language Features Fail To Install RRS feed

  • Question

  • I for the life of me can't figure out why users are unable to install additional language features (basic typing, hand writing, and speech)

    They start to download then just fail. I checked WSUS and within Products and classifications > Windows I have Win 10 language packs and language interface packs selected.

    Within Event viewer I get this - 

    Fault bucket , type 0
    Event Name: CbsPackageServicingFailure2
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: 10.0.17134.1
    P2: Microsoft-Windows-LanguageFeatures-Basic-de-de-Package
    P3: 10.0.17134.1
    P4: amd64
    P5: unknown
    P6: 800f0954
    P7: CBS Other
    P8: Absent
    P9: Absent
    P10: FodHelper(LanguageFeaturesOnDemand)

    Event ID 1001

    I have tried approving German language options however nothing seems to work. If I manually do this on a machine the downloads work fine

    Regkey

    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU 

    UseWUServer 

     

    Change vlaue to 0 

      

    cmd 

    net stop wuauserv 

    net start wuauserv 

    The download works fine. 

    Am I missing something obvious here?

    Friday, August 10, 2018 9:34 AM

All replies

  • Hi,

    To avoid any misunderstanding, I want to confirm with you that you can synchronize and download the language packs in WSUS. But when you approve them to the clients, the clients show download failed.

    When you download other kind of updates, is this problem solved?

    If yes, please check the MIME Types in IIS:


    In addition, you could turn off the firewall temporary. You can also find error report in the WindowsUpdate log.  

    Best regards,
    Johnson

    =====================
    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.
    • Edited by Johnson ZDH Monday, August 13, 2018 4:45 AM
    Monday, August 13, 2018 4:43 AM
  • Your summary of the issue is correct.

    I have checked the MIME Types and the entry example you have given is there. I don't think it was a firewall issue as everything else works fine. It is just this item however I can look into that.

    This is the information from the log

    2018.08.13 10:20:19.1492881 10664 12200 ComApi          * START *   Federated Search ClientId = TrustedInstaller FOD (cV: 3ZGbFsGNl0yuNsXE.3.1.0)
    2018.08.13 10:20:19.1513942 8572  2240  IdleTimer       WU operation (SR.TrustedInstaller FOD ID 11) started; operation # 65; does use network; is not at background priority
    2018.08.13 10:20:19.1518787 8572  12500 Agent           *FAILED* [80240007] Method failed [CAgentServiceManager::GetTargetedServiceMapping:3010]
    2018.08.13 10:20:19.1782893 8572  12500 IdleTimer       WU operation (SR.TrustedInstaller FOD ID 11, operation # 65) stopped; does use network; is not at background priority
    2018.08.13 10:20:19.1844971 10664 10644 ComApi          Federated Search: Starting search against 1 service(s) (cV = 3ZGbFsGNl0yuNsXE.3.1.0)
    2018.08.13 10:20:19.1846965 10664 10644 ComApi          * START *   Search ClientId = TrustedInstaller FOD, ServiceId = 3DA21691-E39D-4DA6-8A4B-B43877BCB1B7, Flags: 0X80010010 (cV = 3ZGbFsGNl0yuNsXE.3.1.0.0)
    2018.08.13 10:20:19.1863952 8572  2240  IdleTimer       WU operation (CSearchCall::Init ID 12) started; operation # 68; does use network; is not at background priority
    2018.08.13 10:20:19.2507045 8572  2240  Agent           * START * Queueing Finding updates [CallerId = TrustedInstaller FOD  Id = 12]
    2018.08.13 10:20:19.2507154 8572  2240  Agent           Removing service 3DA21691-E39D-4DA6-8A4B-B43877BCB1B7 from sequential scan list
    2018.08.13 10:20:19.2507241 8572  2240  Agent           Service 3DA21691-E39D-4DA6-8A4B-B43877BCB1B7 is not in sequential scan list
    2018.08.13 10:20:19.2507320 8572  2240  Agent           Added service 3DA21691-E39D-4DA6-8A4B-B43877BCB1B7 to sequential scan list
    2018.08.13 10:20:19.2511032 8572  12276 Agent           Service 3DA21691-E39D-4DA6-8A4B-B43877BCB1B7 is in sequential scan list
    2018.08.13 10:20:19.2749097 8572  14612 Agent           * END * Queueing Finding updates [CallerId = TrustedInstaller FOD  Id = 12]
    2018.08.13 10:20:19.3053371 8572  14612 Agent           * START * Finding updates CallerId = TrustedInstaller FOD  Id = 12 (cV = 3ZGbFsGNl0yuNsXE.3.1.0.0.2)
    2018.08.13 10:20:19.3053439 8572  14612 Agent           Online = Yes; Interactive = Yes; AllowCachedResults = No; Ignore download priority = No
    2018.08.13 10:20:19.3053477 8572  14612 Agent           Criteria = (Product='Client.OS.rs2.amd64' and CurrentVersionOnly=1)""
    2018.08.13 10:20:19.3053545 8572  14612 Agent           ServiceID = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7} Managed
    2018.08.13 10:20:19.3053567 8572  14612 Agent           Search Scope = {Machine}
    2018.08.13 10:20:19.3053639 8572  14612 Agent           Caller SID for Applicability: S-1-5-18
    2018.08.13 10:20:19.3745073 8572  14612 Misc            Got WSUS Client/Server URL: http://wsus.address.com/ClientWebService/client.asmx""
    2018.08.13 10:20:19.5841366 8572  14612 ProtocolTalker  ServiceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL = http://wsus.address.com/ClientWebService/client.asmx
    2018.08.13 10:20:19.5841563 8572  14612 ProtocolTalker  OK to reuse existing configuration
    2018.08.13 10:20:19.5841627 8572  14612 ProtocolTalker  Existing cookie is valid, just use it
    2018.08.13 10:20:19.5841657 8572  14612 ProtocolTalker  PTInfo: Server requested registration
    2018.08.13 10:20:23.5476997 8572  14612 IdleTimer       WU operation (CAgentProtocolTalker::SyncUpdates_WithRecover) started; operation # 69; does use network; is at background priority
    2018.08.13 10:20:23.5477461 8572  14612 WebServices     Auto proxy settings for this web service call.
    2018.08.13 10:20:23.5831394 8572  14612 IdleTimer       WU operation (CAgentProtocolTalker::SyncUpdates_WithRecover, operation # 69) stopped; does use network; is at background priority
    2018.08.13 10:20:23.6888859 8572  14612 ProtocolTalker  Skipping driver sync because system spec is not available.
    2018.08.13 10:20:23.6888912 8572  14612 ProtocolTalker  SyncUpdates round trips: 1
    2018.08.13 10:20:35.4097549 8572  14612 Agent           Found 0 updates and 95 categories in search; evaluated appl. rules of 882 out of 2184 deployed entities
    2018.08.13 10:20:35.4941284 8572  14612 Agent           * END * Finding updates CallerId = TrustedInstaller FOD, Id = 12, Exit code = 0x00000000 (cV = 3ZGbFsGNl0yuNsXE.3.1.0.0.2)
    2018.08.13 10:20:35.4968247 8572  14612 IdleTimer       WU operation (CSearchCall::Init ID 12, operation # 68) stopped; does use network; is not at background priority
    2018.08.13 10:20:35.4973190 10664 9684  ComApi          *RESUMED*   Search ClientId = TrustedInstaller FOD, ServiceId = 3DA21691-E39D-4DA6-8A4B-B43877BCB1B7 (cV = 3ZGbFsGNl0yuNsXE.3.1.0.0)

    Monday, August 13, 2018 8:54 AM
  • Hi,

    Have you tried the methods in the following articles:
    https://www.coopoint.com/library/update-error/0x80240007

    In addition, if you install other updates in the clients, does it work fine.

    Regards,
    Johnson

    =====================
    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.
    Tuesday, August 14, 2018 8:26 AM
  • I have, and I don't think those apply to my situation. The WSUS server doesn't have to go through a firewall to talk to the clients and the windows firewall on the server is turned off. 

    All other windows updates work fine via WSUS. It is only somethings that seem to not to be able to communicate. The additional language features downloads (picture of what I mean attached) and for example if you download .netframe work 3.5 and try to install that will fail when the application calls out to the internet. Adjusting the registry as I posted before allows access. 

    As shown here in this example it just hangs on download then stops

    Tuesday, August 14, 2018 11:50 AM
  • Hi,

    Thanks for your information.

    In my own lab, I download fine of the language in the client. Based on the problem, I will search more information for it and re-display the issue in the test lab.  

    Best regards,
    Johnson
    Wednesday, August 15, 2018 8:53 AM