locked
2 SIP-trunks on dedicated Mediation RRS feed

  • Question

  • Hi!

    I got a question from a customer running Lync 2013 with dedicated Mediation server. They have deployed a new SIP-trunk in addition to existing and working SIP-trunk.

    They now get calls in and out. Incomming calls from cell to SIP-number works with audio both way. Outgoing calls from SfB to cellphone give audio from cell to SfB-klient, but no audio from SfB to Cell.

    What can cause this? 

    I see that the two trunks have been defined with two separate NICs and IP-addresses, but I also see that the Trunks are defined with the same ports in Topology. Could this be the problem?

    Sunday, May 12, 2019 12:50 AM

Answers

  • Hi Eirik81,

    A Mediation Server can have multiple trunks to the same gateway, however, for each trunk you have to specify a certain port to send and receive the SIP and Media traffic on.

    For your issue, I suggest you could try to re-define the ports in the Lync Topology Builder. In addition, Mediation server uses ports 60,000 – 65,536 (UDP) for the audio traffic, please make sure to open firewall ports 60,000 – 65,536 between the Mediation server and the PBX. You could also refer to the following blog to find the details: Skype for Business 2015 – Skype for Business 2015 Mediation server SIP Trunk Ports

    Best Regards,
    Evan Jiang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Proposed as answer by woshixiaobai Tuesday, May 14, 2019 5:44 AM
    • Marked as answer by Eirik81 Thursday, May 23, 2019 2:11 PM
    Monday, May 13, 2019 2:23 AM
  • Hi,

    The problem was that the telco had given me the SBC-address 77.xx.xx.57 as my gateway so I had the Persistent Route set that way, but when I saw the Wireshark-trace it wantet to communicate with 77.xx.xx.55, which the Telco later said was their mediation-server. 

    When I put in a Persistent Route to this address everything started working. 

    Thank you for your time. 

    Brg.

    Eirik 

    • Proposed as answer by woshixiaobai Thursday, May 23, 2019 6:36 AM
    • Marked as answer by Eirik81 Thursday, May 23, 2019 2:11 PM
    Wednesday, May 22, 2019 12:27 PM

All replies

  • Hi Eirik81,

    A Mediation Server can have multiple trunks to the same gateway, however, for each trunk you have to specify a certain port to send and receive the SIP and Media traffic on.

    For your issue, I suggest you could try to re-define the ports in the Lync Topology Builder. In addition, Mediation server uses ports 60,000 – 65,536 (UDP) for the audio traffic, please make sure to open firewall ports 60,000 – 65,536 between the Mediation server and the PBX. You could also refer to the following blog to find the details: Skype for Business 2015 – Skype for Business 2015 Mediation server SIP Trunk Ports

    Best Regards,
    Evan Jiang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Proposed as answer by woshixiaobai Tuesday, May 14, 2019 5:44 AM
    • Marked as answer by Eirik81 Thursday, May 23, 2019 2:11 PM
    Monday, May 13, 2019 2:23 AM
  • Hi Evan!

    Thanks for taking the time to answer my question. 

    You say I have to have different ports both for sending and receiving, but the SIP-trunk provider says it only can be connected on port 5060 on their end. What is the difference between the "listening port" and "Mediation server port" ?

    Tuesday, May 14, 2019 7:22 AM
  • Hi Eirik81,

    With multiple trunk support in Skype for Business Server, you can define multiple SIP signaling ports on the Mediation Server for communication with multiple PSTN gateways.

    When defining a trunk, the Associated Mediation Server port must be within the range of the listening ports for the respective protocol allowed by the Mediation Server. This port range is defined under Skype for Business Server and Mediation Pools. Right-click the Mediation Server pool of interest, and select Edit Properties. Specify the port range in the Listening ports field.

    As I said, for each trunk you have to specify a certain port to send and receive the SIP and Media traffic on. Please double confirm with your provider about this. You could also refer to the similar case

    Best Regards,
    Evan Jiang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, May 16, 2019 7:08 AM
  • Hi Eirik81,

    Is there any update for this issue? If the reply is helpful to you, please try to mark it as an answer, it will help others who have the similar issue.

    Best Regards,
    Evan Jiang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, May 17, 2019 3:00 AM
  • Thanks, I checked with my operator and they have now set the trunk to 5066. I have now changed in the Topology. I call incoming calls ok, but when I try outbound I get a 503 error. "Gateway did not respond in a timely manner (timeout)"

    Do the mediation or FE need a reboot to take the new port or what am I missing?

    Monday, May 20, 2019 9:53 AM
  • Hi Eirik81,

    Usually you do not need to restart the FE Server. After you change the settings in the Topology Builder, you need to run the Step 2 in the SFB Server Deployment Wizard.

    In addition, if you have checked everything and could not find the reason, I suggest you could try to use SFB Debugging tools to collect the logs, then analysis the log. 

    Best Regards,
    Evan Jiang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, May 22, 2019 7:25 AM
  • Hi,

    The problem was that the telco had given me the SBC-address 77.xx.xx.57 as my gateway so I had the Persistent Route set that way, but when I saw the Wireshark-trace it wantet to communicate with 77.xx.xx.55, which the Telco later said was their mediation-server. 

    When I put in a Persistent Route to this address everything started working. 

    Thank you for your time. 

    Brg.

    Eirik 

    • Proposed as answer by woshixiaobai Thursday, May 23, 2019 6:36 AM
    • Marked as answer by Eirik81 Thursday, May 23, 2019 2:11 PM
    Wednesday, May 22, 2019 12:27 PM
  • Hi Eirik81,

    Thanks for your sharing, we are glad to see your issue has been fixed. In addition, please try to mark your reply as answer, it will help others who have the similar issue. 


    Best Regards,
    Evan Jiang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, May 23, 2019 6:37 AM