locked
High update failure rate between 96 & 99 percent RRS feed

  • Question

  •  Hello all,

    A few weeks ago I stood up a WSUS server.  We have around 3000 machines in our environment.  They are a mix of windows 7 and windows 8.  I am currently only targeting workstations and not server.  After enabling updates a few days ago the machines have been happily humming along installing updates.  I check the status today and noticed that 2900ish out of the 3000 workstation are sitting at 96-99 percent patched.  They are all showing that between 3 and 300 updates failed to install.  I have tried updating from a work station itself and it also fails with error 80070570.  I am pretty new to WSUS so I am hoping someone can tell me where to start troubleshooting this issue.  

    Thanks!

    Thursday, February 11, 2016 4:00 PM

All replies

  • If it is an issue client-side, follow this article to troubleshoot. https://support.microsoft.com/en-us/kb/971058

    If you feel that the issue is with the update on the WSUS server, run wsusutil reset on the WSUS server. Which will scan your content folder check for missing packages/corruption and re-download accordingly. 

    Thursday, February 11, 2016 4:11 PM
  • If it is an issue client-side, follow this article to troubleshoot.  the issue is with the update on the WSUS server, run wsusutil reset on the WSUS server. Which will scan your content folder check for missing packages/corruption and re-download accordingly. 

    Thanks for the information!  I tried both of your suggestions and got the following results.

     

    Server suggestion - Doesn't seems to have made a difference.

    Workstation suggestion- Found 4 problems 1 - Service registration missing or corrupt - Not fixed.  2- Windows update errors 0x8070057 (2916-02-11-T-12_45_07p) - Not fixed. 3 - Problems installing recent updates - Fixed, 4 - Problems installing recent updates - Fixed.

     

    Now instead of hanging at 0 when the machine goes to download the updates and then failing it actually downloads them but then fails with the same error code.

    Any other ideas?

    Thursday, February 11, 2016 7:31 PM
  • In my link before, did you preform step 4? Force rename of SoftwareDistribution folder? Did you Reset BITS and WindowsUpdate service?
    Thursday, February 11, 2016 8:24 PM