none
Hyper-V Doesn't Work After Upgrade to Windows 10 1809

    Question

  • Hi everybody, 

    I recently updated my Windows 10 system to the 1809 October Update; everything appears to work well and even a bit faster. Everything, that is, except for Hyper-V. I am running Windows 10 Enterprise. 

    Previously, Hyper-V was perfectly functional and I used it to run Docker Engine and develop on this system. The system is more than capable of running Hyper-V and it exceeds the minimum requirements including virtualization on the processors and BIOS. 

    I have tried just about everything I can think of to enable Hyper-V including installing/reinstalling it multiple times from both the Windows Features app, PowerShell, and DISM. Additionally, I have done the MOFCOMP recompile and eliminated extra adapters that weren't being used in the registry. Absolutely none of these things have had any impact on whether or not it runs. 

    Looking at the logs, none of the required services are running. When I try to enable them manually, the Virtua Machine Management Service starts for a bit, then silently stops. The error when using Hyper-V Manager is to check that exact service because it cannot access any objects through it. See below; 

    I am unsure exactly what is going on; as I have cleaned the Windows 10 update cache and tried everything to bootstrap a working install of Hyper-V short of refreshing the entire Windows 10 install (which I am not going to do). I use Hyper-V and Docker for development purposes and I do enjoy the latest update to Windows 10. Did anybody else run into this problem and is there a repeatable, reliable, and robust way to fix this? What causes it?

    Thanks for the help in advance.

    Thursday, October 4, 2018 4:49 AM

Answers

  • I had the same problem and managed to solve it by doing the following.

    1, Open "Window Security"

    2, Open "App & Browser control"

    3, Click "Exploit protection settings" at the bottom

    4, Switch to "Program settings" tab

    5, Locate "C:\WINDOWS\System32\vmcompute.exe" in the list and expand it

    6, Click "Edit"

    7, Scroll down to "Code flow guard (CFG)" and uncheck "Override system settings"

    8, Start vmcompute from powershell "net start vmcompute"

    Thursday, October 4, 2018 9:18 AM

All replies

  • I had the same problem and managed to solve it by doing the following.

    1, Open "Window Security"

    2, Open "App & Browser control"

    3, Click "Exploit protection settings" at the bottom

    4, Switch to "Program settings" tab

    5, Locate "C:\WINDOWS\System32\vmcompute.exe" in the list and expand it

    6, Click "Edit"

    7, Scroll down to "Code flow guard (CFG)" and uncheck "Override system settings"

    8, Start vmcompute from powershell "net start vmcompute"

    Thursday, October 4, 2018 9:18 AM
  • Thank you for this.  I had the exact same issue. Wonder why this got configured after the update?
    Thursday, October 4, 2018 2:52 PM
  • Wonderful! Thanks for figuring it out and posting this solution. Worked for me!
    Thursday, October 4, 2018 4:02 PM
  • excellent, it worked for me too.
    Thursday, October 4, 2018 5:33 PM
  • I had the same problem and managed to solve it by doing the following.

    1, Open "Window Security"

    2, Open "App & Browser control"

    3, Click "Exploit protection settings" at the bottom

    4, Switch to "Program settings" tab

    5, Locate "C:\WINDOWS\System32\vmcompute.exe" in the list and expand it

    6, Click "Edit"

    7, Scroll down to "Code flow guard (CFG)" and uncheck "Override system settings"

    8, Start vmcompute from powershell "net start vmcompute"

    Thanks, this fixed the problem! I was 95% of the way there....I saw in the logs a bunch of MSR Access Violations that *something* was stopping the Hyper-V process instructions. It is very strange to me that CFG blocked C:\WINDOWS\System32\vmcompute.exe almost exclusively; I would think that heuristics would except and exclude any Microsoft signed and originated process, even/especially if it performs with hypervisor-required privileges; but perhaps they are being extra cautious or the newly updated Windows Security code is being aggressive. 

    I will add one thing, though; I also turned off the CFG block on C:\WINDOWS\System32\vmwp.exe in the same list in addition to vmcompute. I didn't do a regression with only vmcompute unblocked, but it seemed safer to unblock both at the same time. Just an FYI if that helps anybody further. 


    Thursday, October 4, 2018 6:47 PM
  • Thanks for this it worked for me! Just note that i had to reboot after changing this setting.
    Monday, October 8, 2018 6:20 AM
  • Anders,

    very helpful, thanks

    Tuesday, October 9, 2018 12:51 PM
  • Thanks Anders, fixed it for me too!

    Next step for us: trying to automate the solution for the colleagues... :)

    Wednesday, October 10, 2018 8:47 AM
  • The solution worked for me on Win 10 1809 and 2019 servers running Hyper-V. Digging into it a bit further, CFG is having issues with particular files not recognized by Windows. In my case it was from the antivirus program. Specifically Symantec Endpoint Protection 14.0 RU1 MP2. Upgrading to Symantec 14.2 build 760 fixes the issue without turning off CFG.
    • Proposed as answer by JosephIzang Wednesday, February 20, 2019 12:42 PM
    Thursday, October 11, 2018 1:37 AM
  • My VMS dont start also or can install fresh ones it crashes on final step of starting services, event viewer shows

    'New Virtual Machine' was reset because an unrecoverable error occurred on a virtual processor that caused a triple fault. If the problem persists, contact Product Support. (Virtual machine ID 2DB4DB2B-5853-4E0B-AF6A-964A68F67446)

    I tried all above suggestions and nothin is helping, thanks again microsoft for breaking even the most basic features.

    Tuesday, October 23, 2018 9:43 AM
  • HI Andres,

    This fixed the issue, Just curious, How did you figure Control Flow Guard was the culprit ?

    Thursday, October 25, 2018 2:45 PM
  • Would you or someone else that is still reproducing the problem be willing to collect some logs for us to be able to investigate. We cannot reproduce this in house.

    The steps to collect the logs are located here: https://github.com/MicrosoftDocs/Virtualization-Documentation/tree/live/hyperv-tools/HyperVLogs

    Once you have the logs you can ping warrenw @ microsoft . com and we can arrange to get tlogs from you

    Warren


    Wednesday, November 7, 2018 10:45 PM
  • This post saved me many hours of frustration!  Thank you so much Anders!
    Tuesday, December 18, 2018 8:07 PM
  • very good solution, it worked for me.
    Tuesday, January 8, 2019 3:25 PM
  • Worked for me too - I had to also restart Hyper-V Virtual Machine Management Service. I have worked on this in 5 hours. Thank you so much for <g class="gr_ gr_47 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar multiReplace" data-gr-id="47" id="47">the help</g>.

    Saturday, February 9, 2019 4:50 AM
  • Thanks it worked for me too!
    Sunday, February 10, 2019 6:54 PM
  • For a Fix for ICS doesn't work after Host computer or service restart on Windows 10 to support Hyper-V upon Reboot of Host, VM won't connect, unless ICS disabled and re-enabled with External Switch again, please google "windows support 4055559". I was not able to post the URL here until my account is validated.

    The fix is still applicable for Win 10 1809.


    Friday, February 15, 2019 1:53 AM
  • I did exactly that. Upgraded my antivirus and hyper v started purring like a cat. Thank you
    Wednesday, February 20, 2019 12:43 PM
  • Thanks buddy its working.
    Monday, February 25, 2019 9:13 AM
  • FYI this workaround was successful in my case however after installing February 2019 updates (KB4487044, KB4483452, KB4487044) it failed again. It is also possible that it failed after installing npcap.

    I found that the machine was not listening on port 2179, so may be a different issue to this thread but posting my resolution here in case it helps others.

    Resolution:

    1. netstat -ano | find "2179" shows no listeners
    2. Open Virtual Switch Manager
    3. Select the virtual switch being used by my VMs
    4. Change the connection type and OK
    5. Change it back again and OK
    6. Restart Hyper-V Virtual Machine Management service (vmms)
    7. netstat -ano | find "2179" now shows that the service is running
    8. vmconnect now connects successfully

    Evidently something was screwy with my virtual switch or the NICs and this resolved it.

    Simon.

    Wednesday, March 13, 2019 5:00 AM
  • Issue: Unable to connect to a HYPER-V VM using Hyper-V Manager after upgrading from Symantec 14.0 to 14.2

    System: Win10x64 v1803

    1. Using the direct launch of \\windows\system32\vmconnect.exe DOES work.

    2. Adding vmconnect.exe or vmcompute.exe as Application Exceptions to Symantec client DOES NOT work. 

    Unable to locate any relevant messages in any Windows Event Logs. 

    Currently upgrading to Win10 v1809. 

    Monday, March 18, 2019 9:29 PM
  • Oddly enough... while settings up a new laptop running Win10x64 v1809 it was discovered that the Symantec client v14.0 was a know issue with this technology stack combination. While initially unable to get Hyper-V to "run" after enabling it, upgrading Symantec client to v14.2 solve the problem for me. 

    Sadly on my laptop (win10x64 v1803) after upgrading the Symantec client from 14.0 to 14.2, I am unable to connect to a VM using the Hyper-V Manger. Currently I am upgrading to Win10 v1809 and hope it resolves the issue as it would seem to be a combination that is working on another laptop. 

    Monday, March 18, 2019 9:37 PM
  • Hi warren. I have a Hyper-V VM connect issue after upgrading to Symantec 14.2 and sent you an email. 
    Monday, March 18, 2019 9:40 PM
  • The upgrade to Win10 v1809 resolved the issue for me. 
    Monday, March 18, 2019 10:23 PM
  • The upgrade to Win10 v1809 resolved the issue for me. 
    Monday, March 18, 2019 10:23 PM
  • May I ask the step of Windows server 2016?
    Monday, June 3, 2019 9:40 AM