locked
Flash drive not working RRS feed

  • Question

  • I've got a pretty unique issue with my flash drive.

    It was working perfectly fine, until after extracting a relatively large file onto it, froze and all I could do was unplug it.

    After that, it doesn't work in any computer.

    I've tried block wiping, diskpart, disk management. But the main issue is that whenever I open disk management, it just stays doing nothing until I unplug the drive, same with diskpart. When I try to block wipe with UBCD, again, it just does nothing until I unplug it.

    On Ubuntu, it doesn't mount, however shows in GParted, but when I try to reformat and click apply, it says it's done but after refreshing the drives, none of the changes have applied.

    On Windows it says the drive is OK. Drivers are fine, shows in device manager (which by the way, I've tried uninstalling and reinstalling drivers) shows in the "Safely remove hardware" thingy at the bottom and is recognized correctly, and it supposedly has a drive letter, when using "mountvol" but isn't mounted.

    As far as I can tell, the flash drive physically is OK, as it is recognized, but the actual data on it is just corrupt in such a strange way that it can't be recognized.

    Saturday, May 3, 2014 5:15 PM

All replies

  • your data seems to be lost whatever it was so you need to just do a standard format back to its out of package state and test it from there.

    iron8orn

    Saturday, May 3, 2014 9:56 PM