none
Unable To Create SQL Managed Instance

    Question

  • Hello,

    I tried creating Azure SQL managed instance using the REST API from the docs https://docs.microsoft.com/en-us/rest/api/sql/managedinstances/createorupdate. I used Postman with the PUT verb. I got a response code of 202 Accepted with the response message:

    {
        "operation": "UpsertManagedServer",
        "startTime": "2019-04-18T09:54:26.187Z"
    }

    But no resource was created when I checked the resource group after few hours. Tried this over again but still same response. What could be the issue?

    Thursday, April 18, 2019 10:11 AM

Answers

  • Deployment of Managed Instance, especially if this is a first instance you are provisioning requires a new virtual cluster to be built, and this can take up to 6 hrs. Did this time passed, was the resource created since? If you are sure that the API was executed with proper parameters, the quickest way to get support is through creating a support ticket through Azure Portal which will reach engineering to have a look at.
    • Marked as answer by Deji19 Friday, April 19, 2019 9:25 AM
    Thursday, April 18, 2019 4:50 PM

All replies