none
Project Server 2013 timesheets not showing up for approval RRS feed

  • Question

  • We're using Project Server 2013 and entering timesheets. I'm a team manager who is set up as the timesheet approver for a few people, including Nicole.

    1. Nicole opens her timesheet and fills it in for the week.  She applies time to four Administrative tasks and two project tasks.
    2. Nicole submits her final timesheet for approval.  (We have also tried having her save it first, then to the final submission, with the same results.)
    3. I go to my approval screen and see the four Administrative tasks listed as separate lines.  I do not see the project tasks.
    4. I select the four Administrative tasks and approve them.  They disappear when the screen is submitted.
    5. In previous weeks, and with some other employees, I would immediately see a single line item that said "My Timesheet" for Nicole which I could then approve.  But recently this stopped, and I do not see her timesheet.
    6. If Nicole checks the status of the timesheet it says it's submitted to me.
    7. On my Approval page if I go to History, Timesheets this timesheet is not listed under "approved by me" nor is it under "my resources unsubmitted timesheets."  It's in limbo.
    8. The only fix is for Nicole to recall the timesheet and resubmit it.  Then it shows up on my Approval page.

    Any suggestions?

    -- Paul

    Wednesday, January 15, 2014 10:48 PM

Answers

  • We resolved this. The solution was as follows:

    • Go to PWA Settings, and under Security choose Manage Groups.
    • Click the Team Members group.
    • Scroll to the Categories section, and in the Selected Categories area highlight (select) My Tasks.
    • Click the box to allow the permission called Adjust Timesheet which is under the grouping for Resource.

    Now don't ask me how or why that works.  It's not a setting that intuitively matches what's going on.  But it fixed it for us.

    By the way, we had a number of other timesheet issues (view failures, etc.) that were all cleared up when we installed the April 2014 Cumulative Update for Project Server 2013, as well as SharePoint 2013 SP1.  I highly recommend both.

    -- Paul


    Paul LoSacco, Web Presence Team, Omnicare

    • Marked as answer by Paul LoSacco Wednesday, May 21, 2014 7:45 PM
    Wednesday, May 21, 2014 7:45 PM

All replies

  • I have seen something similar to this and have fixed it by turning OFF "Single Mode".... do my approvals and then "Single Mode" back ON. 

    I don't like this solution, but once I do this, the Status Updates show up, so it's a temporary fix for now.

    I have reported this to Microsoft as a bug, but Microsoft has not accepted it as a bug.  It occurs randomly and I cannot reproduce when I need to.   I think Microsoft is working on the issue, but it's only a hunch.

    Cheers!


    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Website http://www.WhartonComputer.com
    Blog http://MyProjectExpert.com contains my field notes and SQL queries

    Thursday, January 16, 2014 12:27 AM
    Moderator
  • Michael, 

    We are experiencing this, too. Have you heard anything more from Microsoft? This article is the lone one I found while researching how to fix it for our Project Managers. 

    Wednesday, May 21, 2014 6:51 PM
  • We resolved this. The solution was as follows:

    • Go to PWA Settings, and under Security choose Manage Groups.
    • Click the Team Members group.
    • Scroll to the Categories section, and in the Selected Categories area highlight (select) My Tasks.
    • Click the box to allow the permission called Adjust Timesheet which is under the grouping for Resource.

    Now don't ask me how or why that works.  It's not a setting that intuitively matches what's going on.  But it fixed it for us.

    By the way, we had a number of other timesheet issues (view failures, etc.) that were all cleared up when we installed the April 2014 Cumulative Update for Project Server 2013, as well as SharePoint 2013 SP1.  I highly recommend both.

    -- Paul


    Paul LoSacco, Web Presence Team, Omnicare

    • Marked as answer by Paul LoSacco Wednesday, May 21, 2014 7:45 PM
    Wednesday, May 21, 2014 7:45 PM