none
Each WORKBOOK in separate windows Excel 2010 Windows 7 RRS feed

  • Question

  • Hi,

    I read a lot of thread about this topic, and I begin to despair :)

    With this config : Excel 2010 / Windows 7

    I found the solution to open 2 Workbooks in separate windows, but from explorer / desktop ONLY !

    But from Excel (when a document is already opened), if I have an hyperlink in a spreadsheet that points on an other wordbook, when I click on the link, I would like to open it in a new instance of Excel.

    Same about FILE => OPEN (I would like to open it in a new instance of Excel too, always in fact)

    Thank you.

     

     

    Thursday, February 24, 2011 11:44 AM

Answers

  • Hi,
     

    To launch multiple instances of Excel, we change it by not using DDE to open the file.
    Check the "Ignore other applications that use Dynamic Data Exchange (DDE)" box in Excel -> Excel Options -> Advanced

    If this does not work,for Windows Vista and Windows 7, we need to edit the registry to remove DDE completely.
    ===============
    Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs.

    1. Click Start, in the Search box, type regedit and press Enter.
    2. Locate the registry subkey: HKEY_CLASSES_ROOT\Excel.Sheet.14\shell\Open
    3. Delete the ddeexec subkey.
    4. Click on the command subkey, and then double-click the Default value from the right pane. Replace the value data with:  "C:\Program Files\Microsoft Office\OFFICE14\EXCEL.EXE" "%1"
    Double-click the Command string value, replace its data with:  (f'^Vn-}f(ZXfeAR6.jiEXCELFiles>!De@]Vz(r=f`1lfq`?R& "%1"


    Best Regards,

    Sally Tang

     

    • Marked as answer by Sally Tang Monday, February 28, 2011 1:35 AM
    Saturday, February 26, 2011 5:38 AM

All replies

  • Open the 2, or 3, or n workbooks, then try this keyboard shortcut, pressing one key at a time, in this sequence: Alt,  J,  J, 1 (1 or 2 or 3, or n)

    Hope it helps.

    renatoabc

    After that try Alt, J, B and  Alt, J, VS

     

    Thursday, February 24, 2011 4:48 PM
  • Sorry, I don't understand your answer : When I click on an hyperlink (link to an other wordbook), I would like to automatically open it in a new Excel.

    Thanks,

     

    Pierre

     

    Thursday, February 24, 2011 4:58 PM
  • Hi Pignon007,

    Now I understood yor question.

    The answer is that the behavior is by design (or it's a bug in Excel).

    The point is that both Excel and Word are part of Office, but Word behaves in a diferent way.

    To check try doing the same with Word and you will see more than one instance of word will be oppened when you oppen more than one Word doc.

    Another way to check the different behavior between oppening mutiple Word and Excel files can be checked with Task Manager, in the process tab, it will show many process for Word, but only one process for Excel, both when you oppen mutiple files.

    renatoabc

    Friday, February 25, 2011 10:04 AM
  • Hi,

    There is no solution to fix that ? (editing the Windows registry for exemple )

    Thanks,

    Pierre

    Friday, February 25, 2011 11:25 AM
  • Hi,
     

    To launch multiple instances of Excel, we change it by not using DDE to open the file.
    Check the "Ignore other applications that use Dynamic Data Exchange (DDE)" box in Excel -> Excel Options -> Advanced

    If this does not work,for Windows Vista and Windows 7, we need to edit the registry to remove DDE completely.
    ===============
    Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs.

    1. Click Start, in the Search box, type regedit and press Enter.
    2. Locate the registry subkey: HKEY_CLASSES_ROOT\Excel.Sheet.14\shell\Open
    3. Delete the ddeexec subkey.
    4. Click on the command subkey, and then double-click the Default value from the right pane. Replace the value data with:  "C:\Program Files\Microsoft Office\OFFICE14\EXCEL.EXE" "%1"
    Double-click the Command string value, replace its data with:  (f'^Vn-}f(ZXfeAR6.jiEXCELFiles>!De@]Vz(r=f`1lfq`?R& "%1"


    Best Regards,

    Sally Tang

     

    • Marked as answer by Sally Tang Monday, February 28, 2011 1:35 AM
    Saturday, February 26, 2011 5:38 AM
  • Hi Sally Tang,

    In my Win 7 machine I don't have this hive (HKEY_CLASSES_ROOT\Excel.Sheet.14\shell\Open) as you can see in the screenshot bellow:

    What should I do?

    Renatoabc

    • Proposed as answer by tdileonardo Thursday, October 17, 2013 12:04 AM
    Monday, February 28, 2011 2:45 AM
  • Hi,

     

    If you do not have the registry key, you can add it manually.

     

    Best Regards,

     

    Sally Tang

     

     

    Monday, February 28, 2011 7:37 AM
  • I have attempted to follow the above instructions without success.

    However, I was forced to create the keys described as they were not present on my computer. I believe that I may have not done so properly. I found the instructions at step 4 unclear.

    This is what I did:

    1. Created all keys described.

    2. In the "command" subkey, I altered the "Default" value as described to: "C:\Program Files\Microsoft Office\OFFICE14\EXCEL.EXE" "%1" (including the quotes).

    3. In the "command" subkey, I created a further String Value "Command" which I changed to: (f'^Vn-}f(ZXfeAR6.jiEXCELFiles>!De@]Vz(r=f`1lfq`?R& "%1"

     

    This results in a final subkey "command", with TWO VALUES "Default" and "Command" populated as indicated above. Was this the intended result? It did not have the intended effect. The only change I observed was that tiny snapshots (dialog-box-sized) of the additional Workbooks now appear in Aero Flip.

    I would greatly appreciate further clarification.

     

    Thanks for your time.

    • Edited by Guilbault Thursday, March 3, 2011 12:04 AM Paragraph formatting stripped.
    Thursday, March 3, 2011 12:02 AM
  • Hi Sally Tang!

    I need more help to apply your answer, see the picture:

    I don't know where to insert the : (f'^Vn-}f(ZXfeAR6.jiEXCELFiles>!De@]Vz(r=f`1lfq`?R& "%1"

    Please help me,

    renatoabc

    Saturday, March 12, 2011 2:22 PM
  • I have the exact opposite situation.  I cannot stop excel from open multiple instances when I click on shortcuts or open files from the file browser.  It's extremely frustrating!  I've checked all the settings in the Excel options setting, display show all bla bla in task bar, checked unchecked no change.  I've checked an unchecked the DDE box, no change.   Windows 7 with office enterprise 2007. 

     

    For reference this only happens on my log in.  The admin can log in to a stock sign on and it works as it should, only ONE instance opening multiple files from shortcuts, or the file browser. 

     

    I'm at my wits end, please help!!

    Friday, March 18, 2011 1:23 AM
  • To launch multiple instances of Excel, we change it by not using DDE to open the file.
    Check the "Ignore other applications that use Dynamic Data Exchange (DDE)" box in Excel -> Excel Options -> Advanced

     

    When you perform these steps, you can no longer open the files.

    • Proposed as answer by tinkms Tuesday, March 5, 2013 6:01 PM
    Friday, November 4, 2011 4:06 PM
  • Open the first workbook, then minimize it to access your Desktop.  Click on the Excel icon (assuming that is on your desktop - just go in Programs or where ever you have the Excel exe) and open a second Excel window then open your second workbook.
    Friday, November 4, 2011 4:15 PM
  • Sally,

    I too was looking for a way to get multiple Excel 2010 windows in Windows 7 when launching from any Explorer shell method.

    I tried following your instructions, but got an error when testing, something like "This command is only valid for products which are currently installed."

    I reverted to the original settings and then followed your instructions again. However, in step 4, instead of using your quasi-encrypted command string, I left mine intact and just changed the /dde at the end to "%1", the same as for the default value string. This worked as expected.

    Thank you for your help getting me to this point. I hope that others are able to use your instructions regardless of the contents of the encrypted command string.

    Shem Sargent

    SargenTech

    Tuesday, November 29, 2011 1:27 AM
  • Sally,

    Even as these 'fixes' may accommodate, as a purchaser of this software I shouldn't be burdened with concerns to applying a 'fix' correctly.  It really is in Micrsoft's court to apply an update to this very annoying glitch in Excel 2010. There's no point in my laptop having 'side-by-side' capability, or using a double monitor to better view multiple data sheets, if the Excel program won't allow it.  What a bummer!!  

    Tuesday, December 13, 2011 4:37 PM
  • 1. Find excel.exe

    2. Create shortcut to excel.exe on desktop

    3. Drag and drop excel files on shortcut

    4. Voila, multiple instance of excel.exe and all file remain visible

    Wednesday, December 21, 2011 10:26 AM
  • Hi!

    Pasting an Excel.exe shortcut on desktop does not solve the problem, it's not the right answer, I've tryed it and it did not work as stated.

    In my opinion the solution is to create a .bat file on the desktop (you can create a .txt file with this line , save it and after that rename it changing the extension from .txt to .bat), or wherever, with the following line adapted to each situation:

    start "Excel" "c:\Program Files\Microsoft Office\Office14\EXCEL.EXE" /e %1

    After that if you drag and drop the Excel files to this .bat icon, Excel will be started with separeted instances for each file you drag and drop, so you can place some Excel files in one monitor and other files in another one.

    This solution was tested for Win7 32 bit / Excel 2010 EN.

    Regards,

    Renatoabc

    Wednesday, December 21, 2011 6:45 PM
  • Hi

    Works with me, I am running Win 7 Ultimate 64bit with Office 2010 pro. Also worked when i was using Win XP Pro and Office 2007 pro and later Office 2010 pro

    With the solution you have do you mean create a .bat file every time I need to open multiple instances?

    Cheers

    Wednesday, December 21, 2011 7:01 PM
  • Hi!

    The .bat file is to be created just once, e.g. can be created on the desktop, and after that any Excel file can be oppened with a drag and drop to the .bat icon.

    The %1 at the end of the line in the .bat file will start a new instance for each Excel file.

    If you try, please tell if it worked for you, this way other users will be aware of the usability of this solution.

    Marry Christmass!

    Renatoabc

    Wednesday, December 21, 2011 9:41 PM
  • Hi

    The .bat method also works for me. In fact both methods (.bat or shortcut to excel.exe) give exactly the same result.

    Best regards and  a merry X-mass to you too.

    Thursday, December 22, 2011 11:06 AM
  • Hi!

    I tryed the Exel.exe shortcut on the desktop again, and it worked indeed.

    But for both solutions (including the .bat solution) there are some limitations when dealing with copying and pasting formulas.

    See my post from Dec/27/2011 on:

    http://social.technet.microsoft.com/Forums/en-US/excel/thread/f6f54088-220d-4218-af10-0026f2ccbc72

    I wish you all a very Happy New Year.

    Renatoabc

    Tuesday, December 27, 2011 8:43 PM
  • Here's what works for me (Excel 2010, Windows 7 86 bit). I have the Excel shortcut on the taskbar. Open the first workbook. Right-click on the Excel shortcut. I see three icons: "Microsoft Excel 2010", "Unpin this program from the taskbar", and "Close window" plus a listing of recent programs. I left-click on the Excel icon and it opens a new instance of Excel. On my computer I can also open a second instance from the Excel shortcut on the desktop. Right-click on the desktop icon and left click on the Open command. I have not checked the "Ignore other applications that use Dynamic Data Exchange (DDE)" advanced option.
    Wednesday, January 18, 2012 5:41 PM
  • Thank You Sally & Shem,

    For Step 4 - I use a combination of both your answers, i.e. just replaced    /dde     with    "%1"     for both "(Default)"  &  "command".

    Easy!

    Michael

    • Proposed as answer by mw1966 Wednesday, January 31, 2018 5:21 PM
    Friday, April 6, 2012 11:48 AM
  • Here is another fix:

    Run regedit

    Update:    HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\command\(Default) to "C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE" /e "%1"

    Rename: HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\command\command to HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\command\command2

    Rename: HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\ddeexec\ to HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\ddeexec2\

    Update: HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\command\(Default) to "C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE" /e "%1"

    Rename: HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\command\command to HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\command\command2

    Rename: HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\ddeexec\ to HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\ddeexec2\

    However, this is often overwritten by subsequent windows updates - and aren't those as common as rain in London, so can I make a suggestion to the readers of this forum to add a message here (perhaps every week) until this gets a permanent solution? After all, individual license revenue is considerable to this company.

    If there is no room on the ribbon for such an option perhaps we can replace the translate function (Review bar) with it.

    Cheers,

    Thomas

    • Proposed as answer by AaronJP Thursday, October 3, 2013 2:43 AM
    Saturday, April 7, 2012 1:59 PM
  • Hello all,

    The above solution is the proper one. I've written a blog article addressing this issue, with easy to download .reg files containing all the changes you'll need. http://ptihosting.com/blog/it-blog/force-excel-20072010-to-open-in-seperate-window/

    -Brad


    Brad Laszlo Systems Engineer | Prestige Technologies

    Sunday, April 8, 2012 12:52 PM
  • everyone should note that brad's file points to folders that might not have been your unique installation pathway.  his file points down "program files->..." whereas some might have "program files (x86)->..." pathways.  so some editing is necessary.

    Thomas's quick fix worked like a charm, whereas some other regedits from above failed for me.

    Cheers,

    John

    Saturday, May 5, 2012 5:10 PM
  • Hi,

    If you do not have the registry key, you can add it manually.

    Best Regards,

    Sally Tang

    Hi Sally, I did this and it didn't work. Do I need to further replicate the rest of the excel.sheet.12 subkeys under the new excel.sheet.14 and then delete the excel.sheet.12?

    Why wouldn't Office install the correct registry keys?

    Wednesday, May 9, 2012 11:32 PM
  • This is the only thing I tried that actually works. Open one of your Excel files. Click Start and type, "Excel" into the Search Programs and Files Bar. Open a new Excel document through the search results and it will open in another window. Open your second document through the new window you just opened and drag it to the other screen.
    Thursday, May 17, 2012 3:11 PM
  • Thank you Brad!

    I have used your Reg files now on three machines with Office 2007 and Office 2010.  Each time it has worked flawlessly.  My most recent use was on a machine that also has LibreOffice installed along with 32 Bit Office 2010.  After running the Reg file "Add Open In New Excel Instance and Make Default.reg" and then clicking on an .xls file I was prompted to select which program I wanted to use to open the file.  LibreOffice Calc was suggested in the dialog along with a button to browse for and select another program.  After browsing Program Files (x86) and selecting C:\Program Files (x86)\Microsoft Office\Office14\Excel.exe everything again works perfectly.

    Microsoft, WAKE UP.  With all the options in Excel, there must be more than a thousand, the option to open files in a new window should be available AND MADE THE DEFAULT!

    Until this happens, countless man hours are being lost in frustration and unnecessary searching for a solution to this problem around the world!

    Thursday, June 7, 2012 3:51 PM
  • Thanks 2manyquestions,

    Yours was the simple solution...now its easy.

    rkorgan


    • Edited by rkorgan Wednesday, December 12, 2012 8:47 PM
    Wednesday, December 12, 2012 8:46 PM
  • All those other directions on here are just too complicated and didn't work on some... your (2manyquestions) answer was the simplest and actually the only thing that is needed.... those other folks don't know what they are talking about.
    Tuesday, March 5, 2013 6:02 PM
  • If you do the above, you will get multiple instances, which is great for going between workbooks quickly and easily, HOWEVER, beware, you will lose the main reason i need to go between workbooks, and that is cutting rows from one workbook and inserting them into another. The "insert cut cells" option will not be available in the right click menu anymore.
    Thursday, October 3, 2013 3:20 AM
  • Shem,

    Thank you, your small correction to Sally Tang's explanation higher in this page: it was the trick that made it work. Without that, I also got the error message that it only works for installed products (or something like that).

    Also, for Office 2010, I autocorrected Sally's hive to be modified:

    HKEY_CLASSES_ROOT\Excel.Sheet.14\shell\Open must be

    HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open

    In my case, I also did the same modifications in the HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open hive, but I'm not sure if that's really required.

    But indeed, I don't know if this is a bug, but there should be a setting somewhere to do this.

    • Proposed as answer by 311inNYC Thursday, December 12, 2013 3:14 PM
    • Unproposed as answer by 311inNYC Thursday, December 12, 2013 3:18 PM
    Tuesday, November 12, 2013 9:01 PM
  • Greeting all,

    I believe another posting has already provided the simplest answer, IMHO - no registry edits, etc.

    Problem: opening multiple workbooks using Excel 2010

    Answer:  start button click on icon to open up another instance of Excel and then open your second workbook to nth workbook....

    Thursday, December 12, 2013 3:17 PM
  • This is such a nuisance, and i can't belive that, 3 years on, there still isn't a viable work-around/option available through Excel itself.

    For me, switching the DDE off either a) did not result in the desired outcome, or b) did not result in the desired outcome AND stopped me opening spreadsheets. Needless to say, i switched it back on!

    Are there any solutions for this which don't involve editing the registry? i'm on a corporate license, and i don't think our IT team would appreciate me playing in the registry, and there is the high possibility that, even if i do it correctly, something else will mess up.

    Opening  separate instances of Excel, and then opening the spreadsheets i want does work, but it's such a waste of time that i can't really afford to be spending each time i need to open a spreadsheet, particularly because the majority of the ones i access are shared documents that i can't keep open.

    i'm on W7 | Office 2010

    Thanks in advance,

    J

    Thursday, February 20, 2014 1:14 PM
  • Hi,

    I have been having trouble with this for a long time since I have to compare inventory sheets to keep them accurate. I believe I have found a solution or at least one that works for me.

    First I open the first spreadsheet then click File>Open.

    I then find the second spreadsheet and right-click>open and it opens in two windows.

    Hope this helps.

    Thursday, May 1, 2014 3:07 PM
  • I hope this clears some things up.

    REMEMBER TO BACK UP BEFORE MAKING CHANGES

    In Windows 7 using Office/Excel 2010, there are many shell commands. You might want to consider "fixing" all the keys of the shell commands you use (New, Edit, Open, [print doesn't matter because it simply opens, prints, then closes]). I only use Open (double click uses the Open shell-command), so that's all I'm going to cover below. If you can't figure out the others then you probably shouldn't be altering the registry.

    Note: Excel.sheet.12 is used to open .xlsx files while Excel.sheet.8 is used to open .xls files as can be seen under "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\{.xls or .xlsx}\OpenWithProgids" (there are other extensions you might need to look at as well). Change both the .12 and .8 keys, in both locations, as listed below:

    Edit HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\command

    Before: (Default)  REG_SZ  "C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE" /dde
        and: command  REG_MULTI_SZ  xb'BV5!!!!!!!!!MKKSkEXCELFiles>VijqBof(Y8'w!FId1gLQ /dde

    to

    Change: (Default)  REG_SZ  "C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE" /e "%1"
        Rename to: command2  REG_MULTI_SZ  xb'BV5!!!!!!!!!MKKSkEXCELFiles>VijqBof(Y8'w!FId1gLQ /dde

    then

         Before: key "HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\ddeexec"
        Rename to: "HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\ddeexec2"

    then repeat the above steps on:
    HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\command
    HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\ddeexec

    then repeat the above steps on: 
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.12\shell\Open\command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.12\shell\Open\ddeexec
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.8\shell\Open\command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.8\shell\Open\ddeexec

    This worked for me and hopefully will work for you. 

    I don't know about FILE => OPEN because it is issuing the OPEN command from within an existing instance of Excel; however, a Right-Click => OPEN from outside of any Excel instance will open in a new window.

    -Justin

    http://www.JustinsComputers.com

    • Proposed as answer by Justinr9999 Thursday, June 26, 2014 4:57 PM
    • Edited by Justinr9999 Tuesday, July 8, 2014 3:57 AM
    Thursday, June 26, 2014 4:56 PM
  • Just an update to my above instructions:

    I had an MS Office update pushed via my corporation and while I'm not going to try and determine which update caused the reversion, my Excel open commands reverted back to the default behavior.

    What happened: 

    The (Default)  REG_SZ  "C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE" /e "%1" (specifically the /e "%1") reverted back to the default ... /dde switch.
    The HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\ddeexec was returned (remember, we renamed it). 
    The HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\ddeexec2 key remained.
    The same applies to the Sheet.8 keys:
    HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\command

    HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\ddeexec

    How to revert Excel 2010 back to open workbooks in separate instances:

    Simply change the Excel sheet.12 and sheet.8 open commands back to the /e "%1" switch and delete the ddeexec keys, since we already renamed them once before and the renamed key remains. 

    Detailed Instructions:

    Edit HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\command

    Before: (Default)  REG_SZ  "C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE" /dde
        and: command  REG_MULTI_SZ  xb'BV5!!!!!!!!!MKKSkEXCELFiles>VijqBof(Y8'w!FId1gLQ /dde

    to

    Change: (Default)  REG_SZ  "C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE" /e "%1"
        Delete (if exist): command  REG_MULTI_SZ  xb'BV5!!!!!!!!!MKKSkEXCELFiles>VijqBof(Y8'w!FId1gLQ /dde

    then

        Delete (if exist): "HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\ddeexec"

    then repeat the above steps on:
    HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\command
    HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\ddeexec

    This seems to "fix" what an update unfixed.


    • Edited by Justinr9999 Friday, September 5, 2014 7:30 PM Some formatting was lost
    Friday, September 5, 2014 7:29 PM
  • This was the best instruction and it did work for me. Thanks
    Friday, April 24, 2015 2:18 PM
  • Perfect

    Easy and fast, only thing what worked for me!

    Tuesday, January 12, 2016 5:45 PM
  • For anyone who sees this, Microsoft's hotfix is the only thing that consistently worked for me.

    It is located here: https://support.microsoft.com/en-us/kb/2636670

    Friday, June 3, 2016 3:39 PM
  • Hi Sally,

    I tried this but it did not work. I am on Office 2010, Windows 7 Professional.

    Regards, Sharad

    Thursday, March 30, 2017 2:34 AM
  • I had the same issue with "This command is only valid for products which are currently installed." error. I restored the original keys, deleted the ddeexec key, and changed the /dde in the entries to "%1". Now I can have multiple excel windows open across my screens!

    Why isn't there an "open in new window" option in excel? Seems like a pretty common request..

    Thursday, January 4, 2018 3:28 AM
  • Hi, I'm trying to solve the same problem: to open different Excel files (xls, xlsx, xlsm...) in different windows (like Office 2016... or in my case like Word 2007) - my OS = win 7 64bit.

    The Microsoft's hotfix  https://support.microsoft.com/en-us/kb/2636670 works well but there is a big problem: if you have a personal.xlsb file, with your personal macros, every time you open a file, a message remembers you that personal.xlsb is already opened and you have to open it in read-only mode.

    Is there a way to solve this problem?
    thanks.

    Thursday, January 11, 2018 10:13 PM
  • This isn't a hotfix. This is a fix in new editions of Excel. This doesn't change the behavior of Excel 2010.

    Tuesday, September 18, 2018 8:15 PM
  • Even though this is an old thread it is still a current problem and I found the excel shortcut on the desktop solution to work for me.  Although the customer did not have this problem in Windows 7, only after we upgraded him to Windows 10.  Still running MS Office Business 2010.
    Wednesday, September 11, 2019 11:45 PM