locked
Application Compatibility Manager - Cannot Send and Receive or Check for Updates in Windows 7 x64 RRS feed

  • Question

  • I have installed the Application Compatibility Toolkit following the provided MS guide and am attempting to manage it with the Application Compatibility Manager on a Windows 7 Professional x64 machine. I am receiving the following error message when it launches and tries to check for updates:

    ----- Begin Error Message ----
    Window Title: Application Compatibility Manager
    ACT was unable to connect to the Internet to check for updates due to the following error:
    The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.
    The remote certificate is invalid according to the validation procedure.

    Verify your Internet settings and try again.
    ----- End Error Message ----

    The exact same message comes up when I try and do a Send and Receive. Not being able to do that makes me unable to use the Analyze portion of the Manager. I do concede that it may be a proxy issue (we use a DansGuardian/Squid proxy setup) and we are investigating that to try and find errors, etc that it may be encountering.

    Has anyone seen this error message or have any tips to try and resolve it?

    I have verified that this does work on a Windows XP Professional x86 machine using the same network and Internet Configuration settings, so the proxy argument is a weak one at the moment. It would seem to be a Windows 7 x64 issue (I haven't tried x86 or Vista at all).

    I did change my Internet Options to allow/use all versions of SSL and TLS and also to ignore Publisher and Server certificate Revocation in Internet Options > Advanced > Security. I rebooted my machine after these changes and it still would not connect and gave the same error.

    The system details are as follows:
    Windows 7 Professional x64
    Microsoft Application Compatibility Manager v5.5.6762.1798
    Symantec Endpoint Protection v11.0.5002.333 (tried both disabled and enabled)
    User Account Control is turned off (legacy application requirement)

    If there is more information that I can provide I would be more than happy to do so.

    Thank you for your time
    Tuesday, January 12, 2010 9:04 PM

Answers

  • I took this machine home and used it outside of our network. The application updated fine (it couldn't connect to the SQL server, but that was expected). Once I brought it back on network it now connects fine, also.

    Thanks for your time!
    • Marked as answer by Joe Tinney Wednesday, January 13, 2010 6:05 PM
    Wednesday, January 13, 2010 6:05 PM