locked
Adding AD contact object in people picker RRS feed

  • Question

  • Hello experts,

    We have two SharePoint farms one in MOSS 2007 and one in SP2010. Both uses same AD and same service accounts are used for app-pool.

    AD have both user objects and contact objects. Vendors are added to AD as contact objects.

    My issue is, In MOSS 2007 when I give these AD contact objects, its getting resolved and I can add them to sites. By default it is getting resolved with out any configuration changes on STSADM or AD. 

    But in SP2010, I cant able to resolve these AD contacts. People picker waits for some and throws an error message that user cannot be found. Is there any way to resolve this issue in SharePoint 2010?


    Regards, karthik.
    Friday, December 9, 2011 10:29 PM

Answers

  • Hi Karthik,

     

    Did you create User Profile Service Application for SharePoint 2010 farm? If not, please create it. And if the DNS name of your domain is different from the Netbios name of your domain. You need to set NetBiosDomainNamesEnabled property to be true for the UPSA. Then Recreate the synch connection and run a full import. If this not works, you can post more detailed error information.

     

    And this forum is for pre-SharePoint 2010, you should post the question related to SharePoint 2010 to the dedicated forum for more efficient responses.

     

    Thanks.


    Pengyu Zhao

    TechNet Community Support

    • Marked as answer by Pengyu Zhao Monday, December 19, 2011 2:01 AM
    Monday, December 12, 2011 9:55 AM