Storage Replica: Unable to Sincronize replication group "cannot update state for replication group in the storage replica driver" RRS feed

  • Question

  • Hi all:
                    How are you? I have a problem to create a storage replica in a PoC (virtual testing environment) I tried to crete a Storage replica (Windows 2019 standard) using the following command (powershell with admin rights):
    Set-SRPartnership -SourceComputerName APPLIANCEWK01 -SourceRGName rg01 -SourceVolumeName g: -SourceLogVolumeName r: -DestinationComputerName APPLIANCEWK02 -DestinationRGName rg02 -DestinationVolumeName g: -DestinationLogVolumeName r:

    But the following error apperars:

    New-SRPartnership : Unable to synchronize replication group rg02, detailed reason: Cannot update state for replication group rg02 in the Storage Replica driver.

    The replica was created, but the destination partition is in RAW format, and i can’t obtain the “replica status”
    PS C:\Users\administrator.DCFSAAS> Get-SRGroup
        $r=(Get-SRGroup -Name "rg01").replicas
        [System.Console]::Write("Number of remaining bytes {0}`n", $r.NumOfBytesRemaining)
        Start-Sleep 10
    }until($r.ReplicationStatus -eq 'ContinuouslyReplicating')
    Write-Output "Replica Status: "$r.replicationstatus
    AllowVolumeResize  : False
    AsyncRPO           :
    ComputerName       : APPLIANCEWK01
    Description        : 
    Id                 : 215a66cc-404e-4494-927e-62b297e5c03c
    IsAutoFailover     :
    IsCluster          : False
    IsEncrypted        : False
    IsInPartnership    : True
    IsMounted          : False
    IsPrimary          : True
    IsSuspended        : False
    IsWriteConsistency : False
    LastInSyncTime     :
    LogSizeInBytes     : 8589934592
    LogVolume          : r:\
    Name               : rg01
    NumOfReplicas      : 1
    Partitions         : {14bd8a0b-bf8e-4fc1-9a6d-a2a7bb78bec0}
    Replicas           : {MSFT_WvrReplica (PartitionId = "14bd8a0b-bf8e-4fc1-9a6d-a2a7bb78bec0")}
    ReplicationMode    : Synchronous
    ReplicationStatus  : ContinuouslyReplicating
    TemporaryPath      : 
    PSComputerName     :
    Number of remaining bytes 0
    Replica Status:
     Have you some documentation to help me with this or any idea about this problem?
    I tried recreating the virtual volumes again (using V-cloud) but the problem persist, the size of all partitions (replica and logs) is 15Gb.

    Monday, May 27, 2019 5:51 PM


  • Hi!

    Thanks for your answer, I ran Test-topology before New-PartnerShip, and everything was checked with "green check"

    Now the replica is working well, I had to delete content from registry Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WVR\ConfigStore\ in SourceServer and DestinationServer

    This entry have all ResourceGroup configuration, next, restart both servers, and then create again the New-PartnerShip using this command:

    Set-SRPartnership -SourceComputerName APPLIANCEWK01 -SourceRGName rg01 -SourceVolumeName g: -SourceLogVolumeName r: -DestinationComputerName APPLIANCEWK02 -DestinationRGName rg02 -DestinationVolumeName g: -DestinationLogVolumeName r:

    And now it's working. 

    Thanks for your information and rapid response,

    • Edited by Masterop512 Wednesday, May 29, 2019 3:10 PM
    • Marked as answer by Masterop512 Wednesday, May 29, 2019 3:21 PM
    Wednesday, May 29, 2019 3:08 PM

All replies