locked
When Using an Alternate Shell Per User, Experiencing Long Log Off time RRS feed

  • Question

  • Hi!

    I've been trying to figure this out with not much luck. So here's the situation... For certain users I've replaced the shell (HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\Shell). The users are direct entries into different applications (Windows Media Center for example). This is being done on Windows 7 Home Premium for a HTPC. The users are standard users not administrators.

    Basically everything is working as desired *except*, as the subject says, at time of shutdown or logoff. In both cases these users take an inordinate amount of time to log off. Sometimes 5 or so minutes, a couple of times I had to Power the machine off as it was going without end. If I return to explorer as a shell (deleting the CURRENT_USER shell key, shutdowns and logoffs are fine.

    What I've done

    I've tried sleuthing by creating a custom view in event viewer looking for those events with id 200... The only thing I could find was something Saying <SENS> is taking a long time to shutdown. So all I could find on that is something about windows messenger... and I don't have that installed.

    As suggested on an article I changed the \SYSTEM\CurrentControlSet\Control\ WaitToKillServiceTimeout to a lower number... but that didn't help. And I didn't think it would as I'm logging off.

    Anyway, any help is totally appreciated. Even better with the same or similar setup that ran into this problem!

    Thanks!

    Tuesday, March 26, 2013 4:46 PM

Answers

  • Jason,

    Again thanks for your reply.

    I know it's not Steam per se, as the user using Windows Media Center as its shell has the same behavior.

    Although, I *may* have found the culprit. I did a clean boot, hid Microsoft services, and disabled everything. The long logoff went away. I then systematically enabled one at a time, rebooted, and logged off looking for the issue. Rinse, lather, and repeat.

    Wouldn't you know, it was the last service in the list. :o/

    The Broadcom Wireless LAN Tray Service. I'm not going to mark this answered yet though... I want to test for a couple of days to protect against it being a transient issue, or one that may build over time (When the BWLTS was enabled my logoff was over a minute... still a lot less than before i did the clean boot. But compare to when it was disabled; it took 5 seconds.

    Scott

    P.S. I'm kind of in a quandry if it is though. I'd like to reward you for your time by clicking on your post as the answer... but I want others to find the solution as well. Should I just mark my post as the answer if this is it?

    P.P.S. Is there a capacity in windows to output a verbose log of startup/shutdown prrocedures? So in the future I could run that instead of the trial and error approach?


    • Edited by Scott_2 Friday, April 5, 2013 4:59 PM
    • Marked as answer by Scott_2 Tuesday, April 9, 2013 8:49 AM
    Friday, April 5, 2013 4:58 PM

All replies

  • Hi,

    Thank you for your question.

    I am trying to involve someone familiar with this topic to further look at this issue.

    Regards,

    Leo   Huang

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Leo Huang
    TechNet Community Support

    Wednesday, March 27, 2013 3:18 AM
  • Excellent. Thanks Leo! I look forward to hearing from them.
    • Edited by Scott_2 Thursday, March 28, 2013 5:40 AM Late at night, so I got Leo's name wrong. :o(
    Wednesday, March 27, 2013 6:19 AM
  • Hi,

    Please export following registry and paste to here, then I could know what changes you made on the registry.


    Best regards, Jason Mei Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, March 28, 2013 10:25 AM
  • HI,

    please export following registry and paste here.

    HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\Shell


    Best regards, Jason Mei Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, March 29, 2013 9:24 AM
  • Hi Jason!

    Thanks for getting back to me. I went ahead and just got the whole key of one of the users. In this particular user (which shows the symptom) it starts the steam game platform as a shell. Note this behavior exists for the other users, and shells, alike. If after starting this shell I hit CTRL+ALT+DEL to bring up task manager and start explorer and THEN log off I have a normal logoff time. If I logoff from that menu without starting explorer that's when the logoff takes forever (this also can be seen if from the steam interface I select shutdown.... the log off portion takes forever).

    Hope that blurb was helpful and not confusing... anyway, here is the entire winlogon key for one user:

    [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]
    "ExcludeProfileDirs"="AppData\\Local;AppData\\LocalLow;$Recycle.Bin"
    "BuildNumber"=dword:00001db1
    "FirstLogon"=dword:00000000
    "ParseAutoexec"="1"
    "Shell"="\"C:\\GamesDir (x86)\\Steam\\Steam.exe\" -tenfoot"

    I'm curious as to the ExcludeProfileDirs  value... what does this value do, and could it be related?

    Thanks in advance for your help.






    • Edited by Scott_2 Monday, April 1, 2013 10:49 PM
    Monday, April 1, 2013 7:22 PM
  • HI Scott,

    Thanks for your reply.

    ExcludeProfileDirs is the default configuration, so i'm afraid this is not the cause of this issue. below is a article for your reference.

    http://support.microsoft.com/kb/188692

    Registry setting "Shell" is not default configuration, here is an article about this.

    http://msdn.microsoft.com/en-us/library/ms838576(v=winembedded.5).aspx

    Any question, please let me know. Have a nice day!


    Best regards, Jason Mei Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, April 2, 2013 10:58 AM
  • Hi Jason,

    Thanks for your quick answer. Looking at the second article it says it only applies to Windows XP Embedded. I'm on Windows 7 Premium... will it still be alright to try this on Windows 7? From that article the only key I need to verify is key one (as key 2 just has explorer as the default, and key 3 is already set up). I can definitely check into that tonight.

    It's important to note the alternative shell does start. It's the logging off that takes a long time. How will that first key help?

    Thanks again, and if I can confirm with you that the article on Windows XP Embedded is ok to do with Windows 7 (and you still think it'll help based on the last sentence) I'll give it a try.

    Do you know what the SENS behavior is about? Is there any way to log any info for you to better help?

    Thanks!


    Tuesday, April 2, 2013 6:32 PM
  • Hi Scott,

    The only changes involved in this issue is "Shell", I'm this issue is related to the GamesDir (x86)\\Steam\\Steam.exe when set as the value of "Shell".  When log off, system need long time to kill process Steam.exe and then log off. You may need to verify how steam works with steam engineer.


    Best regards, Jason Mei Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, April 5, 2013 8:56 AM
  • Jason,

    Again thanks for your reply.

    I know it's not Steam per se, as the user using Windows Media Center as its shell has the same behavior.

    Although, I *may* have found the culprit. I did a clean boot, hid Microsoft services, and disabled everything. The long logoff went away. I then systematically enabled one at a time, rebooted, and logged off looking for the issue. Rinse, lather, and repeat.

    Wouldn't you know, it was the last service in the list. :o/

    The Broadcom Wireless LAN Tray Service. I'm not going to mark this answered yet though... I want to test for a couple of days to protect against it being a transient issue, or one that may build over time (When the BWLTS was enabled my logoff was over a minute... still a lot less than before i did the clean boot. But compare to when it was disabled; it took 5 seconds.

    Scott

    P.S. I'm kind of in a quandry if it is though. I'd like to reward you for your time by clicking on your post as the answer... but I want others to find the solution as well. Should I just mark my post as the answer if this is it?

    P.P.S. Is there a capacity in windows to output a verbose log of startup/shutdown prrocedures? So in the future I could run that instead of the trial and error approach?


    • Edited by Scott_2 Friday, April 5, 2013 4:59 PM
    • Marked as answer by Scott_2 Tuesday, April 9, 2013 8:49 AM
    Friday, April 5, 2013 4:58 PM
  • Hi,

    Yes, it is the last service we enabled.

    You can marked any post as answer.  To troubleshoot the long logon and logoff issue, we could use following trace.

    1. event log.

    2.  logman, lease help to enable the profile tracing on affected PC so that we could check if there are problem when loading profile. To do this, please follow these steps to enable profile tracing:

    1) Please log on to affected PC with administrator account and open a command prompt.
    a. Select the start menu
    b. Type CMD in "Start Search"
    c. Right mouse click on CMD under programs
    d. Select "Run as administrator"

    2) Run "logman -start profile -p {eb7428f5-ab1f-4322-a4cc-1f1a9b2c5e98} 255 3 -ets" (without the quotes)

    3) then reproduce the symptom.
    4) then open a command prompt to stop the tracing:
    e. Select the start menu
    f. Type CMD in "Start Search"
    g. Right mouse click on CMD under programs
    h. Select "Run as administrator"

    5) Run "logman -stop profile -ets" (without the quotes)

    6) Profile.etl will be located in the directory that logman -start was run.


    Best regards, Jason Mei Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, April 9, 2013 8:17 AM
  • Jason,

    Thanks for all your help. It looks like the service I tracked down, the Broadcom wireless LAN tray service, was the problem. The logoff times are now 5 seconds or less. Thank you so much for your time though, and the trace instructions! I'll be sure to use that next time (sounds a lot easier then systematically starting services).

    Best wishes and I hope this thread is helpful to someone else.


    Scott

    Tuesday, April 9, 2013 8:53 AM