none
Date format using space as date separator rather than forward slash! RRS feed

  • Question

  • Hi all,

    I'm new to Windows 7 (Home Premium 32-bit) and I just can't figure out what's going on here! Basically I want my short date format to be dd/mm/yyyy (UK format) e.g. 05/11/2010, but when I key a date into Excel 2002 it is appearing as 05 11 2010. In Control Panel I have the short date format set to ddd dd/MM/yyyy and the example is shown as Fri 05/11/2010, but in Excel all the date formats are shown with space separators, e.g. 14 03 2001! I don't think it's an Excel problem though as in Windows Task Scheduler the dates are shown with spaces there e.g. '19:25 on Mon 01 11 2010'. The date by the clock though is shown correctly with slash separators!

    I know in Windows XP you can select the date separator from a drop-down list, but this option seems to be absent in Windows 7. Under HKEY_CURRENT_USER\Control Panel\International in the registry, sDate was set to a space, but changing that to a slash (and rebooting) didn't fix the problem.

    Does anyone have any ideas please what's wrong and how to fix it?

    Thanks
    Steven
    Sunday, November 7, 2010 12:56 PM

Answers

  • Hi Steven,

     

    Thanks for the post!

     

    When you set the Short date to ddd dd/MM/yyyy, the date by the clock is shown with slash, however, the date in Task Scheduler doesn’t show the slash. This behavior is by design. When you double click the time and the trigger tab (for example) in task scheduler, the details are shown with slash.

     

    When you change the Short date to dd/MM/yy, the date in the Task Scheduler and the clock become the same.

     

    For the Excel date problems, I recommend you ask this question in Office Forum.

     

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other communities who read the forums regularly can either share their knowledge or learn from your interaction with us. 

     

    Thanks for your understanding and cooperation!

     

    Best Regards,

    Miya Yao

     


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, November 9, 2010 3:29 AM
    Moderator

All replies

  • Hi Steven,

     

    Thanks for the post!

     

    When you set the Short date to ddd dd/MM/yyyy, the date by the clock is shown with slash, however, the date in Task Scheduler doesn’t show the slash. This behavior is by design. When you double click the time and the trigger tab (for example) in task scheduler, the details are shown with slash.

     

    When you change the Short date to dd/MM/yy, the date in the Task Scheduler and the clock become the same.

     

    For the Excel date problems, I recommend you ask this question in Office Forum.

     

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other communities who read the forums regularly can either share their knowledge or learn from your interaction with us. 

     

    Thanks for your understanding and cooperation!

     

    Best Regards,

    Miya Yao

     


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, November 9, 2010 3:29 AM
    Moderator
  • Hi Miya,

     

    Sorry for the delay, for some reason my alerts weren't confirmed - sorted now.

     

    Can I please ask why the Task Scheduler is designed not to show the slash if that's how I've set my date format in Control Panel?

     

    I see that the date is shown with a slash when I edit a trigger, however the full date isn't shown in the box - all I can see is Mon 15/11/201 - I think this needs correcting!

     

    I have since found out that the character you use after the 'ddd' (a space in my case) is used as the date separator in the Task Scheduler and also in Excel, regardless of whether you choose dd/mm/yyyy or dd.mm.yy for example - this doesn't seem right to me.

     

    Please advise.

     

    Thanks

    Steven

    • Proposed as answer by lengoldstein Saturday, September 29, 2012 12:44 AM
    Friday, November 12, 2010 10:00 PM
  • Steven, that date...er...feature in Win7 was driving me nuts.  Excel sheets in my wife's computer showed spaces instead of slashes in the dates, while my computer, with a seemingly identical setup and set of programs, showed slashes.  I would never have guessed that the Short Date setting in Region and Language would have changed Excel's universal date formats!  To quote you, "this doesn't seem right to me" either, but at least know I know how to deal with it, and have done so.  Thanks so much!

    Lenny

    Saturday, September 29, 2012 12:51 AM
  • Thank you so much for that reply.  I know this was ages ago, but this just happened on my legacy W7 machine and I would have never come up with this.  I put in a custom Short Date so the Day would show on my taskbar (ddd mm/dd/yy,) that was the cause all along.

    I will also put my vote in for how this seems somewhat illogical.

    Thursday, May 31, 2018 12:53 PM