locked
"The filename, directory name, or volume label syntax is incorrect." when opening a document from the search results RRS feed

  • Question

  • This is really driving me nuts, as the problem is present on both my home desktop and home laptop (both Windows 7 Ultimate).

    When I type a search query directly in the Start Menu's "Search program and files" text box, I get what I call a "first search results" list. If I single-click one of these entries, or right-click then select the very first option in the context menu I get:

    caption: <absolute path>

    <absolute path>

    The filename, directory name or volume label syntax is incorrect.

    This mostly occurs with documents (Word, Excel, Acrobat...), not with e.g. music files.

    If I right-click then select "Open" or "Edit" or "Open with..." then I can successfully open the document in either the default or another application.

    If I click on "See more results" I get a "<query> - Search results" window where everything works properly.

     

    Any clue?

    Sunday, January 22, 2012 8:05 AM

All replies

  • Reset your search index by going to add / remove programs > add/ remove features > untick search restart and go back to the features folder and retick.

     

    Rebuilding index may take time but will sort your problem.


    Professional In Computing - Please Contact for Help. Please remember to click “Mark as Answer” on the post that helps you This can be beneficial to other community members reading the thread.
    Sunday, January 22, 2012 11:03 PM
  • I have reset (rebuilt from scratch; takes in the order of a couple days to rebuild) the index quite a number of times, for instance when changing the way file types are handled, but the problem stuck.

     

    Note that I have the "UNC add-on" installed that allows me to index the contents of mounted network shares, dunno if that can have any relationship.

    I'm not sure if I described my problem in an appropriate manner, but here it is again in other words: the search results are correct, it's just that the UI refuses to "launch" (ShellExecute) the results that are shown in the result list directly.

    I can supply a capture of the issue made with Problem Step Recorder, if you send me your email address at live.nospam4sba@spamgourmet.com.

     

    Monday, January 23, 2012 12:58 PM
  • Ah right! I underatand your problem now. Try sfc/scannow in the command promopt (admin rights) this should fix the search ui file which is acting up.
    Professional In Computing - Please Contact for Help. Please remember to click “Mark as Answer” on the post that helps you This can be beneficial to other community members reading the thread.
    Monday, January 23, 2012 6:03 PM
  • SFC's not a magic wand ;-)

    After:

    C:/Users/THEADM~1> sfc /scannow

    Beginning system scan.  This process will take some time.

    Beginning verification phase of system scan.
    Verification 100% complete.

    Windows Resource Protection did not find any integrity violations.

     

    The problem's still there!

     

    Monday, January 23, 2012 8:40 PM
  • Check that the indexing service is running, If problems still persist i would try to repair install windows. Best way. You can back up your files to digital media.

    Solution:

    And check The filename, directory name or volume label syntax is correct. Meaning check the filename, where it is stored, or the drive letter.

    Option 1:

    Try dragging your files to desktop and see if it works,

    Option 2:

    Try going to Start Menu > Computer > Right Click Manage > Disk Management (only do this if you have more than one disk is to change the drive letter and restart)


    Professional In Computing - Please Contact for Help. Please remember to click “Mark as Answer” on the post that helps you This can be beneficial to other community members reading the thread.
    • Marked as answer by Juke Chou Friday, February 3, 2012 3:56 AM
    • Unmarked as answer by sba923 Friday, February 3, 2012 7:36 AM
    Tuesday, January 24, 2012 10:05 AM