locked
Display driver not being installed RRS feed

  • Question

  • I have a new model of desktop Dell OptiPlex 5060, which I'm trying to image with an existing Windows 10 ts.  I've been using the "Total control" method outlined at https://deploymentresearch.com/Research/Post/325/MDT-2013-Lite-Touch-Driver-Management for years, but with this new model the display driver is not being installed.  That is, once the machine is imaged, I open Device Manager and it says it's using the "Microsoft Basic Display Adapter".




    To be clear, I've download the 5060 version A04 (01/22/2019) .cab, from https://www.dell.com/support/article/ca/en/cadhs1/sln312414/dell-command-deploy-driver-packs-for-enterprise-client-os-deployment?lang=en, imported the .cab to a new folder under the Out-of-Box Drivers node called OptiPlex 5060 and I have the ts configured as shown here and here.  In the BDD.log it shows DriverGroup001 being set correctly and I can also see the display drivers being injected here.

    Does anyone know where to go from here?

    Thank so much for the help.

    Tuesday, March 5, 2019 10:09 PM

All replies

  • Hi try

    your-file.exe /?

    For examble you can install your driver as an application with the /s parameter.

    Hope this helps!


    Toni

    Wednesday, March 6, 2019 9:46 AM
  • The driver for some reason just may not be installing. I have this issue with Dell drivers sometimes as well. You may need to get an earlier version of the driver and try. You can also download the specific driver listed instead of the full cab file and try it.

    I would also just use the individual driver downloads and then make specific folders for each under the computer model, IE Video, Network. Easier driver management is you need to change any out.

    There is a way you can test driver installs as well. If you notice in many dell drivers you will see a file called dpinst.exe. Its a driver installer like pnputil. You can copy all drivers to a computer and run that dpinst.exe to see what installs and what doesnt. You will make a config file to tell the exe what to do such as force driver install or scan hardware to match drivers.

    Wednesday, March 6, 2019 1:02 PM
  • From my experience with Dell CAB files, if you associate it properly and drivers apply, yet you get a generic display driver (or in some cases Bluetooth or other driver showing generic), then likely it is not contained in the CAB.

    I find myself having to add an application for that driver. Usually an MSI for display drivers. I just test/find the switch then add an application in the Task to run in the State Restore section (on the desktop). If they are MSI or exe based driver installations, then they cannot run in WinPE but only in the OS at the desktop.

    Thursday, March 7, 2019 4:35 PM
  • Thanks for all the helpful replies. 

    I've also tried downloading the individual driver from Dells site but it fails to install also.  And the previous version driver fails with the error "The installation package is not supported by the processor type"

    @the1rickster, I have verified the driver is included in the .cab so I know it's there and the log confirm it's being injected.  I'll try installing it with an app.

    I also tried a support chat with Dell, he was not helpful, in the end he said I need to use Dells OEM image, not the out of box Windows 10 1607 iso 


    Friday, March 8, 2019 7:11 PM
  • Based on that error message I would just make sure when you are filtering for drivers on Dell's site make sure you are selecting the type that matches the OS, x64 or x86.
    Friday, March 8, 2019 11:39 PM
  • I've been having a heck of a time with the Optiplex 5060. I have a Task Sequence that deploys a customized Windows 10 x64 1803 WIM through SCCM. I have the most current ADK that supports 1803. At first, I had a difficulties getting the unit to PXE boot through the network, but I fixed that by importing updated Intel Network drivers from Intel's site.

    What happens now is that the image processes and installs but NONE of the drivers are being installed. This can be seen at the Device Manager with multiple missing devices and no ethernet connection. I'm using a "Total Control" like method by using Apply Driver packages based on the System Model Variable, this has worked fined with all models except the 5060s. It even works fine with the new 7490 laptop models. I'm at a loss because I'm using the Dell Driver Cab A04 and this has never happened before.

    Thanks also, for any help that may be provided.

    Monday, March 11, 2019 3:58 PM
  • Just an update on this, after updating the 5060 to Windows 10 1803 Device Manager now says the display adapter is an "Intel UHD Graphics 630".  I'll update my task sequence to deploy 1803 instead of 1607, something I need to do anyway, and my problem should be solved.
    Friday, March 22, 2019 3:31 PM
  • Hi Jim. Have you confirmed SCCM is identifying the 5060 as a 5060? Years ago we were buying Acer desktops/laptops and the model number was not populated in WMI therefore MDT (in my case) was not detecting my model properly.  I had to write a userexit script to detect the model based on the first 8 characters of the MAC and use that to populate a custom MDT variable called ModelAlias (which you can see in the screenshots in my first post) and use this ModelAlias variable to populate the DriverGroup001 task sequence variable.

    I haven't had this issue since going 100% Dell but perhaps the 5060 you have there has this problem.

    Friday, March 22, 2019 3:42 PM