none
Team resources : nothing to do... RRS feed

  • Question

  • Hi,

    I'm testing the use of Team resources in PWA 2010.

    I created several Team resources. I assigned them to different tasks of a project, saved and published the project.

    When I connect on PWA as one of these team members, in my Tasks page, Add task.... I get nothing : the page is empty.

    What did I miss?

    Thanks

     

    Friday, February 18, 2011 2:13 PM

Answers

  • WLID1966,

    Just to verify, I'm going to list all settings again.

    For the Team Resource:

    • Go to Resource Center -> New Resource
    • Type should be Work
    • Budget and Generic should NOT be selected
    • Enter a display name
    • Leave all other options default (Default Assignment Owner should be the team resource itself, or blank if this is a new resource; leave the Resource Departments field blank)
    • Scroll down to the Team Details section
    • Select the Team Assignment Pool checkbox
    • In the Team Name field, select the team it belongs to

    For the normal resources

    • Type should be Work
    • Budget and Generic should NOT be selected
    • The Team Assignment Pool checkbox should NOT be selected
    • In the Team Name field, select the SAME value as your team resource

    Once you have made all these changes, you have to open your project again and save and publish it again for these changes to apply.

    Some other things to verify:

    • Make sure the security group the resource belong to have the permission 'Self-assign Team Tasks'
    • In your project, open the Build Team window, and make sure the Team Resource has booking type Committed
    • In your project, make sure the Team Resource is assigned to the task
    • In your project, make sure the task is set to automatically scheduled
    • In your project, make sure the Publish flag for the task is set to Yes
    • In PWA, go to Server Settings -> Close Tasks To Update, select the project and make sure the tasks are NOT selected (if so, unselect and submit and publish)

    After making any changes, make sure to re-open and publish the project again!

    I hope this helps,
    Hans


    My EPM blog: Projectopolis
    • Marked as answer by WLID1966 Saturday, February 19, 2011 9:32 AM
    Saturday, February 19, 2011 9:03 AM
    Moderator

All replies

  • Hi WLID1966,

    Have you entered the Team field for both the team resources and all other resources?
    Have you selected the checkbox 'Team Assignment Pool' for the Team resources?
    Are you looking at the correct page? PWA -> My Work -> Tasks -> Insert Row -> Insert Team Tasks?

    Please verify these settings.

    I hope this helps,
    Hans


    My EPM blog: Projectopolis
    Friday, February 18, 2011 3:15 PM
    Moderator
  • Hi Hans,

    << My Work -> Tasks -> Insert Row -> Insert Team Tasks>>

    Yes, I did everything.... :-(

     

    Friday, February 18, 2011 4:10 PM
  • Hi,

    are your team members also members of project team? This seems to be a prequistite in 2010, at least it was in RC and RTM.

    Regards
    Barbara

    Friday, February 18, 2011 5:05 PM
    Moderator
  • Hi,

    sorry, please ignore my last post. Team member has to be member of project team to get no error message while self-assigning. It was not necessary to have the tasks displayed at all - I recalled wrong initially.

    Has team resource booking type "Committed" in your project?

    Barbara

    Friday, February 18, 2011 6:19 PM
    Moderator
  • Hi Barbara,

    All my resource have Booking type : Committed.

    I tried to add members of the Team resource in the Build Team (which is quite ridiculous) but the Team Tasks page is still empty for each member of the Team resource...

    ;-(

     

    Friday, February 18, 2011 7:02 PM
  • Hi,

    regarding adding Team Members to project team, have a look at http://social.technet.microsoft.com/Forums/en-CA/projectserver2010general/thread/e812db48-eba3-4fac-8bc9-e2babe1cad81 and the other links I posted there. There will be a change at some time, perhaps was already included in any CU. I can't remember to have read about it in KB articles.

    Can you see Team resource's tasks in Resource Assignments? (See if it was published sucessfully). Are you trying with the same project? Then you could try to force a re-publish be setting publish first to "No".

    I am struggling a bit with your initial question "I created several Team resources. I assigned them to different tasks of a project, saved and published the project. .... When I connect on PWA as one of these team members, in my Tasks page, Add task.... I get nothing : the page is empty". Perhaps it is an issue of my English: Do you try to see team tasks as Team resource (marked as 'Team Assignment Pool')?

    Regards
    Barbara

    Friday, February 18, 2011 7:35 PM
    Moderator
  • Barbara,

    I created a Team resource name "Development Team" which includes several nominative resources : Julia, Peter, Eric.

    I assigned the "Development Team" to a development task.

    I connected to PWA as Julia and expected to find this task in the Tasks -> Insert Row -> Insert Team Tasks page. But this page is empty.

    I added Julia in the resource list of this project, without any assignment on a task.

    I connected again to PWA as Julia and expected to find this task in the Tasks -> Insert Row -> Insert Team Tasks page. But this page is still empty.

    ??

     

    Friday, February 18, 2011 8:16 PM
  • Hi WLID1966,

    Can please describe in detail what checkboxes you have enabled to make this Development resource a 'Team' resource?

    • Is the type set to Work?
    • Did you select the generic checkbox? Make sure this checkbox is NOT selected!

    And what configuration changes did you make to a resource to 'include them in the team'?

    Hans


    My EPM blog: Projectopolis
    Friday, February 18, 2011 10:56 PM
    Moderator
  • hi Hans,

    Yes, my Team resourcess such as Development Team have the Work Type.

    I also selected the Generic check box

    To includee the human resource in the Team, I used the "Equipe Name" field where I said Julia is in the Development Team for ex.

    I tried again without the generic check box, but no avail ;-(

    The Team Tasks page is still empty for every member of team resource

    Saturday, February 19, 2011 8:33 AM
  • WLID1966,

    Just to verify, I'm going to list all settings again.

    For the Team Resource:

    • Go to Resource Center -> New Resource
    • Type should be Work
    • Budget and Generic should NOT be selected
    • Enter a display name
    • Leave all other options default (Default Assignment Owner should be the team resource itself, or blank if this is a new resource; leave the Resource Departments field blank)
    • Scroll down to the Team Details section
    • Select the Team Assignment Pool checkbox
    • In the Team Name field, select the team it belongs to

    For the normal resources

    • Type should be Work
    • Budget and Generic should NOT be selected
    • The Team Assignment Pool checkbox should NOT be selected
    • In the Team Name field, select the SAME value as your team resource

    Once you have made all these changes, you have to open your project again and save and publish it again for these changes to apply.

    Some other things to verify:

    • Make sure the security group the resource belong to have the permission 'Self-assign Team Tasks'
    • In your project, open the Build Team window, and make sure the Team Resource has booking type Committed
    • In your project, make sure the Team Resource is assigned to the task
    • In your project, make sure the task is set to automatically scheduled
    • In your project, make sure the Publish flag for the task is set to Yes
    • In PWA, go to Server Settings -> Close Tasks To Update, select the project and make sure the tasks are NOT selected (if so, unselect and submit and publish)

    After making any changes, make sure to re-open and publish the project again!

    I hope this helps,
    Hans


    My EPM blog: Projectopolis
    • Marked as answer by WLID1966 Saturday, February 19, 2011 9:32 AM
    Saturday, February 19, 2011 9:03 AM
    Moderator
  • Thanks a lot Hans, that works!

    The Self-assign Team Tasks permisson was missing for each of the resources.

    For the Team Resource, don't you think it's redoudant to do that: "In the Team Name field, select the team it belongs to"?

    Thanks again

    Saturday, February 19, 2011 9:40 AM
  • < to add members of the Team resource in the Build Team>

    Eventually, this operation is useless (hopefully)!

     

    Saturday, February 19, 2011 9:57 AM