none
Windows 7 DNS issues - Unable to ping any host name including localhost

    Question

  • Hi,

    Firstly I am no n00b when it comes to operating systems.  I have been playing this game for more years than I care.  However this thing has got me well and truly stumped.

    Not too long ago I believe my machine must have been hit with a rootkit virus of some sort.  I run AVG but for reasons it did not pick this up.  None the less, this has now been cleaned.

    Initially it took out my network cards, my wirless, my firewall, renamed my machine with no name, and all sorts of fun things.  Good times, but now mostly resolved.  What I still don't have is internet access.

    I am connected to my router (along with my other equipment), trusting in DHCP which works as it should.  I am running Windows 7 home edition (64 bit).  Now the fun part.....I am unable to ping anything by hostname.  Absolutely nada.  I can't can't ping localhost "Ping request could not find host localhost. Please check the name and try again.".  In fact I can throw anything I like in the host file and it will come up with the same error. 

    I can 100% ping everything via IP address, no issues.

    I get 100% responses from nslookup.

    I am unable to ping by hostname only.  This is somewhat troublesome as this prevents me from getting to the internet and other things.

    I have reset winsock, I have reset tcp, I have uninstalled both my nics and reinstalled them, I have uninstalled SP1 and reinstalled it.  I suspect it may be a dns client dll, but thought that I may throw this out for discussion.  I don't particularly want to reinstall the OS.....so technical gurus....open to thoughts and suggestions.

    Bov23

    Tuesday, October 15, 2013 11:49 AM

All replies

  • Have tried to run the System File Checker tool?

    Start --> Run --> Cmd and press Enter.

    sfc /scannow

    Tuesday, October 15, 2013 2:11 PM
  • Thanks for the advice, I forgot all about that little command.  Unfortunately it returned with "Windows Resource Protection did not find any integrity violations".....

    *sigh*

    So....gotta be something else.  I will keep looking.  Suggestions are definitely welcome.....grrrr

    Wednesday, October 16, 2013 8:35 AM
  • Hi,

    First I recommend you try the following method.

    Under the DNS tab of the properties of TCP/IPv4 you need to change the radio button to "Append these DNS Suffixes in order" AND THEN click "Add" and for the suffix just enter a period.  "." (without the quotes).

    Meanwhile, please refer to the similar thread.

    Unable to ping local machines by name in Windows

    http://superuser.com/questions/476417/unable-to-ping-local-machines-by-name-in-windows-7

    If the issue persists, please use Network Monitor to capture the package for the nslookup and Ping individually, then upload the log to SkyDrive and post the link here.

    http://www.microsoft.com/en-us/download/details.aspx?id=4865

    Regards,

    Ada Liu


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Thursday, October 17, 2013 9:40 AM
  • Hi Ada,

    Thanks for the link.  I actually looked at that one early in the piece.  The difference between mine and the one in the link is my machine does not know how to handle a hostname regardless of the DNS setup.  I did make the changes specified, however it made no difference.  Now here is the odd thing....I ran the Net Mon and captured a ping of 127.0.0.1, no problems.  When I pinged localhost and it came up with "Ping request could no find host localhost.  Please check the name and try again.", it actually did not even register an event in the net mon.  Not a single iota of an acknowledgement that it was even hitting the network anywhere.  The system does not know how to handle a ping to a host, and it is not going anywhere to look for it.  Very very odd.

    So....what does this tell us.....besides how odd it is.  What I really dislike about Microsoft at the moment is you don't even get the media (DVD) to run a repair when you buy your systems anymore.  I would love to have a home premium DVD and perform a full repair *sigh*


    • Edited by Bov23 Tuesday, October 22, 2013 9:39 AM
    Tuesday, October 22, 2013 9:38 AM
  • I had a similar issue. I wasn't able to ping any names, only IP's. DNS was apparently running in the background, ipconfig /displaydns was returning DNS queries, although telnet on port 53 was not working to the DNS server, I was receiving error "An invalid argument was supplied telnet on port 53" . I was also able to log in with domain credentials though.

    In my case the issue was with User Access Control. Somebody enabled it, and didn't reboot the server immediately after that action. Most probably some other actions were performed on the server, that were pending also reboot, and from that point UAC was acting recklessly not allowing users to perform basic actions, like pinging names or telneting the DNS server on port 53.

    I have noticed by chance, after century-old battles that lasted almost 2 days that I could not access directly (an access denied message was received)  one of the system folders, C:\Windows\temp. It is the normal behavior when UAC is enabled. I have checked before the UAC settings, and the slide bar was all the way down(disabled), but apparently this feature was still "live".

    I've enabled it back(moved the slide bar up), rebooted the server and that was it, everything went back to normal. I have disabled it again, afterwards, because we need it like that, and reboot immediately the server and things were also ok.

    So..UAC... a big NO for Microsoft ! 

    Thursday, September 14, 2017 12:24 PM