550 5.7.1 NDR's as mail volume from IIS Virtual SMTP server to Exchange 2010 increases RRS feed

  • Question

  • We have a virtual win 2008 server that has a Virtual SMTP server running via IIS. A separate application on this server drops emails in the pickup directory to forward to our Exchange 2010 environment and this works fine. The odd issue is that as the volume of messages being dropped in the pickup directory increases to over around 500 per minute we see a huge increase of bounced emails ending up in badmail directory on this server. The NDR we receive from our exchange environment states the following

    550 5.7.1 Anonymous clients does not have permissions to send as this sender

    As soon as we throttle this application the issue stops. And the same emails that bounced can be resubmitted with no issues

    This particular virtual SMTP instance sends to only a handful of mailboxes in our organization, but it does send a lot of messages

    We currently have a receive connector for all internal relay servers, and this server is called out in the accepted IP range and the message rate is sent to unlimited. Here are the edited version of the details of one of the internal relay receive connectors on one of our hub transport servers. Is there something we have setup on the these connectors that might be causing this?

    RunspaceId                              : 1e06e317-da65-4916-9b2c-e1253b4b550b
    AuthMechanism                           : None
    Banner                                  :
    BinaryMimeEnabled                       : True
    Bindings                                : {}
    ChunkingEnabled                         : True
    DefaultDomain                           :
    DeliveryStatusNotificationEnabled       : True
    EightBitMimeEnabled                     : True
    BareLinefeedRejectionEnabled            : False
    DomainSecureEnabled                     : False
    EnhancedStatusCodesEnabled              : True
    LongAddressesEnabled                    : False
    OrarEnabled                             : False
    SuppressXAnonymousTls                   : False
    AdvertiseClientSettings                 : False
    Fqdn                                    : HT02.corp.com
    Comment                                 :
    Enabled                                 : True
    ConnectionTimeout                       : 00:10:00
    ConnectionInactivityTimeout             : 00:05:00
    MessageRateLimit                        : unlimited
    MessageRateSource                       : IPAddress
    MaxInboundConnection                    : 5000
    MaxInboundConnectionPerSource           : 100
    MaxInboundConnectionPercentagePerSource : 100
    MaxHeaderSize                           : 64 KB (65,536 bytes)
    MaxHopCount                             : 60
    MaxLocalHopCount                        : 8
    MaxLogonFailures                        : 3
    MaxMessageSize                          : 30 MB (31,457,280 bytes)
    MaxProtocolErrors                       : 5
    MaxRecipientsPerMessage                 : 200
    PermissionGroups                        : AnonymousUsers
    PipeliningEnabled                       : True
    ProtocolLoggingLevel                    : Verbose
    RemoteIPRanges                          : REDACTED
    RequireEHLODomain                       : False
    RequireTLS                              : False
    EnableAuthGSSAPI                        : False
    ExtendedProtectionPolicy                : None
    LiveCredentialEnabled                   : False
    TlsDomainCapabilities                   : {}
    Server                                  : HT02
    SizeEnabled                             : EnabledWithoutValue
    TarpitInterval                          : 00:00:05
    MaxAcknowledgementDelay                 : 00:00:30
    AdminDisplayName                        :
    ExchangeVersion                         : 0.1 (8.0.535.0)
    Name                                    : Internal Relay
    DistinguishedName                       : REDACTED
    Identity                                : HT02\Internal Relay
    Guid                                    : a1f5af2e-6d53-4cb9-80b6-d19aab6879b4
    ObjectCategory                          : REDACTED
    ObjectClass                             : {top,msExchSmtpReceiveConnector}
    WhenChanged                             : 6/20/2014 11:12:17 AM
    WhenCreated                             : 2/18/2011 10:15:58 AM
    WhenChangedUTC                          : 6/20/2014 3:12:17 PM
    WhenCreatedUTC                          : 2/18/2011 3:15:58 PM
    OrganizationId                          :
    OriginatingServer                       : dc04.corp.com
    IsValid                                 : True

    • Edited by Iczersigma Tuesday, June 24, 2014 6:23 PM
    Tuesday, June 24, 2014 6:19 PM

All replies

  • Are you sure that this receive connector is actually being selected for the traffic?  Enable SMTP protocol logging on all your receive connectors, then look at the protocol logs for more clues.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Tuesday, June 24, 2014 8:06 PM
  • Hello,


    Thank you for your post.

    This is a quick note to let you know that we are performing research on this issue.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Simon Wu
    TechNet Community Support

    Thursday, June 26, 2014 3:08 AM
  • Hi, according to your description, the issue occurs when increasing the volume of messages to over around 500 per minute.

    I think we can check the parameter PickupDirectoryMaxMessagesPerMinute by using command:

    Get-transportserver "Type the server name" | ft *pickup*

    And we can increase the max volume, use this command:

    Set-Transportserver "Type the server name" -PickupDirectoryMaxMessagesPerMinute 1000

    For more details, please refer to this article:


    Thursday, June 26, 2014 7:07 AM
  • We aren't using the pickup directory on the hub transport servers directly, we are using an W2K8 server running a virtual SMTP server via IIS and using the pickup directory on that server to send to our Exchange environment. I'm not 100% sure why we don't use the pickup directory on hub transports directly besides the fact that it's always been this way (Maybe it makes it easier to remediate bounces due to the bad mail folder?).

    Per Ed Crowley's suggestion I've turned up logging on the receive connector we setup as a relay on each hub transport. Not sure if any other diagnostic logging would help as well but I'm going to start there.

    Monday, June 30, 2014 2:15 PM
  • So for some of the messages that are getting bounced I'm seeing the following

    A parsing error has occurred: MIME content error: Single text value size (32781) exceeded allowed maximum (32768).

    These aren't part of the messages that get bounced when the volume increases, I have to wait until tomorrow for that application to have data to dump as it pulls info from the previous work day.

    In regards to the MIME error, does anyone know where that info is set? I did a quick search and I couldn't find anything.

    Monday, June 30, 2014 8:18 PM
  • How large are the affected messages? And please check the size limit on the relay connector. It seems that the message is too large.
    Tuesday, July 1, 2014 7:48 AM
  • The max message size is set to 30MB, the messages getting the MIME error are between 65-72KB. So it's not a setting on the connector, mailbox, or org but something else that controls MIME size limits, which I can't seem to find.
    Tuesday, July 1, 2014 1:28 PM
  • The pickup directory will check for new email messaged every 5 seconds. I think the Exchange server considers that all of the items in the folder is "one email" and it exceeds the size limit(500*65=32500). So we get this issue.

    Wednesday, July 2, 2014 7:03 AM
  • Just to clarify, this is not a pickup directory on an Exchange server but on a Windows 2008 server running an SMTP Virtual server in IIS 6.0. The problem happens only when the message volume from this server to Exchange increases to over ~500 messages a minute. When that happens the messages get bounced from Exchange with the following info in the NDR

    550 5.7.1 Anonymous clients does not have permissions to send as this sender

    If we resubmit all the bounce messages at a lower volume per minute we do not see the issue. I'm still working on replicating the issue now that we have logging turned up on the receive connectors.

    In addition some messages are being bounced with the following NDR message

    554 5.6.0 Invalid message content

    These messages are always between 65-70KB and have around 200 recipients

    In the Exchange receive logs for the receive connector for these messages we see the following message (with different sizing)

    A parsing error has occurred:MIME content error: Singletext value size (32781)exceeded allowed maximum (32768).

    The messages dropped in this pick-up  directory can be anywhere from 1KB to 10MB, so it's not that it's viewing each batch as a single email but something different with this particular email. I've tried searching for where to increase this MIME value but can't find out where it is stored in Exchange.

    Wednesday, July 2, 2014 2:18 PM
  • We can check the message throttling options on Receive Connectors:

    Understanding Message Throttling


    Thursday, July 3, 2014 2:05 AM
  • Those settings are listed in the first post, as far as I can tell I don't see personally see anything list that might contribute to the issue but I would greatly appreciate it if someone looked over it.
    Thursday, July 3, 2014 4:10 PM