locked
Windows SteadyState is not correctly installed. Repair or reinstall the application RRS feed

  • Question

  •  

    I created some limited user accounts and forgot to log into them first before editing their Start Menu / Programs shortcuts list from my admin account. After a reboot, this created duplicate accounts for each user account and would not let me log into my regular admin account. So I restored to a prior point using VCOM’s Recovery Commander. This fixed the user account duplicates, but SteadyState was installed set to accept all changes to the cache file after reboots.  SteadyState would not then work. So I uninstalled it, reinstalled and get the following error message:

     

    “Windows SteadyState is not correctly installed. Repair or reinstall the application.”

     

    I went to this post http://forums.microsoft.com/WindowsToolsandUtilities/ShowPost.aspx?PostID=2219665&SiteID=69 (I crashed SS) which suggests deleting the following two registry branches: 

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Computer Toolkit

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Windows SteadyState

     

    I have the first branch, but not the second.

     

    Next I uninstalled SteadyState & reboot. Then I reboot again into Safe Mode. I tried to install SS from my own account (an admin account) and get the message “The System Administrator has set policies to prevent this installation” and I cannot install SS from Safe Mode. The same thing happens when I log into the Administrator account in Safe Mode. I think SS is the culprit. Before SS, there was nearly 60 G of free space on my C drive. After SS there was about 30 G free space (which I expected). After uninstalling SS, there is still only 30 G of free space, which makes me think the SS cache file is still there even after the uninstall.

     

    Any help would be appreciated to get SS reinstalled and working. Thanks. Lionman

     

    Sunday, June 22, 2008 10:02 AM

Answers

All replies

  • After checking the error message, I have noticed that this issue has once been discussed in the forum and it was resolved. Therefore, I'd like to include the link below:

     

    lost SteadyState access during installation

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=2318942&SiteID=17

     

     

    Hope this helps!

     

    Tuesday, June 24, 2008 8:29 AM
  • Hello Sean Zhu,

    I read the link, which did not help. There was no similar error message in that link. I have searched the forum for a solution but so far have found none.

    I have uninstalled SS through Add/Remove Programs. Then I checked Windows Installer Clean Up Utility, and SS was not there. Then uninstalled any remnants in the registry following the directions from this link: Windows Steady State 2.5 uninstall (New) at
    http://forums.microsoft.com/WindowsToolsandUtilities/ShowPost.aspx?PostID=2594927&SiteID=69  I deleted all "Windows SteadyState" registry entries and the Cache.wdp file from the C drive.

    Thinking SS was uninstalled and the problem fixed, I then tried to install it again through various means:
    If I try to install SS in the Administrator account, I get this error message:
    "The windows installer service could not be accessed. This can occur if you are running windows in safe mode, or if the windows installer is not correctly installed. Contact your support personnel for assisstance."
    ....or in my own name as administrator in safe mode
    "The system administrator has set policies to prevent this installation"

    In safe mode, I tried to access the program directly through its Program Files folder with SCTUI.exe (That was the fix through the link you gave) but get the same error message: “Windows SteadyState is not correctly installed. Repair or reinstall the application.”

     I also tried to go to some of the other files in the Program folder but was afraid to edit any of them without more expertise.

    I can only install SS in full windows through an admin account. When installed and trying to access the program, I get again: “Windows SteadyState is not correctly installed. Repair or reinstall the application.”
    After rebooting, I then get this error message: "An unexpepcted error occurred (0x80041002)" and the same not correctly installed error when trying to access the program.

    I feel like I am on an endless loop of failure. I have searched this forum with all my error messages but no  help. Most people just seemed to reformat.

    Your help would be greatly appreciated as it would take me weeks to reinstall the OS & all programs properly configured again.

    Thanks, Lionman2
    Tuesday, June 24, 2008 1:15 PM
  • For this error message, we can try the suggestions in the following knowledge base article:

     

    "The Windows Installer Service Could Not Be Accessed" error message when you install a program in Windows XP

    http://support.microsoft.com/kb/315353

     

    Also, you can check a recently resolved issue via the following link:

     

    How to uninstall VCF driver (VCFFltr.sys)  

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3471001&SiteID=17

     

    Wednesday, June 25, 2008 9:29 AM