locked
Outlook “We are unable to connect right now. Please check your network and try again later.” RRS feed

  • Question

  • Hello,

    We are experiencing a very nasty error when connecting from Outlook Client to O365 Exchange servers via a VPN connection over Juniper Pulse. The error message is “We are unable to connect right now. Please check your network and try again later.”

    The issue can be solved by manually restarting the NlaSvc service on the client. This however is only a workaround countermeasure. We are currently trying to find out the root cause.

    Is someone familiar with this error and what could be the cause ?

    Regards.

    Friday, January 20, 2017 2:34 PM

Answers

  • I know this is an old thread but in case there are still people looking it up.

    If you cannot see the key "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\NlaSvc\Parameters\Internet\EnableActiveProbing", make sure that you launch the registry editor with admin rights.

    A standard user doesn't have Read access to the Parameters key by default.

    • Marked as answer by Andy DavidMVP Saturday, February 1, 2020 1:37 PM
    Tuesday, March 19, 2019 12:47 AM

All replies

  • Hi CBBG,

    What's the version of your outlook client?

    Based on my searching, there is a blog descripts that some VPN would cause the issue on office 2013, the root cause of the issue seems to be that Office 2013 took a dependency on NLA (Network Location Awareness), and some VPN solutions do not work properly with NLA. More details for your reference: Office 2013 can not check in files when LAN does not have internet access or over some VPN's.

    Moreover, we can check the following registry key in client PC, and make sure the value is 1(Enabled). 

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\NlaSvc\Parameters\Internet\EnableActiveProbing

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Andy202a Thursday, January 16, 2020 9:46 PM
    Monday, January 23, 2017 6:19 AM
  • The version of the Outlook client is Microsoft Outlook 2013 (15.0.4859.1000) MSO (15.0.4859.1000) 32-bit

    Best regards.

    Monday, January 23, 2017 7:58 AM
  • The registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\NlaSvc\Parameters\Internet\EnableActiveProbing is not in the registry. What is the impact if it is not in the registry ?

    Actually I see only 3 entries at the NlaSvc\Parameters level

    (Default)

    ServiceDll

    ServiceDllUnloadOnStop

    Best regards.

    Monday, January 23, 2017 8:02 AM
  • Hi CBBG,

    The registry key is in "NlaSvc -> Parameters -> Internet", not in "NlaSvc -> Parameters", as below:

    It's used to identify the network’s connectivity status.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 23, 2017 8:26 AM
  • I am actually on the coporate LAN which might show differences at registry level. If I go to the registry

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\NlaSvc , I do not see an \Parameters\Internet subfolder

    In HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\NlaSvc\Parameters, I only see 3 entries:

    (Default)
    ServiceDll
    ServiceDllUnloadOnStop

    best regards.

    Monday, January 23, 2017 8:41 AM
  • Hello,

    You can try the Enable ActiveProbing method

    For this the mentioned registry key needs to be changed:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\NlaSvc\Parameters\Internet]

    "EnableActiveProbing"=dword:00000001

    To know more about this error in detail, follow the link:
    https://support.microsoft.com/en-us/help/3027491/-we-are-unable-to-connect-right-now-error-when-users-try-to-activate-office-365-proplus

    Thanks & Regards,

    Kelvin Howard

    Monday, January 23, 2017 12:49 PM
  • Hi CBBG,

    You can add the " Internet\EnableActiveProbing" key manually and check if any helps.

    Note: Before modifying the regedit, it's recommended to take a backup first.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Niko.Cheng Tuesday, February 7, 2017 3:11 AM
    Tuesday, January 24, 2017 9:12 AM
  • Hi,

    I noticed something here. I don't see "NlaSvc\Parameters\Internet\EnableActiveProbing" under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services in my machine. In this case, what is being considered by Outlook to consider that it's connected to Internet. 

    I tried a different option & it worked though it's not a fix. I disconnected from VPN & logged into my profile through a regular Internet connection. Then Outlook didn't throw the error & continued updating all emails. Then I connected to VPN. After also, Outlook worked perfectly fine. 

    Regards,

    Chandra


    Wednesday, July 12, 2017 10:41 AM
  • The problem could be with the VPN address. Check your Settings in Regedit. You can also use Microsoft Support and Recovery Assistant.

    You can download it from https://diagnostics.outlook.com

    Wednesday, July 12, 2017 12:35 PM
  • We had a similar error.

    Deleting the folowing keys fixed the error:
    Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet\UseOnlineContent
    Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Internet\UseOnlineContent
    Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Internet\UseOnlineContent

    Or set the value to 2

    More info:
     
    https://technet.microsoft.com/en-us/library/jj683102.aspx
    https://social.technet.microsoft.com/Forums/systemcenter/en-US/5cffd878-558c-43ac-b043-5889af5e9dca/allow-office-to-connect-to-the-internet-greyed-out?forum=officeitpro


    • Edited by superivo Friday, September 15, 2017 11:17 AM
    Friday, September 15, 2017 11:16 AM
  • For what little it is worth, having my user disconnect from our VPN, reverting her connection back to just her home internet, allowed the O365 authentication window to fully show up the next time we launched Outlook. After she logged in, she reconnected to our VPN and everything went back to working as desired.
    Friday, June 8, 2018 4:17 PM
  • It was our VPN. Thank you
    Tuesday, October 16, 2018 9:12 PM
  • I know this is an old thread but in case there are still people looking it up.

    If you cannot see the key "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\NlaSvc\Parameters\Internet\EnableActiveProbing", make sure that you launch the registry editor with admin rights.

    A standard user doesn't have Read access to the Parameters key by default.

    • Marked as answer by Andy DavidMVP Saturday, February 1, 2020 1:37 PM
    Tuesday, March 19, 2019 12:47 AM
  • Worked for me. The key was in 0, I changed to "1". Thank you very much.
    Friday, May 24, 2019 6:18 PM
  • For what little it is worth, having my user disconnect from our VPN, reverting her connection back to just her home internet, allowed the O365 authentication window to fully show up the next time we launched Outlook. After she logged in, she reconnected to our VPN and everything went back to working as desired.
    Hey just want to say thank you for this. This actually worked. I was racking my brain for weeks and I can't believe this actually worked. Even starting NLA service didn't work. It seems there was a prompt that was trying to come up but didn't come up. After I did your workaround, we got a prompt from our corporate O365 portal asking the user to authenticate. After the user authenticates, it says that the machine is now registered to the user and they can use company resources. After that it worked every time smoothly. I think it might be a configuration issue on our end but just wanted to say thank you and that this worked as a permanent solution once we were able to pull up that prompt and log in. Thanks again.

    • Edited by JCL315 Saturday, February 1, 2020 1:34 AM
    Saturday, February 1, 2020 1:34 AM
  • For me, all the suggestions above did not work. 

    I went to

    1. Close the Outlook services 
    2. Search for"Services" in Windows Search
    3. Open Services app
    4. Right click on "Network List Service" and click on "Properties"
    5. Change "Startup Type" to "Manual"
    6. Click on Ok 
    7. Right click on "Network Location Awareness" and click on "Restart"

    Now, open the Outlook, this problem should have been resolved now. 

    Thursday, April 16, 2020 6:30 AM
  • Thank you so much Ganesh, your solution was the only one that worked. All of the above had already been done and the problem still persisted 
    Tuesday, May 19, 2020 4:05 PM
  • Indeed, restarting the "Network Location Awareness" service solved this issue for me also. Thank you Ganesh!
    Thursday, May 28, 2020 6:46 AM
  • For me, all the suggestions above did not work. 

    I went to

    1. Close the Outlook services 
    2. Search for"Services" in Windows Search
    3. Open Services app
    4. Right click on "Network List Service" and click on "Properties"
    5. Change "Startup Type" to "Manual"
    6. Click on Ok 
    7. Right click on "Network Location Awareness" and click on "Restart"

    Now, open the Outlook, this problem should have been resolved now. 

    Tried this also, but Network Location Awareness is already set to Manual and still problem persists. I am running Express VPN and this might be the culprit. If I shutdown the VPN I can connect and then can work normally once Outlook is running. I have tried emailing their Support but they keep trying to point at Port 25 and I am pretty sure Exchange does not utilize this port since it is not doing POP mail.


    Sunday, June 7, 2020 4:59 PM
  • Tried all the above suggestions to no avail, but disconnecting from VPN (using openvpn client) and reconnecting fixed it.
    Monday, July 6, 2020 11:30 PM
  • Thank you Ganesh.  I changed mine to auto from manual at now it works.  I had the issue with no password outlook 2016
    Tuesday, July 14, 2020 4:56 PM
  • I was using Nordvpn and how to stop the service before I could input my password.
    Monday, July 27, 2020 1:37 PM
  • You cannot restart the network list service.  It says "windows could not stop the network list service the service cannot accept control messages at this time"

    Would like to get this user's copy of Office 365 buisness activated, but for christ sake it doesn't allow them to get on

    Wednesday, August 5, 2020 2:49 PM