locked
Files in doc libraries always open in Read-Only mode RRS feed

  • Question

  • I have inherited a WSS 3.0 environment.  Tons of document libraries.  Authentication is whack.  ISA FBA authentication, not integrated Windows authentication.  Anyway, most users are now Windows 7, which may have something to do with the root cause.  After we were upgraded to Windows 7, WebDav stopped working, but our servers are managed centrally by a different group and we can't do anything about that.  Users (including myself, and I have full access to everything) can upload new MS Office files without a problem.  However, when they open those same files, even if they check them out first, and even if they select Edit from the pop-up, they get a Read-Only version of the file and cannot save changes back to the library.  The file will even say Read-Only in the title bar.  I have no idea what is going on with this thing.  The users have Contribute permissions and are getting this on files that they themselves have uploaded.

    Any ideas?


    • Moved by Mike Walsh FIN Thursday, July 14, 2011 6:24 AM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Wednesday, July 13, 2011 5:49 PM

Answers

  • Hi,

    Which office version you are using ?

    Office 2003, 2007 or 2010 ?

    If Office 2003 is installed on the computer, follow these steps:

    1. Click Start, and then click Control Panel.
    2. Click Add or Remove Programs.
    3. In the list of currently installed programs, click Microsoft Office 2003, and then click Change.
    4. Click Add or Remove Features, and then click Next.
    5. Click to select the Choose advanced customization of application check box, and then click Next.
    6. In the Choose update options for applications and tools box, expand Office Tools, click the down arrow next to Windows SharePoint Services Support, and then click Run from My Computer.
    7. Click Update.
    If a 2007 Office suite is installed on the computer, follow these steps:
    1. Click Start, and then click Control Panel.
    2. Click Add or Remove Programs.
    3. In the list of currently installed programs, click Microsoft Office <var>suite</var> 2007, and then click Change.
    4. Click Add or Remove Features, and then click Continue.
    5. Expand Office Tools.
    6. Click the down arrow next to Windows SharePoint Services Support, and then click Run from My Computer.
    7. Click Continue.

    Please let us know the results.


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    • Marked as answer by Emir Liu Monday, July 25, 2011 5:23 AM
    Thursday, July 14, 2011 12:36 AM
  • In addition to Pratik's suggestion, you should know that SharePoint integration with Office does not work well with FBA, especially the older versoins (2003 and prior).

    The fundamental problem is that office client apps (more precisely, each process such as winword.exe) need to directly authenticate with IIS and using an FBA-design complicates this as the Office client can't easily accomodate this.

    Assuming you have at least Office 2007, you might find this blog helpful: http://sharepoint.microsoft.com/blog/Pages/BlogPost.aspx?PageType=4&ListId={72C1C85B-1D2D-4A4A-90DE-CA74A7808184}&pID=503.

    Hope this helps.


    Randy - http://sharepointhawaii.com/randywilliams
    • Marked as answer by Emir Liu Monday, July 25, 2011 5:23 AM
    Thursday, July 14, 2011 5:32 AM

All replies

  • Hi,

    Which office version you are using ?

    Office 2003, 2007 or 2010 ?

    If Office 2003 is installed on the computer, follow these steps:

    1. Click Start, and then click Control Panel.
    2. Click Add or Remove Programs.
    3. In the list of currently installed programs, click Microsoft Office 2003, and then click Change.
    4. Click Add or Remove Features, and then click Next.
    5. Click to select the Choose advanced customization of application check box, and then click Next.
    6. In the Choose update options for applications and tools box, expand Office Tools, click the down arrow next to Windows SharePoint Services Support, and then click Run from My Computer.
    7. Click Update.
    If a 2007 Office suite is installed on the computer, follow these steps:
    1. Click Start, and then click Control Panel.
    2. Click Add or Remove Programs.
    3. In the list of currently installed programs, click Microsoft Office <var>suite</var> 2007, and then click Change.
    4. Click Add or Remove Features, and then click Continue.
    5. Expand Office Tools.
    6. Click the down arrow next to Windows SharePoint Services Support, and then click Run from My Computer.
    7. Click Continue.

    Please let us know the results.


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    • Marked as answer by Emir Liu Monday, July 25, 2011 5:23 AM
    Thursday, July 14, 2011 12:36 AM
  • In addition to Pratik's suggestion, you should know that SharePoint integration with Office does not work well with FBA, especially the older versoins (2003 and prior).

    The fundamental problem is that office client apps (more precisely, each process such as winword.exe) need to directly authenticate with IIS and using an FBA-design complicates this as the Office client can't easily accomodate this.

    Assuming you have at least Office 2007, you might find this blog helpful: http://sharepoint.microsoft.com/blog/Pages/BlogPost.aspx?PageType=4&ListId={72C1C85B-1D2D-4A4A-90DE-CA74A7808184}&pID=503.

    Hope this helps.


    Randy - http://sharepointhawaii.com/randywilliams
    • Marked as answer by Emir Liu Monday, July 25, 2011 5:23 AM
    Thursday, July 14, 2011 5:32 AM