locked
New issue with windows 2012 R2 servers : No reboot after updates RRS feed

  • Question

  • Hi,

    First sorry for my english

    So I will try to explain my situation :

    - For me all was right on the other month

    - The issue occures only on windows 2012 r2 server

    - Server install update and tell us that it will reboot after 15 minutes but 15 minutes after nothing happen.

    All Wsus configuration are made by GPO:

    Can you tell me why nothing happen?

    Monday, December 21, 2015 9:54 AM

Answers

  • Fix released now:

    This update fixes the following issue with previous versions of the Windows Update Agent for Windows 8.1, Windows RT 8.1, and Windows Server 2012 R2:
    • Windows Update would sometimes not restart the computer as expected when the “Always automatically restart at the scheduled time” policy was set.

    Rolf Lidvall, Swedish Radio (Ltd)

    • Proposed as answer by Steven_Lee0510 Thursday, March 3, 2016 12:58 AM
    • Marked as answer by alain131284 Thursday, April 14, 2016 11:11 AM
    Wednesday, March 2, 2016 7:06 PM

All replies

  • Hi,

    Please try to enable the following group policy:

    Computer Configuration\Administrative Templates\Windows Components\Windows Update\Always automatically restart at the scheduled time

    Best Regards.


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, December 22, 2015 7:57 AM
  • Hi,

    Please try to enable the following group policy:

    Computer Configuration\Administrative Templates\Windows Components\Windows Update\Always automatically restart at the scheduled time

    Best Regards.


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    For me this setting is already done in french it correspond to "Toujours redémarrer automatiquement à l'heure planifié" and the setting indicate 15 minutes (this is the object of this topic).

    Thanks for this reply but try again :-D

    Tuesday, December 22, 2015 8:25 AM
  • Hi,

    If this policy is enabled, please try to disable the following policy:

    Computer Configuration\Administrative Templates\Windows Components\Windows Update\No auto-restart with logged on users for scheduled automatic updates installations

    If issue persists after disable this policy, please try to restart the server manually and monitor if this issue occurs again.

    Best Regards.


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, December 22, 2015 9:13 AM
  • Hi,

    If this policy is enabled, please try to disable the following policy:

    Computer Configuration\Administrative Templates\Windows Components\Windows Update\No auto-restart with logged on users for scheduled automatic updates installations

    If issue persists after disable this policy, please try to restart the server manually and monitor if this issue occurs again.

    Best Regards.


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    This setting is already configured in "Pas de redémarrage automatique avec des utilisateurs connectés pour les installation planifiées de mises à jour automatiques" (in french for me)

    This month for my dev and production servers groups I have been forced to manually restart each server.

    I don't want to do this all month... :'(

    Thanks for this new answer but it not seems to be the solution.

    Tuesday, December 22, 2015 9:20 AM
  • Howdy,

      I was comparing your OU Policy with ours and I see that you have the Install of updates disabled

    Computer Configuration\Administrative Templates\Windows Components\Windows Update\Configure Automatic Updates

    Install during automatic maintenance: "Box needs to be checked"


    Another issue might be if the DNS lookup for your WSUS host is misconfigured so your Domain member servers or workstations will never be able to reach the server.  For this ensure that the WSUS server is reachable via the CNAME that is entered.  Try entering the FQDN of the machine instead of the CNAME ie h~/WSUS.foo.com:8530 instead of h~/WSUS:8530 or even the IP (if it is static).


    Other than the above, your configuration looks very close to ours.  Our WSUS server policy does work to reboot all servers on multiple OSes.

    Wednesday, December 23, 2015 9:02 PM
  • First thanks for this reply.

    To my mind this is not the answer for our issue because all month before our servers restart/reboot as planified on GPO (15 minutes after installing update)

    Il have not configured a maintenance period so I don't want that installation and reboot occure during the default maintenance periode. That is why install during automatic maintenance is unchecked.

    For the other idea it is clearly not my solution because all server report everyday in wsus and they install updates like it is configure.

    My issue is that system tell me "I will reboot in 15 minutes to finalise installation of updates" and nothing happen after.

    Any new idea to help me?

    Thursday, December 24, 2015 7:36 AM
  • Is there anybody who can help me for this topic.

    I have already the same issue this month...don't let me restart manually all my servers please.

    Wednesday, January 20, 2016 3:40 PM
  • Hello,

    Your settings seems correct.

    First, I would recommend you to use the more recent version of Windows Server to edit the WSUS GPO.Settings are presented differently and editing from an older system can harm settings for new system.

    Did you have a 2012R2 Domain Controler to edit this settings ?
    Also, check in the link below if KB are installed on your system.

    I would suggest to follow this article, well written about this problem (help me in the past to solve the exact same problem as you )

    Bonne chance ! :)

    https://vnetwise.wordpress.com/2014/03/20/howto-dealing-with-windows-2012-and-2012-r2-windows-update-behavior-and-the-3-day-delay/


    http://blogs.technet.com/b/wsus/archive/2013/10/08/enabling-a-more-predictable-windows-update-experience-for-windows-8-and-windows-server-2012-kb-2885694.aspx



    Wednesday, January 20, 2016 3:58 PM
  • Hi,

    Yes I have configured all my Gpo for wsus on windows 2012 R2 DC.

    I'll read this tomorrow morning in details.

    I have not specified any maintenance period for the moment. Just tell restart after update on planified time (15 minutes)

    thanks

    Wednesday, January 20, 2016 4:09 PM
  • Hello,

    Your settings seems correct.

    First, I would recommend you to use the more recent version of Windows Server to edit the WSUS GPO.Settings are presented differently and editing from an older system can harm settings for new system.

    Did you have a 2012R2 Domain Controler to edit this settings ?
    Also, check in the link below if KB are installed on your system.

    I would suggest to follow this article, well written about this problem (help me in the past to solve the exact same problem as you )

    Bonne chance ! :)

    https://vnetwise.wordpress.com/2014/03/20/howto-dealing-with-windows-2012-and-2012-r2-windows-update-behavior-and-the-3-day-delay/


    http://blogs.technet.com/b/wsus/archive/2013/10/08/enabling-a-more-predictable-windows-update-experience-for-windows-8-and-windows-server-2012-kb-2885694.aspx



    Hi,

    I don't find the answer beacause if I read these two links I have maid a correct configuration.

    My windows 2012 system reboot after update but not windows 2012 R2. KB2885694 is installed on 2012 servers as a part of update rollup KB2883201. So windows 2012 should work like windows 2012 R2?

    I have no schedule maintenance window configured. But I have Deselect “Install during automatic maintenance” so it should work no?

    Please explain me.


    Thursday, January 21, 2016 11:15 AM
  • Just somes news about this topic.

    This month I have noticed that I've windows 2012 R2 that restart after updating and other that tell the will restart but don't really restart after.

    I've cheked all gpo settings but nothing explain why one server restart after and the other don't restart

    I've check that they are in the same OU in active directory...nothing too

    I've check last updates...nothing too

    For information, these updates were install on the 21 of october and after this patch management non restarting server appears. :

    KB3083711

    KB3080446

    KB3093983

    KB3097666

    KB3088195

    KB3042058

    Is there anybody with an idea to help me?


    • Edited by alain131284 Tuesday, January 26, 2016 4:21 PM modif
    Tuesday, January 26, 2016 3:58 PM
  • We have the same issue with various Servers in our Domain.
    Especially i have an example of two Servers, which have the same results in gpresult /r and the first is rebooting and the other doesnt reboot. in the eventlog the reboot is announced to happen in 15 minutes, but nothing happens.
    im also looking forward to get a solution.
    this behaviour appears suddenly out of nowhere

    Regards
    Matthias

    Monday, February 1, 2016 7:25 AM
  • Hello, sorry for late reply,

    I don't know if anybody has already tried this, but I recommend to try a reset of the Windows Update component on impacted server. Maybe some settings are not applied correctly. (following update or various fix)

    https://support.microsoft.com/en-us/kb/971058

    Monday, February 1, 2016 12:23 PM
  • Does anybody have a update on this?
    Tuesday, February 16, 2016 12:00 PM
  • Does anybody have a update on this?

    Hi, I've no good answers but I've noticed that all servers start "not restarting" on the same month, to my mind after octobert tuesday patch management.

    I 've also noticed that few server seems have solved this bug/issue alone because they have restarted this month alone.

    I 'll tried to use windowsupdatediagnotic.cab on servers with issue this month.

    If anybody have the solution please tell us.

    Tuesday, February 16, 2016 1:17 PM
  • We've had this issue the past few months too - also seem to think it started after the October patches and only affects 2012 R2 servers.

    What we have noticed is the servers that are not restarting have disconnected RDP sessions - we have AlwaysAutoRebootAtScheduledTime set to 1 to force the restart but this doesn't seem to be working, we can't use timeout for the disconnected sessions as they are needed from time to time to run tasks.

    Would 'No auto-restart with logged on users for scheduled automatic updates installations' set to disabled force the restart after 5 mins? - its set to Not Configured which should have the same effect

    Tuesday, February 16, 2016 4:08 PM
  • I have checked/tested and yes, servers, that do not automatically restart, had disconnected session/s.

    https://support.microsoft.com/en-us/kb/971058 - This fixit for Windows Update didnt help.

    Would 'No auto-restart with logged on users for scheduled automatic updates installations' set to disabled force the restart after 5 mins? - its set to Not Configured which should have the same effect

    I have servers, with both not configured and also disabled for that GPO setting - no effect, restart just wont happen.

    Tuesday, February 16, 2016 7:07 PM
  • I have checked/tested and yes, servers, that do not automatically restart, had disconnected session/s.

    https://support.microsoft.com/en-us/kb/971058 - This fixit for Windows Update didnt help.

    Would 'No auto-restart with logged on users for scheduled automatic updates installations' set to disabled force the restart after 5 mins? - its set to Not Configured which should have the same effect

    I have servers, with both not configured and also disabled for that GPO setting - no effect, restart just wont happen.

    It is the same thing on our servers. I've noticed that there were some idle session but I have not realised that it was the main cause of this issue.

    It is very strange that microsoft won't react on this?

    Maybe there is a solution...

    I have test the fixit wsus but I don't think it will solve the problem

    Wednesday, February 17, 2016 9:11 AM
  • According to a recent post in this thread, MS is aware and a fix is expected, maybe in March:

    Windows 2012R2 servers NOT rebooting when configured to do so after installing Windows Updates


    Rolf Lidvall, Swedish Radio (Ltd)

    Wednesday, February 17, 2016 10:29 AM
  • thanks I've activated the "alert me" option in the other thread and I will write here if I have news about this topic.
    Wednesday, February 17, 2016 12:00 PM
  • Fix released now:

    This update fixes the following issue with previous versions of the Windows Update Agent for Windows 8.1, Windows RT 8.1, and Windows Server 2012 R2:
    • Windows Update would sometimes not restart the computer as expected when the “Always automatically restart at the scheduled time” policy was set.

    Rolf Lidvall, Swedish Radio (Ltd)

    • Proposed as answer by Steven_Lee0510 Thursday, March 3, 2016 12:58 AM
    • Marked as answer by alain131284 Thursday, April 14, 2016 11:11 AM
    Wednesday, March 2, 2016 7:06 PM
  • Hi,

    Thanks for this update.

    I've added the fix on my wsus server and I will test after.

    It is probably the answer to my/our issue.

    The patch is also available for Windows 8.1 version

    Monday, March 7, 2016 1:28 PM
  • Alain,

    I'd be interested to hear if this did work for you. It doesn't seem to have helped with ours where there are disconnected sessions left on the server despite having the hotfix and setting 'No auto-restart with logged on users...' to disabled.


    Thursday, April 14, 2016 11:08 AM
  • Hi Josh,

    For me it have solved the issue.

    This month all servers have restarted after update like I've configure (about 15 minutes after installation).

    Thursday, April 14, 2016 11:13 AM
  • Still having the same "

    • Windows Update would sometimes not restart the computer as expected when the “Always automatically restart at the scheduled time” policy was set.

    "

    on a handful of 2012 R2 VM servers. Other 2012 R2 servers would reboot as specified in the same group policy in the same AD OU. 

    KB3138615 has been installed in 5/2016, uninstalled in 8/2017, reinstalled in 8/2017.

    Thursday, September 28, 2017 4:03 PM
  • Hi, I'm not sure to understand.

    Issue was fixed for your server but it came back this summer?

    Is the issue always alive for you?

    On my servers nothing like that occure.

    Friday, September 29, 2017 6:41 AM