locked
Server 2012 Essentials - Client Back Up Fails When Using Storage Pool for client backups folder RRS feed

  • Question

  • Hi,

    I recently rebuilt my WHS 2011 with Server 2012 Essentials but am experiencing issues with backups when the Client computer backups folder is on a Storage pool.

    If the Client backups folder is on the system drive or an individual hard drive it works fine but as soon as I move the folder to a storage pool it fails after around 1-2%.

    I see the following errors:

    On the Client (Windows 8) -
    Event ID 8194 - Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface. hr = 0x80070005, Access is denied.
    . This is often caused by incorrect security settings in either the writer or requestor process.
    Operation:
    Gathering Writer Data
    Context:
    Writer Class Id: {e8132975-6f93-4464-a53e-1050253ae220}
    Writer Name: System Writer

    Writer Instance ID: {64dbdd8a-3a41-42d6-b9eb-2e084683d5b1}

    On the server -
    Event ID 1000 - Faulting application name: WSSBackup.exe, version: 6.2.9805.0, time stamp: 0x504a9faa
    Faulting module name: WSSBackup.exe, version: 6.2.9805.0, time stamp: 0x504a9faa
    Exception code: 0xc0000094
    Fault offset: 0x000000000008e49d
    Faulting process id: 0x1d3c
    Faulting application start time: 0x01cdc1077d58979e
    Faulting application path: C:\Program Files\Windows Server\Bin\WSSBackup.exe
    Faulting module path: C:\Program Files\Windows Server\Bin\WSSBackup.exe
    Report Id: f32af8dd-2cfc-11e2-93f3-001f1fc0d3ce
    Faulting package full name:
    Faulting package-relative application ID:

    I've tried it with a storage pool of 3 disks with parity, and 2 disks mirrored, both scenarios fail.  I've tried with ReFS as well as NTFS for the file systems.

    I can replicate easily: move the Client Backups folder to C: or other individual drive and it works, move the folder to use a storage pool and it fails every time.  I've tried rebuilding the server many time with the same result. My Windows 7 client doesn't back up either. Has anyone else experienced this or have any ideas how to resolve this?

    Thanks,

    Paul

    Tuesday, November 13, 2012 8:04 AM

All replies

  • Hi,

    It seems that your VSS services is not running properly, please run the following command in Windows PowerShell:

    Get-Service | Where-Object {$_.displayname -like "*volume*"}

    Please make sure the VSS service is running.

    At the same time, I suggest that you need to run the Windows Server 2012 Essentials BPA to have a general health check on the server, for details, there is a link for your refernece:

    Title: Run the Windows Server 2012 Essentials Best Practices Analyzer

    URL: http://technet.microsoft.com/en-us/library/jj713500.aspx

    And post back your findings. Of course, backup tab under Event Viewer on the server is a checkpoint here too.

    Regards,

    James


    James Xiong

    TechNet Community Support

    • Marked as answer by James Xiong Friday, November 30, 2012 1:18 AM
    • Unmarked as answer by James Xiong Friday, November 30, 2012 1:18 AM
    Thursday, November 15, 2012 9:26 AM
  • I have been working with the product team for Server 2012 Essentials and they are aware of this issue and are evaluating a fix for a future update.  In the meantime the work around is to store the Client backups folder on a drive which is not a storage pool.

    Paul Hines

    Friday, December 21, 2012 7:19 AM
  • That sort of destroys one of the benefits of WSE2012, especially for those of us looking at it as a move from WHS2011. And why were these scenarios not tested before this was launched? Together with limitations on restoring client backups to machines with UEFI BIOSes but MBR disks, and the inability to remember passwords in the Client Connector on non-domain-joined machines, it is starting to feel like it is
    Sunday, December 23, 2012 9:49 PM
  • So is this an official bug in Server 2012 Essentials, I can't backup my clients to a Storage Space? I agree, whoever let this product ship without such a simple test needs to be fired, I mean come on, they say this is a product for a small business with 10 or 20 computers and they are not supposed to use storage spaces to create a drive big enough to back them all up? 

    In any case I am seeing the same problem. I can back up my 4 computers for about a week then they start failing and corrupting the backup database. The database repair tool fails to fix it. At that point I have to delete the backup database and start over. 


    Sunday, December 23, 2012 11:52 PM
  • Hey Paul,

    Did they give any sort of timeframe before this is fixed ?

    Thanks,

    Jorn

    Monday, December 24, 2012 3:01 PM
  • My understanding is that this ONLY affects a very small number of older processors.  There is simply no way every hardware combination can be tested and that is what the Beta releases are to help identify.  I never used the beta and only had limited time testing the RC before it went RTM and I installed as my main server.

    I've since found several colleagues doing the same as I tried without any problems so I think that I've just been unlucky and maybe I shouldn't be so tight and should've bought a new mobo and processor ;-)

    The KB article is being worked on and the fix should be in the next update roll up.  If I see the KB appear I will post it here.


    Paul Hines

    Monday, December 24, 2012 5:29 PM
  • Thanks Paul !

    I did buy a new mainboard & processor so I probably won't have any issues then :) Thanks for the info !

    Jorn

    Tuesday, December 25, 2012 11:02 AM
  • Thanks, Paul.  So that may explain my problem as well.  I have a Server 2012 Essentials box, which I built originally as a WHS2011 box.  The processor is fairly new, but is low powered.  I think it's a Core I3 low-power (35w) processor I purchased in April, 2011.  I didn't really think of it as old, but you could argue it is underpowered.  I chose it since my server would only be doing reads and writes--pretty simple tasks.  It didn't seem like I would be getting value from the additional capabilities of an I5 or I7.

    My backups are regularly becoming corrupted.  Most times I can repair the database (losing most of my backups), but then often within the day, I get notification of backup database corruption again.

    I have a storage pool made up of 7 drives, 6 of which are 2TB, the other is 1TB.  The pool is divided into two storage spaces, one I call "Duplicated" because that's where I put stuff I want duplicated.  The other is "Non-Duplicated", which, of course, is not duplicated.  That's where I put the client computer backups.

    As a workaround, it seems like I can try one of two things.  I can upgrade my processor and see if that helps, or I can move the client computer backup to a single non-pooled drive, creating an obvious space limitation.  A better solution would be a software fix :-).

    Do you have any additional data on the problem yet?  Can you confirm that a low-power I3 processor would be a likely cause of the backup corruption problem?  I'd love to see the KB article, and, of course, the fix.

    UPDATE:  This last week, I was having such problems with backups, that I finally disabled backup for all computers, stopped the backup service, removed all the backups, and restarted again with each backup.  Things went well for about 4 days.  I got backups for all my computers.  Then, this morning, backup database corruption again.  The corruption appears to have occurred while one of the PCs was doing it's nightly backup.

    No solutions here, but the backup database problem continues.

    • Edited by edarring Tuesday, January 15, 2013 5:02 PM Update
    • Proposed as answer by edarring Thursday, January 24, 2013 4:15 PM
    • Unproposed as answer by edarring Thursday, January 24, 2013 4:15 PM
    Wednesday, January 2, 2013 3:52 PM
  • Older processor? My CoreI3 that I bought a little over a year ago is an older processor? What is the explanation for the older processor causing this, that doesn't make much sense to me.

    So anyway, I moved my client backups to an external USB drive and I continue to have the problem. Are external drives also a no-no? Do I need an internal drive that is not part or a storage space to make this work?

    This is really irritating me as I have no reliable backups of my client machines, client machines that I backup up with WHS 2011 running on the same processor without ANY problems for almost 2 years. Why if it could work in WHS 2011 won't it work in Server 2012 which I assume is basically the same technology for the client backup piece?

    Friday, January 4, 2013 3:25 AM
  • Another backup data corruption update:  I had been running mControl, a home automation background service, on Windows Server 2012 Essentials to do some simple lighting control.  For a completely unrelated reason, I removed mControl from the server.  To my delight, since then--some 11 or 12 straight days, backups have happened flawlessly with no data corruption.  I don't know if removing the service and the backup data corruption are related, but I thought I would post that data in case others happen to run into a similar situation.

    UPDATE:  Well, the problem wasn't mControl.  After about 3 weeks, the backup corruption issue reappeared.  I have, however, learned one best practice.  When backups become corrupted, after repairing the database, restart the server.  Then it will work again for several days.  If I don't restart the server after repairing the database, it will fail again with the next backup.  Yes, I'm repairing that often.  

    Also, sometimes I'm able to save the backups, other times not.  This unreliability of the backups sort of defeats the purpose of having Server 2012 Essentials as a backup solution.

    I remain frustrated by this.


    • Edited by edarring Sunday, February 24, 2013 11:36 PM
    Thursday, January 24, 2013 4:33 PM
  • The Core I3 processor should be fine, mine is older than that and I believe it was to do with L2 cache.

    My symptom was that backup didn't work at all as the check sum returned an error.  If your back ups work but are getting corrupt then that is a separate issue.  Not sure where to point you for this one :(


    Paul Hines

    Friday, January 25, 2013 12:16 PM
  • Add me to this dubious list.  Been wrestling for days now trying to get the server to back up a laptop.  Total data approx 400gb on one partition.  I've gone so far as to isolate the server and laptop on the switch (no other devices present, gigabit all the way through).  The backups begin but never utilize more than a fraction of one percent (no typo) the network throughput.  Typically the backup hangs at around 15% and 15-20 hours later.  Today it managed to reach almost 50% in a period of almost 24 hours.  

    I've read a couple suggestions about not using storage spaces.... are the folks at MS/Technet serious?  I think I'd prefer the futile argument for a refund to non-redundant backup storage, the PRIMARY factor in using WSE2012.  Can't believe it but I'm actually considering dusting off my WHSv1 media.... 

    Friday, February 1, 2013 6:50 AM
  • I've read a couple suggestions about not using storage spaces.... are the folks at MS/Technet serious?  I think I'd prefer the futile argument for a refund to non-redundant backup storage, the PRIMARY factor in using WSE2012.  Can't believe it but I'm actually considering dusting off my WHSv1 media.... 

    sddjd, I read the same thing about not using storage spaces, so I put it to the test.  I went out and purchased a new 2GB drive, added it to the server, but not to storage spaces, and moved the backup to go there.  Two days later, the red X is back with a corrupted backup.

    Clearly, this backup corruption problem is not related to the backup being on storage spaces.

    Other possibilities?  The backup drive is a WD Green EARX drive.  Does the "greenness" of the WD drive cause problems?   Should I be using something else? Would WD Red address that?  Black?  How about the connections?  Is the Cisco/Linksys router a problem?  Anyone have any ideas?  The server is really quite reliable except for this backup problem--one of the main reasons I have it.

    Sunday, March 10, 2013 9:50 PM
  • Hi, edarring, (and other folks who had client backup issue),

    Do you still experience client backup database corruption issue? Could you zip your log in "ProgramData\Microsoft\Windows Server\Logs" and share it with us (maybe with skydrive) to troubleshoot please?

    Yang

    Tuesday, May 14, 2013 11:31 PM
  • I have had the same issue with both Stablebit Drivepool and Drivebender (yes I have been playing with this for awhile, very tedious) I have a newer AMD processor on my server just so we can say that it seems to effect both flavors of processors and not just "older" ones.  I have tried storage spaces as well, the only thing that works is a client backup folder on a non-pool drive.  Every other permutation fails in seconds from the attemp to start a backup.  I have posted on Stablebits forum and plan to do the same on Drivebender's.  This is definetly a flaw in WSE2012 not in 3 different pooling technolgies.  Has there been any progress on this issue and do you still need logs or other info from us?  WHS 2011 worked in this configuration why can't Windows Server 2012 Essentials at 10 times the price?! 

    I think you can upload you logs from both client and server side here.  Or you can go to the Connect site to submit a bug to Microsoft. 

    Please do, I don't think they are taking this seriously, 6 months with no real reply or advise?!

    Connect Site for Windows Server 2012 Essentials:

    https://connect.microsoft.com/WindowsServer/feedback/CreateFeedbackForm.aspx?FeedbackFormConfigurationID=5352&FeedbackType=1

     

    Log Collector download link:

    http://www.microsoft.com/en-us/download/details.aspx?id=34821

    You can find your logs here:

    %programdata%\Microsoft\Windows Server\Data

    Dave


    • Edited by dslabby Sunday, June 23, 2013 9:45 PM additional info
    Saturday, June 22, 2013 5:25 PM
  • I am now completely Stuck, reading all the above problems.
    We have only 6 users!!!
    I need storage Space of 4T.
    I have had 6 lots of 3T drives Returned as The Server for some odd reason Fails to recognise them. 
    Disk Management does not even see them, to say Initialise.
    So I got two brand new 2T drives.
    Thought ok, will create a dynamic disk, Windows 2012 essentials dose not support Dynamic Disk, Server 2012 does..

    Have tried Soft Raid. Backup does not recognise the drive so i can not use it for backup.
    Server 2012 essentials will only recognise Simple Disk. and 2T is not enough ?

    I see the start this post was DEC 2012.
    As IT it is my job for the company to make sure we have a full and successful backup, How do i explain the investment of S2012e to the company, as No backup is possible what so ever???
    Storage Pool I have not tried, but all the above, says that will fail too…
    There is no support for external drives, So what am I supposed to do ?

    This is a Major Vital Part of any Server office environment, Backup. How can MS just do nothing about it, bit like getting a car with the steering wheel missing, saying we will find one when we get round to it…
    If we can not back up the data of just 6 users, best of luck for those with 20..
    I could, just use only that which we can not loose, but the main company folder, with Website, Quotes, drawings is larger than 2T only Just, so backup fails saying not enough storage….

    Monday, September 16, 2013 10:20 AM
  • Here's another example: Windows Server 2012 Essentials 6.2

    Running a Storage Pool using 9.08 Tb of 18.1 Tb pool capacity on a HP 40 NL Microserver. 

    The Storage Space is a two-way mirror composed of 6 physical drives:

    4 x 3 Tb Western Digital Reds in the Microserver

    2 x 4 Tb Seagate NAS Class Drives in a Mediasonic 8 Drive Enclosure (Bridged with USB 3.0)

    WS2012E reports that the Storage Space is Okay.

    Despite my main client workstation (C drive an SSD containg system and program files, D hard drive for data) having succesfully backed up for months, the WS2012E began to fail to backup in early September.   I was able to manuall backup about a week ago when logged in remotely via Remote Desktop, but have since had no successful backups manual or automatic.

    Other info:  

    weekly backup cleanups have been failing for a couple of months, even with manual triggering.  

    server backups have been successful.

    Any insight into the causes, fixes, approaches to diagnosis and repair would be extremely appreciated.

    Friday, September 20, 2013 4:38 AM
  • I know this is old, but did you get any resolution? I'm experiencing the same thing.

    -George Handlin

    Tuesday, December 31, 2013 10:13 PM
  • I found this old thread and wondering if a fix has ever been found for this issue. I have been running Windows Server Essentials successfully since July 2013. However for the past month I am having the back up failures occurring on three client machines. 

    I have tried the following:

    1. Tried to repair backup database.

    2. Stopped back up service and deleted client backups.

    3. Cleared any shadow copies.

    4. Backups are not on a pool drive.

    5. Removed connector software and reinstalled and connected each client to the server.

    After three weeks I still cannot get client backups to complete successfully.

    My last resort is to reinstall Windows Server Essentials, but I do not want to do this yet.

    Any help or insight would be appreciated.

    Tuesday, February 25, 2014 9:04 PM
  • Paul, your report of the bug was extremely helpful to me, thanks!  However, I repro the original and B Dyer's scenario with a new motherboard, Celeron G1840, and a striped storage space.  

    Very disappointing and a waste of time.  This is what happens when there are not enough good testers.  Please fix this.   And what's kind of scary: why on earth would storage spaces make a difference?  Not writing at the logical volume level? Sounds like optimization before robustness to me.    
    Thursday, April 2, 2015 3:08 AM
  • 1 year later, ditto.  Backup log shows error 112 API name: WriteFile.  Line 502 of diskfile.cpp  

    Thursday, April 2, 2015 3:18 AM
  • Are you running 2012 or 2012R2 essentials

    Grey

    Thursday, April 2, 2015 12:41 PM
  • I'm having this problem now, running 2012R2, all updates installed

    I had three 2TB Seagates in the machine for data, plus a 1TB system drive
    Two were set up as mirrors, one as backup

    Backup drive kept failing.

    Thought it was the Seagate drives as I'd have one "disappear" once in a while... randomly.

    Replaced with three 2TB Toshibas
    Same backup issue, but haven't had one of the drives disappear [yet]

    Built the system in October 2013, and haven't had two months go by without at least one backup corruption.

    Kinda defeats the purpose to have automatic backups when they keep getting corrupted!

    It would be nice if there was a fix after all this time!
    Come on, Microsoft!!!!!

    System specs:

    Operating System Windows Server 2012 Essentials 64-bit
    CPU                         Intel Xeon E3 1230 v2 @ 3.30GHz  34 °C                                Ivy Bridge 22nm Technology
    RAM                        32.0GB Dual-Channel DDR3 @ 666MHz (9-9-9-24)
    Motherboard            Supermicro X9SAE (CPU) 31 °C


    Thursday, August 27, 2015 4:16 PM