none
Keyboard losing focus while in remote desktop session

    Question

  • Hi,
    I have several Win7 computers that remote into a hosting company's server. Our users will log into the hosting company's servers via remote desktop. The issue that keeps coming back is that the keyboard will stop functioning after a user locks the computer then returns after a short period of time to continue working. The remote desktop session will remain working while the pc is locked. After unlocking the computer the keyboard will not work in the remote session. The mouse isn't affected by this and minimizing the session, the keyboard works fine on the local session. Sometimes you have to restore down then restore back or minimize the RDP session several times to get the keyboard to work inside the remote session. On a few occasions, ending the RDP session will cause the keyboard to work again. Anyone experienced this and have a resolution for this issue? This issue appears to be occurring more frequently and we have already recreated user profiles on the remote server but to no avail. Thank you for your help.
    Wednesday, April 3, 2013 6:09 PM

Answers

  • Nicholas

    The KB appears to describe the issue we are experiencing. I tried the hotfix but I received a message that the hotfix doesn't apply to this computer. The pc is a windows 7 pro 64-bit. Would you have any other suggestion?

    ***update***

    I changed the keyboard setting for the rdp file to On This Computer. This is found under Local Resources when you edit the rdp file. This appears to have resolved our keyboard issue.

    • Edited by Jon_Q Wednesday, September 25, 2013 8:31 PM Found a resolution
    • Marked as answer by Jon_Q Wednesday, September 25, 2013 8:31 PM
    Thursday, April 11, 2013 12:13 AM

All replies

  • Hi,

    Please see if this is the issue; if so, please try the hotfix:

    A remote desktop session does not respond to keyboard input or mouse input after it loses the focus in Windows 7 or in Windows Server 2008 R2

    http://support.microsoft.com/kb/2579381

    Thanks.

    Nicholas Li
    TechNet Community Support

    Friday, April 5, 2013 10:00 AM
    Moderator
  • Thank you Nicholas. I will give it a try.
    Monday, April 8, 2013 2:19 PM
  • Nicholas

    The KB appears to describe the issue we are experiencing. I tried the hotfix but I received a message that the hotfix doesn't apply to this computer. The pc is a windows 7 pro 64-bit. Would you have any other suggestion?

    ***update***

    I changed the keyboard setting for the rdp file to On This Computer. This is found under Local Resources when you edit the rdp file. This appears to have resolved our keyboard issue.

    • Edited by Jon_Q Wednesday, September 25, 2013 8:31 PM Found a resolution
    • Marked as answer by Jon_Q Wednesday, September 25, 2013 8:31 PM
    Thursday, April 11, 2013 12:13 AM
  • Hi Nicholas,

    I have this issue aswell, and it has traveled with me over a switch if computers. So I suspect there is something with my user account/profile or similar. My colleague does not have the issue. 

    I also tried the hotfix but I received a message that the hotfix doesn't apply to this computer. The pc is a windows 7 Enterprise 64-bit. What can I do to resolve this?

    Any way to reset my Remote-desktop-cache or settings for my user account perhaps, start from scratch. 

    Best regards

    - Björn

    Monday, May 12, 2014 8:00 AM
  • I'm having this issue as well.  The hotfix does indeed seem to apply to computer (Win 7 Pro x64 with SP1) but I also get the "The update is not applicable to your computer" message.  Very frustrating that this is still an issue given the original post is over 2.5 years old.

    Saturday, November 7, 2015 12:09 PM