none
Bluetooth Logitech MX900 Mouse reconnect RRS feed

  • Question

  • Very nice Win RC 7 installation on a Dell notebook where more or less everything (no sound) was working from the installation files. The only remark I have so far is with the internal Bluetooth support. Added my Logitech MX900 Mouse and everything works well until I restart. Then I got the following message: A Bluetooth device is trying to connect - click to allow. But since it is the mouse it self trying to connect - I cannot accept the message. I have tried to tab and enter arround to get into the question box in the right corner, but it is not possibel. With the keyboard I have to go to the "Device and Printers" delete the mouse, and then add it - then it works.
    Friday, May 15, 2009 7:20 PM

All replies

  • Does it do this every single time you restart? Is there a setting to authorize it to automatically connect every time?

    -Nick
    Tuesday, June 30, 2009 5:25 PM
  • Had a similar issue with my Logitech Bluetooth mouse. Only solution I´ve found is to use Logitechs own Bluetooth dongle.

    I did it like this:

    - Unistall drivers for "HID-compliant mouse" using Device Manager.
    - Shut down the computer
    - Insert Logitechs dongle in a free USB-slot
    - Boot

    Everything works now just fine. I have not installed Logitechs Setpoint-software, it´s pain in the A. Every now and then it just stops working, mouse and keyboard don´t connect. After restart it takes a while when Setpoints Bluetooth Connectivity application tries to reconnect mouse and keyboard. Better without, I´ve had no problems using my diNovo bluetooth keyboard, Mediapad and mouse since I did the above mentioned procedure.
    Wednesday, July 1, 2009 12:24 AM
  • Thanks,
    This could be an idea, but I try to avoid since the PC has an internal Bluetooth, so I do not need any device on the pc when I use it "on the run". But I also work docked and there it could be working. Else the device from Logitech is too heavy to run around with so I rather have an extra set of charged batteries with me.
    I have got a reply from Nick also to check up.
    Saturday, August 8, 2009 2:26 PM