none
How do I get weeks in timescale to respect unchecked "Use fiscal year" checkbox when a fiscal year is set? RRS feed

  • Question

  • Hello!

    Longtime user of MS project, but recently started using fiscal year. Currently work with client using FY Sept->Aug, so setting September as first fiscal year month.

    Works great - I can set up my timescale to show calendar year and month (mid tier), and then fiscal year quarters or halves as top tier, toggling using the great "Use Fiscal Year" checkbox.  Super.

    For most of my views I have week numbering as bottom tier. Client does not use fiscal year week numbering, or project week numbering - since we are in Sweden calendar year numbering is the most common practice. And here is where I ran into trouble:

    For the bottom tier, I select weeks as I have always done, I select 1-52 numbering (exact string is different) from the dropdown and then I uncheck the "Use Fiscal Year" checkbox and expect MS project to use calendar and not fiscal week numbering.

    This does not happen. I uncheck but MS project ignores the checkbox and my pleas for attention and resolutely shows week numbers starting with the fiscal year.

    How can I get MS project to please "respect my authoriteeee"! :-)

    Is this a defect? Is there a patch? Do I need to utter magic words when unchecking the box and using weeks?

    Thanks for any help, this drives me nuts! :)

    BR! /marcus

    Image of dialogue, this does not work:

    This does not work as expected

    Image of dialogue, this works fine:

    
    • Edited by Marcus Widerberg Tuesday, November 29, 2016 6:28 AM Clarifying title
    Wednesday, November 16, 2016 11:48 AM

All replies

  • Marcus,

    You won't like it but the answer is this. The lower tier setting of 1...52 is not weeks of the year, it is weeks from the start of the plan. The difference between 1...52 and 1,2,3,4 (from start) is that the former repeats every year while the latter keeps going.

    Sorry

    John

    Wednesday, November 16, 2016 2:41 PM
  • Marcus,

    Tiers are not responsive to unchecking the check box <Use fiscal year> when they display fiscal weeks (this issue exists in all versions !). Solution: set fiscal year to January (that is, disable it) while you work on the plan, it does not affect the calculations. And you can change it back to September before sending file to the client. 

    PS. One of the dialog box images posted (the 2nd one) is supposed to show [x] Use fiscal year.

    Wednesday, November 16, 2016 4:57 PM
  • Marcus,

    Have you solved the issue ? Thanks in advance for any feedback.


    Ismet Kocaman | eBook on Formulas

    Tuesday, November 29, 2016 4:56 AM
  • Hi John,

    thanks for your reply. Actually, I think you are thinking about the "from start" options for weeks in the timescale, they are weeks from the start of the plan. There are also options to use week numbering from the end of the plan, see image below. 

    But, the option I mentioned, 1..52 is not from the start of the plan, that is incorrect. It is for the year. Fiscal, due to this bug in ms project.

    (one would think either calendar or fiscal, but as we have discussed here it seems only the fiscal year)

    Best regards! /marcus

    For everyones reference, here is an image of the 1..52 option selected, w fiscal year set to calendar year and ms project correctly shows week numbering ending at week 52 for 2016 and re-starting at week 1 for 2017. (This example project starts in October 2016.)

    Tuesday, November 29, 2016 6:21 AM
  • Hi Ismet,

    I appreciate your reply. This is what I am concluding as well: It is a defect in MS project and the only workaround is to not use the feature. That is to (1) not use weeks (1..52, i e with calendar numbering) when a fiscal year (different from calendar) is set or, as you say (2) temporarily set fiscal year to calendar year whenever you need any views with calendar week numbering.

    It would be interesting to know if this bug has been reported to Microsoft and if it has been acknowledged.

    Could be a defect that is not too hard to fix.

    BR! /marcus

    Tuesday, November 29, 2016 6:26 AM
  • Thank you for the feedback. 

    Tuesday, November 29, 2016 6:40 AM
  • Marcus/Ismet,

    Upon reviewing my initial reply and doing a little more testing, I find my "theory" is incorrect. I'm in the process of verifying which versions display this anomaly (i.e. I see it in older versions and in Project 2010 but I do not have Project 2013 or Project 2016). Depending on what response I get back on those, it may or may not be something that should be forwarded to Microsoft for review.

    Just a word about anomalies in Project, or any other application for that matter. Over the years I have seen or been alerted to anomalous behavior of Project, sometimes under very specific conditions. In some cases it's a matter of the user not fully understanding how the application works. Note I said how the application works, which isn't necessarily how the user thinks it should work. But okay, let's say that behavior is actually a bug. Now the question is, does it impact basic functionality or is it a fringe anomaly (i.e. only occurs under very specific/unusual conditions). If it impacts basic functionality for most users then it will be recognized quickly and fixed in an update. Even if the bug does impact basic functionality but only occurs under very isolated scenarios (e.g. limited number of users), it might not be fixed unless requested by a user with a support contract. What gets fixed or doesn't get fixed is a matter of impact and priority.

    John

    Tuesday, November 29, 2016 4:44 PM
  • Hello Marcus,

    Tests reveal that this issue exists in the desktop versions 2007, 2010, 2013 and 2016. But the timescale is responsive to the checkbox, when it is unchecked, if the tiers show the quarters and years when there is a fiscal year setting. I just want to let you know that I have developed a set of formulas in the new book to display the fiscal week numbers of the dates specified (e.g., task start or finish dates), based on any fiscal year starting month, when the Fiscal year starts in box shows <January>. So you can view the fiscal week numbers on the table part while the timescale shows the calendar weeks. The formulas also handle another issue related to the fiscal year settings. In a nutshell, you can see the same fiscal information in the table columns as the tiers show on the timescale.

    Kind regards, 

    Ismet


    Tuesday, April 4, 2017 1:22 AM
  • Hi Marcus,

    I totally agree this is frustrating. On top of this "feature" I also noticed that once got the week numbering starting at the fiscal start of the year I am unable to get it back no matter what I do. Resetting year to no fiscal (selecting January) doesnt make any difference - the week numbering still keeps starting at the previously selected fiscal year start... VERY annoying indeed!

    You still havent got any solution to this I suppose?

    Have you discovered any other forums where this has been discussed or reported to Microsoft?

    BR // Anders

    Thursday, January 24, 2019 2:00 PM