locked
List Attachments taking too much time RRS feed

  • Question

  • Hi,

    In MOSS

    We have large sharepoint web application.

    There is list in a site. It contains around 900 items.

    90% of the list items have attached files, ranging 300KB to 10MB.

    This is displayed in a view(not default view).

    As we try to add an item with New Item option and attach file, it takes too much time and leads to error page(typical Troubleshoot error).

    This is causing not only in single list, in many(3-4) other lists also.

    According list view threshold, they are below the limit.

    We made sure internet connectivity is not the problem, speed is normal and we tried it number of times.

    Please provide the solution.

    It is getting worse to attach the file in list item.

    Thank you in advance.

     

    Thursday, June 23, 2011 3:27 PM

Answers

  • Hi,

    There are a lot of factors can contribute to this error.

    Check the IIS timeout settings if your file does not get uploaded within this time then you will get the same error.

    There can be other reasons as well. To find out follow these steps:

    1. In web.config file Turn on StackTrace to true and off thecustom error.

    2. Switch to verbose mode and carry out this operation to capture as much details as possible.

    I hope this will help you out.

    Thanks,

    Rahul Rashu

    • Marked as answer by David HM Friday, July 1, 2011 1:35 AM
    Friday, June 24, 2011 9:43 AM

All replies

  • What is the error returned ? Is it intermittent or consistent ? Can you try performing the new item creation on the server where this site is hosted ?
    Here to help.
    Friday, June 24, 2011 2:34 AM
  • Thank you for reply.

    The error is "The unexpected error has occurred".

    No specific error message, this is the single statement with "Troubleshoot issues with windows sharepoint services".

    Thanks

     

    Friday, June 24, 2011 7:25 AM
  • Change the web.config to give a better error.

    Change the following areas in the web.config to get a more detailed error.

    CallStack="true"

    customErrors mode="Off"

    Friday, June 24, 2011 9:10 AM
  • Hi,

    There are a lot of factors can contribute to this error.

    Check the IIS timeout settings if your file does not get uploaded within this time then you will get the same error.

    There can be other reasons as well. To find out follow these steps:

    1. In web.config file Turn on StackTrace to true and off thecustom error.

    2. Switch to verbose mode and carry out this operation to capture as much details as possible.

    I hope this will help you out.

    Thanks,

    Rahul Rashu

    • Marked as answer by David HM Friday, July 1, 2011 1:35 AM
    Friday, June 24, 2011 9:43 AM