none
Unable to retrieve installation information during install of DPM Remote Administration 2016 RRS feed

  • Question

  • I had the misfortune of installing Windows 10 1709 on my computer.  1709 really messed things up for me.  Programs would take a long time to start (Excel went from seconds to a full minute) etc.

    During the time I had Windows 10 1709 on my computer I deleted DPM Remote Administration 2012 and installed DPM Remote Administration 2016.  While not without incident, DPM Remote Administration 2016 worked fine.

    Because of the extreme slowness in Windows 10 1709, I rolled back to Windows 10 1703.  My computer is now responding much better.  Of course, my installation of DPM Remote Administration 2016 was not there.

    I tried to install DPM Remote Administration 2016 again and the installer told me that 2012 was still on my system.  Under installed programs, 2012 was indeed there.  I tried to uninstall it but uninstall failed because the system could not find the uninstaller.  Note that the actual files were already gone from my system.

    I ran the Windows Uninstaller Troubleshooter.  It corrected error in my registry such that when I tried to uninstall 2012 the system detected that it was not there and removed it from the list of installed programs.

    I then try to install DPM Remote Administration 2016 and I am immediately greeted with a dialog box that says "Unable to retrieve installation information."  There is no error number, no entry in the event log (at least none that I can find), no log file, no additional information.  I tried to reinstall 2012 and I get the same error.

    How do I get past this?

    Thanks in advance.

    Friday, February 2, 2018 8:06 PM

All replies

  • I was ultimately able to resolve this using https://docs.microsoft.com/en-us/sysinternals/downloads/procmon to find a reference that looked odd in the registry when running setup.

    Deleting the key:

    [HKEY_CLASSES_ROOT\Installer\UpgradeCodes\9F3649448F6E29E7DE0E92A8BB5539BA]

    allowed me to install.

    Prior to this I deleted all references in the registry to "Data Protection Manager" and DPM references that were obvious to me as DPM related.  I'm not going to restore my original registry and just delete the above key to see if that was all that was necessary but I am guess that it is.

    Good luck.

    Friday, February 2, 2018 11:45 PM