locked
Can't seem to install latest driver for ATI Radeon Mobility X800 in Vista RRS feed

  • Question

  • Hi everyone,

     

    I'm trying to update my display driver to the last version which Windows Update said was available but it kept failing with an error code that I have since lost due to reboot after reboot.  I tried getting Windows Update to install the driver but it failed every time.  So I tried uninstalling the card to see if Vista would pull down the most current version but no go, kept using the dusty old copy from 2006 each time.

     

    Now for some strange reason the update is no longer showing as available yet I'm still stuck with an old driver.  I've tried downloading this from the Alienware site but they don't seem to care whether my system works with Vista or not, and the ATI website says this is only available direct from my vendor.

     

    Microsoft do have this latest driver, it was signed in 2008 but why can't I get it???

     

    Any help would be HUGELY appreciated as I honestly can't afford a new card.

     

    Thanks,

    Wazr

    Friday, July 4, 2008 11:54 AM

Answers

  • All fixed, the issue was purely to do with my graphics card driver which I managed to download elsewhere.

     

    The driver available via WU is seriously out of date!

    Thursday, July 10, 2008 11:07 AM

All replies

  • Hi,

     

    Before moving on, please understand that Microsoft is not a display hardware manufacturer. Microsoft do not develop latest driver for this product.

     

    Regarding the drivers on Windows Update, please understand that the drivers on the Windows Update are directly provided by hardware manufacturers. Microsoft released them on Windows Update only for customer convenience. I recommend you download the driver from Alienware directly. Thank you for your understanding.

     

    If possible, could you please let me know your computer module? I will find the latest driver for you.

     

    Thank you for your cooperation.  

     

    Monday, July 7, 2008 10:57 AM
    Moderator
  • Thanks for the reply Robinson,

    I realise the drivers are made by the actual hardware manufacturers but Alienware don't provide the Vista drivers on their site and for some strange reason ATI no longer provide downloads for their Mobility Radian product line, saying instead to get them from my laptop reseller.

    So Alienware say talk to ATI, and ATI say talk to Alienware.

    Recently I made a possible discovery however that may lead to the answer, my motherboard driver may need updating as I'm pretty sure now that the Vista install used a generic version.  I've had this before in that the graphics card will work... but only 90% of it's features are visible by the OS.  I have found an updated driver for both the motherboard and... fingers crossed... the graphics card also.

    Will let you know how I go.
    Wednesday, July 9, 2008 5:42 AM
  • Hi Wazr,

     

    Thank you for your reply.

     

    Please keep me on update. If you have any questions, feel free to let me know.

     

    Thanks.

     

    Thursday, July 10, 2008 10:32 AM
    Moderator
  • All fixed, the issue was purely to do with my graphics card driver which I managed to download elsewhere.

     

    The driver available via WU is seriously out of date!

    Thursday, July 10, 2008 11:07 AM