SQL Server not detected on external database when adding AD RMS role


  • I am unable to get my AD RMS server to detect any instances of SQL Server on my database server.  I have followed the MS guide to setting up AD RMS.  I am using a domain account that is in the domain Enterprise Admin group, is a local admin on the database server, and has sysadmin rights on the SQL Server.  I turned off the firewall on both the AD RMS and database servers.  I believe TCP/IP protocol is setup properly for my SQL Server as I have a Sharepoint installation on a separate server which uses it.  If I try to add the AD RMS role on the database server it does successfully detect the instances when specifying the server name for external databases.  Anyone have any ideas as to why I'm running into this problem?
    Wednesday, July 10, 2013 8:29 PM

All replies

  • Hi,

    can you access the database from the server where you want put on RMS by using the ODBC wizard under Administrative Tools. From there you should easily identify if the you have network or permissions issues access the database server/instance. If this does not help please provide more information about your environment and what exact error message you get.



    Tuesday, July 16, 2013 1:24 AM
  • Hi Lutz,

    Thanks for the reply.  I setup a User DSN which tested successfully on the server which I am trying to add the AD RMS role to.  The DSN used Windows NT authentication and TCP/IP protocol.  The error I receive happens after I click the "Get Database Instances" button on the AD RMS setup wizard.  It seems to contact the server because a progress bar pops up which states "Detecting database instances...".  After that an error message pops up which states "SQL Server was not detected on <server name>. Verify that the computer is operating normally and that it is accessible from the network, and then try to connect again."

    The AD RMS server is running Windows 2008 R2 and the SQL server is running Windows 2008 R2 with SQL Server 2008 R2.

    Tuesday, July 16, 2013 7:02 PM
  • Hi,

    can you work through those procedure to make sure the SQL instances on the server can be enumerated.

    you may also want run osql.exe -L what should give you a list of all servers and instances on your network back.



    Wednesday, July 17, 2013 1:34 AM
  • Hi Lutz,

    I've run through the steps described in the article and everything seems like it's working as it should.

    - I was able to ping my SQL server from my AD RMS server

    - I ran PortQry as described in the article and I received a response from the instance of SQL Server I am trying to connect to

    - I ran osql -L from my SQL server and the instance shows up in the results.  I wasn't sure if I ran the command from the right place but I assume that osql comes with a SQL Server install and since I don't have SQL Server on my AD RMS server I was unable to run it from there.

    I forgot to mention something about my environment.  My SQL server has 2 versions of SQL Server running on it.  SQL Server 2008 and SQL Server 2008 R2.  The default instance is running on SQL Server 2008 while the instance I am trying to connect to is running on SQL Server 2008 R2.  When running the AD RMS role setup I am unable to see either of the instances while both of the instances were shown in the results of the tests that I just ran.


    Wednesday, July 17, 2013 5:04 PM
  • having 2 database servers running on the same box, assuming the machine has only 1 ip address then you what are the tcp ports you use for each of the servers? When you tested the database access using the ODBC wizard have you which database server had you reached?

    Wednesday, July 17, 2013 6:12 PM
  • The default instance is using port 1443 and the one I'm trying to reach is port 50000.  The DSN that I used to test connected to the one using port 50000.
    Wednesday, July 17, 2013 6:44 PM
  • Hi,

    I found this

    Unfortunately it was not working that way in my lab. May you have more luck or use the default SQL port e.g. by using a second IP address on the server.



    Monday, July 22, 2013 2:34 AM