none
Installing FIM 2010 Add-ins and Extensions via GPO RRS feed

  • Question

  • Hi,

    I have been trying to install the FIM Client using Group Policy software installation using the following link : http://social.technet.microsoft.com/wiki/contents/articles/2236.how-to-prepareexecute-installation-of-fim-2010-add-ins-and-extensions-via-gpo.aspx

    The crucial section missing on this page is what property to add/modify using Orca so that the install can proceed silently using an MST file which provides the registration_portal_url, RMS_location and addlocal properties for the FIM client install.

    If I install the client manually using the following command, msiexec /i "Add-ins and extensions.msi" transforms=client.mst /q, the client install proceeds silently which is what I expect.

    The UILevel=2 property is supposed to tell Windows installer to proceed silently as per http://msdn.microsoft.com/en-us/library/aa372096%28v=vs.85%29.aspx, however when I set this property in Orca for the transform file and then I execute the msiexec command, the UI still comes up and prompts me for selecting the different options for installing the client.

    Has anybody successfully deployed FIM client through group policy?

    Thanks!


    • Edited by Ustad Monday, December 16, 2013 7:54 PM
    Monday, December 16, 2013 7:53 PM

All replies

  • Ustad,

    I have tried this both ways and highly recommend the ADMX / ADML file approach outlined here: http://technet.microsoft.com/en-us/library/jj134303(v=ws.10).aspx

    Please note there is a problem with the files, and you'll need to replace certain “ ” characters with " ", but I got it to work without much trouble and the install took place during a reboot. 

    I recognize I have not directly answered your question, but this may be a better option for you.

    Monday, December 16, 2013 9:42 PM
  • Thanks for that Andrew. I do have the ADMX/ADML files deployed and I can see the FIM node under the Administrative templates in both user and computer configuration. The problem that I am seeing is that the FIM client fails to install when the Outlook Add-in is selected as a component.

    Since the only way to ensure that the Outlook Add-in is not installed is either through an msiexec or an mst file, I thought it would be a simple task to do the latter using Orca. That did not turn out to be the case.

    I will have to go back and troubleshoot why the Outlook Add-in is causing problem when deploying through GPO.

    Monday, December 16, 2013 10:18 PM
  • I still cannot get the FIM client to install through GPO. To confirm that a silent install of the FIM client works (because that is exactly what the GPO software install is doing), I ran the following command on my Windows XP computer

    msiexec /i "Add-ins and extensions.msi" /q

    Immediately, after running this command, I got an error in the application log

    "Product: Forefront Identity Manager Add-ins and Extensions -- You must specify FIM Service server address."

    So it looks like there is no way to install the client through GPO without specifying the FIM service server, and that cannot be done without an MST file.....

    So I will have to play around with the MST file and see if I can get it installed

    Tuesday, December 17, 2013 3:34 AM