locked
My desktop icons all have locks on them? RRS feed

  • Question

  • Alright, so this is a weird problem I'm having... After installing a program to my desktop in an attempt to extract the files, every file I download to my desktop has a lock icon on it - as in, it's not being shared.

    I can fix this manually for each and every file every time I download something by right clicking, clicking Share With, then adding "Everyone" with read/write access.  But I shouldn't have to.  I tried sharing the entire Desktop folder but that didn't do the trick.  Anyone else got any ideas?
    Sunday, November 22, 2009 10:36 PM

Answers

  • Hey guys, I think I fixed it!

    I went to C:/Users, then right-clicked my account name, went over to Security, and added Everyone with full access.  Applied the changes (some folders were denied, most worked), and now it seems I'm not seeing the locks anymore.

    Thanks for the suggestions though!  Appears the problem wasn't "share with", but something in security.

    Perhaps VMWare Workstation sets the security of its installation folder to user-only to prevent people from messing with it, I have no idea.
    • Marked as answer by Dale Qiao Monday, November 30, 2009 8:38 AM
    Monday, November 30, 2009 6:58 AM

All replies

  • What was the program you installed that seems to have caused this problem?

    Can you provide a picture please?
    Rich
    Monday, November 23, 2009 3:48 AM
  • VMWare Workstation.
    I uninstalled it right after to install it to the proper folder, but the lock icon persists.


    The odd thing is, when I went to download some files to show you, no more lock icon. LOL.  I hope it's permanent - otherwise I'll screenshot and reply!
    Monday, November 23, 2009 6:39 AM
  • http://img52.imageshack.us/img52/7700/locko.png

    That's what it looks like.  It still happens.  It just looks like when I download music and pictures there's no lock, only other filetypes that aren't automatically shared, apparently.
    Monday, November 23, 2009 3:36 PM
  • Hi,

    Since this issue occurred after installing VMWare, I would like to suggest you uninstalling VMWare completely, if the issue persists, try to perform a System Restore before intalling VMWare and see how it works.

    Please note: we provide this third party link for technical use. There may be some changes without notice, Microsoft doesn't guarantee any accuracy on contacting information.

    Best Regards
    Dale
    Tuesday, November 24, 2009 10:15 AM
  • I did uninstall VMWare.  That didn't work.

    And the thing about System Restore is I installed it like a month ago, I've installed several things since then, and I have a feeling System Restore would just mess that up.  Any idea what's CAUSING those locks though?
    Saturday, November 28, 2009 4:26 AM
  • Dale Qiao, that was a shot in the dark.  VMware is not known to put "lock" overlays on icons as far as I know.  I don't know what a "lock" overlay on an icon could mean, unless it's being added by a 3rd party application.  I certainly haven't seen it and I use VMware workstation all the time.

    Drfsupercenter, have you installed any tools that augment explorer (i.e., Shell Extensions)?

    There is a nice freeware tool called ShellExView that can be used to display (and potentially disable) extensions to Explorer:

    http://www.nirsoft.net/utils/shexview.html

    Edit:  I found some information online implying "a new padlock icon overlay appears on protected folders".  I don't know what "protected folders" means in this context, but if taken at face value it implies somehow you've set file protections on your desktop or the contents of same that make Windows 7 believe they are "protected".  More research is needed...

    What do you see when you right-click on one of the icons with a lock on it, choose Properties, then click the Security tab?  Does your username appear in the top box, and when you select it do you see that Full control is checked?

    -Noel
    Saturday, November 28, 2009 10:13 PM
  • Noel Carboni, thanks for your supplement, I do know other customers don't occur with this kind of issue with VMware installed. But as Drfsupercenter discribed above, this overlay icon occurs after installing VMware and revert back normally for some files after uninstalling VMware. Could this be some conflicts between VMware and other relevant programs? Why don't we uninstall VMware completely for a test? 

     Drfsupercenter, I noticed that this overlay icon occurs with some specific downloaded files, I suspect if the issue occurs while downloading these files to other locations except the desktop folder. Moreover, did it happen with other user accounts? How about moving the files to the desktop? If the issue still occur with moving files to the desktop, the desktop folder may not be auto shared with everyone. Otherwise, if the issue doesn't occur with moving files, it may be navigated to downloading process, you may need to restore the network security to the default settings.

    Best Regards
    Dale

    Monday, November 30, 2009 2:12 AM
  • Dale, from what I can see it didn't remove the locks at all.  He wrote:  "I did uninstall VMWare.  That didn't work."

    Let us first start with:  WHY are these locks showing on folders?  What do they mean? 

    I don't know because I haven't run across the Microsoft documentation (yet) describing what they mean.  Do you know the specifics, Dale?

    If the lock overlays have something to do with sharing folders, then it's KEY to determine what they mean.  If it's a permissions problem, he'll want to work out how a) to get the permissions right again, and b) to stop doing whatever he's doing that's causing the permissions problem.

    VMware does have some capabilities to see across the virtual machine boundary into the host, but it doesn't use Windows networking and I don't see how this could cause lock icons on his desktop.  That just doesn't make sense.

    Here are the pertinent things:

    - Exactly what does the padlock overlay mean?

    - Does it hurt anything or prevent any functionality, or is it just an irritation because the user doesn't know what it means?

    - With the answers to the above we can best determine what the user or software is doing (or failing to do) to cause it to appear.

    -Noel
    Monday, November 30, 2009 2:48 AM
  • Alright, well... the lock icon means that a file is not being shared with everybody on your network.  It doesn't restrict it in any way, it's just more ANNOYING than anything.

    Yes, it works fine if I download it elsewhere and copy to the desktop.

    I tried having my desktop shared with everyone, but all new files added to it are then un-shared.  Weird, eh?  I'm looking through ShellExView, trying to figure out what's what.
    Monday, November 30, 2009 6:42 AM
  • Hey guys, I think I fixed it!

    I went to C:/Users, then right-clicked my account name, went over to Security, and added Everyone with full access.  Applied the changes (some folders were denied, most worked), and now it seems I'm not seeing the locks anymore.

    Thanks for the suggestions though!  Appears the problem wasn't "share with", but something in security.

    Perhaps VMWare Workstation sets the security of its installation folder to user-only to prevent people from messing with it, I have no idea.
    • Marked as answer by Dale Qiao Monday, November 30, 2009 8:38 AM
    Monday, November 30, 2009 6:58 AM
  • The CORRECT FIX for this.....

     

    browse to C:\Users

    Right click on the correct Users folder and select Properties.

    Goto the Securities tab and click Advanced.

    Click Change Permissions.

    Highlight the Name SYSTEM in the User selection window.

    Tick the box for 'Replace child object permissions with inheritable permissions from this object'.

    Click Apply.

     

    The correct security rights will be restored without giving ALL local users access to your files.

     

    ----------------------------------

    http://palmergames.com

    • Proposed as answer by ElgarL Wednesday, July 14, 2010 2:55 PM
    Wednesday, July 14, 2010 2:55 PM
  • I have the same problems as mentioned above.. its just like my pc have 3 ownership..The system, Notebook and the administrator. When I click drive "c" "user" it displays that the "Notebook" folder has this padlock overlay icons and its all containing sub folder including the desktop icons. I figured it out how can i remove the padlock icon the whole night lol! and i just came across with this forum and followed the instruction above, nothing to work on me until i came with this instruction from ElgarL and Viola! it works on my pc... thanks everyone.. ! and hope you can find one to which is work to your PC.

    Here is it from ElgarL:

    The CORRECT FIX for this.....

     

    browse to C:\Users

    Right click on the correct Users folder and select Properties.

    Goto the Securities tab and click Advanced.

    Click Change Permissions.

    Highlight the Name SYSTEM in the User selection window.

    Tick the box for 'Replace child object permissions with inheritable permissions from this object'.

    Click Apply.

     

    The correct security rights will be restored without giving ALL local users access to your files.

     

    ----------------------------------

    http://palmergames.com

    • Proposed As Answer byElgarL Wednesday, July 14, 2010 2:55 PM
    •  

     

    Thursday, December 23, 2010 3:09 AM
  • With "everyone" having access, please note that you have just enabled access to your files to everyone in the world, because this security setting allows even users on other networks, such as and including the internet, to have access to your files.

     

     


    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Thursday, December 23, 2010 3:38 AM
  • Actually the padlocks mean a file is not shared.  If you "Share With Nobody", it will add the padlocks, not remove them.

     

     


    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Tuesday, January 11, 2011 9:06 PM
  • Thank you very much ElgarL.  This fixed the problem immediately!
    Saturday, May 14, 2011 5:42 PM
  • Same here ElgarL... it took the locks away here as well. 

    It makes me curious though, as I have my box on a domain and the owner of the files on the domain was the Administrator of the local box, the SYSTEM, and the domain user.  For one reason or another, the domain user's permissions were changed to modify only and I was logged in as the domain user.  The lock icon was telling me that as an administrator of the local box, the LOCAL administrator had removed my full control permissions at the root.  So though I owned the permissions from inheritance, I did not own them on the desktop.  Your suggest, to restore the full permissions to the SYSTEM, made the lock disappear, but the domain user permission was not restored. 

    I guess the think that baffles me is how the full permission rights root permissions were removed in the first place.  I was mucking around with SQL Server permission rights when it happened and the likelihood is that I myself caused the condition.  My second thought was that perhaps an update from Microsoft caused the issue.  I was also mucking about with the WSUS approvals at the time so I may have approved something that created the issue.

    All the same, thanks for your lucid reply and thankfully, it works great!


    R, J
    Saturday, June 11, 2011 12:06 PM
  • I think many folks have a fundamental mis-understanding of what the locks mean.  Here's the real deal:

    • Locks show up when a folder is private, the folder it's in is not.  If the parent folder is already private, locks will not appear (this was a design choice because otherwise every single folder in your user profile would have a lock icon by default and it would look cluttered).  For example, say you share your pictures library, but there's on specific folder inside there that you don't want shared. If you right-click it and choose "Share with nobody", it will get a lock.

     


    Shawn Keene
    Saturday, June 11, 2011 1:07 PM
  • The reason some don't is that if the parent folder is already private, none of the child folders will show the lock.  That was a design decision to prevent a sea of lock icons when you open a folder with a lot of child objects/files.
    Shawn Keene
    Sunday, June 12, 2011 6:01 AM
  • Sorry, I think I'm doing a really bad job of describing it.  Take at look at this source (finally found it after some digging):

    http://blogs.msdn.com/b/oldnewthing/archive/2009/12/09/9934348.aspx

     

    It's an interesting read, but here's the relevant part for this discussion:

    "A private item is an item where the only user account with access is you.¹ You create one of these, for example, by going to the sharing wizard and saying Share with: Nobody. To avoid clutter, the overlay is shown only when there is a transition from non-private to private. (Otherwise you'd have a lock overlay on everything in your Documents folder, for example.)

    No longer present as an overlay is the sharing hand. Why was the sharing hand removed in favor of the private overlay?

    Given the changes in how people use computers, sharing information is becoming more and more of the default state. When you set up a HomeGroup, pretty much everything is going to be shared. To remove the visual clutter, the information was moved to the Details pane. What's more, a single overlay cannot express the different ways an item can be shared, so in order to figure out what the deal is, you have to go to the Details pane anyway."

    However, it doesn't seem like your results are reflecting this, correct?

     


    Shawn Keene
    Sunday, June 12, 2011 8:04 AM
  • It's a little more complicated than what you hope for, I think.

    Keep in mind there are inherited permissions (i.e., permissions which are granted because the parent folder has them) and non-inherited permissions.

    Try this exercise:

    1.  Create a folder called TopFolder in a temporary area and share it.

    2.  Create two subfolders, NotShared and Shared in it.

    3.  Note that none have padlock icons in an Explorer view at this point.

    4.  Right-click and choose Properties on the NotShared folder.

    5.  Click the Security tab, then the [Advanced] button, and note that the [ ] Include inheritable permissions from this object's parent box is checked.

    6.  Press the [Change Permissions...] button, then UNcheck the the [ ] Include inheritable permissions from this object's parent box.

    7.  When prompted, choose [Add] to give the NotShared folder its own, non-inherited permissions.

    8.  Remove permissions for Everyone, Users and Authenticated Users if they are present and ensure Administrators is present with Full Control permissions - you'll want to be able to delete this folder later.

    9.  OK all the way out.  Note the padlock in the Explorer view now:

    -Noel


    Sunday, June 12, 2011 3:36 PM
  • Really stupid, basic question, but can you get to the files in the folders identified with padlocks when you connect to whatever shared area they're a part of?

    In the case of the above example, the padlock icons didn't go away until I removed Users and Authenticated Users from the list of entities with permissions.

    -Noel

    Monday, June 13, 2011 2:43 AM
  • The security settings are related to and affect, but are not the same as, the sharing settings.  The sharing settigs might still be restricted, regardless of the base NTFS security settings here.
    Shawn Keene
    Monday, June 13, 2011 2:16 PM
  • I'm just pointing out that you can set share permissions seperately from the security settings you show above, and these are what control the .ock icons. I've chatted with some folks at the sgell team and am assured it's working as designed, but I will try your steps later and see if i can reproduce your issue.

     

    // shawn keene / microsoft mvp 

    sent from my xoom


    Shawn Keene
    Monday, June 13, 2011 2:58 PM
  • My system is customized, but it shows as i expect them to according to the published criteria in the TechNet database. i'm happy to help you discover whyours show/don't show according to your expectations though.  i haven't meant any disrespect in this thread, and most of my information is a direct quote from other sources. 

     

    // shawn keene / microsoft mvp

    sent from my xoom


    Shawn Keene
    Monday, June 13, 2011 3:34 PM
  • You have actually only posted some mostly useless partial screenshots.  Just showing names in the Security panel is too simplistic.  What permissions do they actually have?  Noting the Everyone and Users groups, what permissions do they have?

    And why do you have $Recycle.Bin and Documents and Settings folders on your drive at all?  Your system looks to be kind of a mess. 

    No one is going to be able to explain something in general terms that is dependent on specific settings on your computer without doing a thorough analysis.  So yes, it actually IS kind of your issue.

    I reiterate my question:

    Since the Lock icon is supposed to indicate an inability to see into that folder from a network connection even though you've shared something at a parent level, can you see into those folders from another computer via a network connection?

    -Noel

    Monday, June 13, 2011 6:51 PM
  • Imagine that.  I had left the Show Hidden Files setting turned off.  LOL.  Sorry about that.

    Is it possible your whole volume is shared?  I know I've shared mine for easy access from my other systems.

    -Noel

    Monday, June 13, 2011 7:21 PM
  • Yes, I have lock icons on various items.  I'm not sure what this proves.

     

    -Noel

    Monday, June 13, 2011 7:39 PM
  • You still didn't enable the entire view.  Your pic doesn't show All Users, for example.


    Sorry about that.  It seems Explorer must be closed and restarted before the Navigation pane recognizes that the user wants to show Hidden files.  Not the files pane, though.  Typical level of consistency.

    I see what you mean about the lock overlays being meaningless / useless.  I've always just ignored them anyway because I know what's shared.

    I'm thinking these lock icons maybe have more to do with the dumbed-down Homegroup type "simplified" sharing...  I turned that off in the first few nanoseconds I was running Windows 7.  It reminded me of that bimbo in the Microsoft commercial who thought up that Windows 7 should be simpler right in the back of a taxi.  There should be a law against publishing commercials that incite feelings of choking someone.

    By the way, I can get to any of the folders that have a lock on them from other systems, just as I can any other folder, because I make connections using my credentials, and of course I'm in the Administrators group.

    -Noel


    Monday, June 13, 2011 10:50 PM
  • Again, the security tab will not affect the display or non-display of the padlock ovrlay. In addition, your All Users folder would have a lock if it is not shared, but the parent folder, 'Users', was.  which it should be by deafault, so that would be normal.  Accessible in the security tab by more than one user does not mean 'shared'.

    Your systtem is obviously not in the default state, nor is it a clean OS installation from the non-Vista/7 directory structure.  As I and my contacts at the shell development team cannot reproduce this issure, I'm dropping the investigation for now.  If we can be provided specific steps or circumstances that cause a padlock to appear when they should not (or vice versa), we'll look again.

     

    // shawn keene / microsoft mvp

    sent from my xoom


    Shawn Keene
    Tuesday, June 14, 2011 3:35 AM
  • Again, the security tab will not affect the display or non-display of the padlock ov[e]rlay.

    Hey Shawn, I'd like to dispute this statement, specifically.  I've listed easy-to-follow steps above in the post starting with "It's a little more complicated" that prove it wrong.

    There's more going on here than can be covered by a simple explanation.

    -Noel

    Tuesday, June 14, 2011 7:56 PM
  • Derosnec, I know you mean well, but your pictures are all but worthless to anyone who knows about permissions.  There is depth beyond just the list of users who have been granted permissions - i.e., WHAT permissions have they been granted?  In your example the permissions granted Gilligan, for example, could be different between the two folders - and thus possibly somehow involved in the difference in lock icons.

    The exercise I posted above where just removing specific groups of users from the list causes the lock icon to appear is the best way to demonstrate that the lock icon is in fact at least partially involved with the Security tab.

    Why isn't there solid documentation from Microsoft that describes what these locks mean?  A web search turns up millions of people wondering what it does, but no real documentation.  Something Microsoft just doesn't want to talk about?

    -Noel

    Thursday, June 16, 2011 11:07 PM
  • Why isn't there solid documentation from Microsoft that describes what these locks mean?  A web search turns up millions of people wondering what it does, but no real documentation.  Something Microsoft just doesn't want to talk about?


    I just completed about 15 minutes of searching using some pretty sophisticated syntax and I can honestly say that (per Google at least) there IS NO DOCUMENTATION for this lock overlay - other than answers that don't match one another in forums by uninformed Microsoft people - anywhere on Microsoft.com.

    -Noel

    Thursday, June 16, 2011 11:17 PM
  • Hey, I can make the font even bigger too, if that helps you understand what I'm saying.

    >See? SECURITY TAB does affect PADLOCK

    I don't see that proof in your pictures.  I'm surprised you think they prove anything at all.

    Don't be so quick to judge, my friend.  I make a lot of mistakes, but this isn't one of them.

    You could have other differences between those two folders.  You're only showing one of them.  It's an incomplete showing as I have said.

    That you're showing a difference in the Security tab proves nothing.  Are we supposed to take it on faith that there are absolutely no other differences?  That the security permissions afforded to Gilligan in one case are identical to the other?  That they are shared (or not shared) identically?  Maybe just folders that start with M have padlocks.  

    The idea is to remove any doubt.

    What proves something is when you take the very same folder, make ONLY changes to the Security tab, and cause the appearance/disappearance of the padlock.

    The funny thing is that we're on the same side of the argument.  You're just putting up oversimplified images that prove nothing.

    -Noel





    Saturday, June 18, 2011 12:51 AM
  • This post has been edited to heighten my embarrassment. 

    Not really.  Now derosnec will have to sweat over deleting his post in which he quotes mine.  Sorry for the inconvenience, derosnec.  Not.

     

    -Noel


    Detailed how-to in my new eBook: Configure The Windows 7 "To Work" Options

    • Edited by Noel Carboni Wednesday, January 25, 2012 6:54 AM I was wrong - I thought I was mistaken but that was in error
    Saturday, June 18, 2011 2:16 AM
  • Not sure if you're joking, but just how do you feel you can judge that?  By my picture?

    -Noel

    Saturday, June 18, 2011 2:57 AM
  • I used windows DVD maker and locks appeared on all my pics. I did what Elgar sead and it worked

    very easy.  Thanks     Bob L   Jan/14/12    

    Saturday, January 14, 2012 3:30 PM
  • My dearest forum friend wrote:

    Then you wouldn't embarrass yourself so badly.

    Edited by dеrоѕnес Monday, January 23, 2012 10:26 PM not detail-conscious. but very loud.

    Embarrassed?  LOL

    I'm proud of my efforts to help people here.  I can't imagine you could possibly be proud of your behavior.

    • Which of us is using his real name and photo?
    • Which of us has accumulated nearly 6000 points and an MCC badge for being helpful?
    • Does your mother know what you say to folks here?
    • Which of us can still respond using his original account because he is respectful to others and doesn't get himself banned?

    Um, tell me who is it that's embarrassed again?

    May I suggest putting more effort into trying to be helpful, instead of just heckling.  You only contribute something meaningful about every 20 posts or so - I'd sure love to see that change, as would a lot of others.  I believe we could be friends; we share a lot of the same ideas about Windows.

     

    -Noel


    Detailed how-to in my new eBook: Configure The Windows 7 "To Work" Options

    • Edited by Noel Carboni Wednesday, January 25, 2012 6:49 AM Quoted my favorite forum buddy so my post won't seem like an orphan after he deletes his
    Wednesday, January 25, 2012 5:55 AM
  • "In Windows 7, we have a padlock icon overlay to indicate a private file."

     

     

    @Shawn and Noel

    As you can see from this article, the rough meaning of the padlock is "private file".

    It goes beyond "sharing". It is connected with Security Permissions.

    As originally explained in some of the earlier (deleted) posts here.

     

    Wednesday, February 1, 2012 8:01 PM
  • It goes beyond "sharing". It is connected with Security Permissions.

    Thanks for the info.  I had figured that out above by Sunday, June 12, 2011 3:36 PM.

    Like you, I do find it interesting that Microsoft is removing those (useless?) padlocks in Windows 8.

     

    -Noel


    Detailed how-to in my new eBook: Configure The Windows 7 "To Work" Options

    Wednesday, February 1, 2012 11:53 PM
  • Only other thing I gathered was that subfolders of "private" folders might be "private" but the overlay not shown, because somehow that would make things even more confusing.  :)

     

    -Noel


    Detailed how-to in my new eBook: Configure The Windows 7 "To Work" Options

    Thursday, February 2, 2012 1:02 AM
  • What do you mean by "added Everyone with full access"???
    Sunday, April 13, 2014 8:13 PM
  • Yep!

    Thanks!

    Tuesday, August 14, 2018 1:51 AM
  • ElgarL, I agree. Worked for me several times over the years:

    Add to 'SYSTEM' : 'Replace child object permissions ..."

    My original source is:

    https://social.technet.microsoft.com/Forums/windows/en-US/f05b494f-0f51-4430-8a7f-c6e11cdf148b/my-desktop-icons-all-have-locks-on-them


    Peter (Plagoon2)


    • Edited by PLagoon2 Tuesday, November 6, 2018 3:08 PM
    Tuesday, November 6, 2018 3:07 PM