locked
Visual Studio Emulators for Android doesn't work on Windows 10 RRS feed

Answers

  • Jumping in with an official answer for the thread:

    1 - What is the problem?

    The problem is that if you are running a version of Windows that does not support Hyper-V - and you upgrade to a version that does support Hyper-V - we fail to create the Hyper-V administrators group.  Home --> Edu and Home --> Pro are the two common paths here.

    2 - What can you do about this?

    Well, you can't just create a Hyper-V admins group.  Sorry - it is special.  There are, however, a couple of options.

    a) You can do a clean install of Pro or Edu without an upgrade.  Painful but viable.

    b) You can run Visual Studio "as administrator"

    c) You can join the Windows Insiders - this bug has been fixed in the latest flight of Windows


    This posting is provided AS IS with no warranties, and confers no rights. You assume all risk for your use.

    • Proposed as answer by Tim CerlingMVP Saturday, May 21, 2016 12:38 PM
    • Marked as answer by BrianEhMVP Monday, May 23, 2016 3:07 PM
    Friday, May 20, 2016 11:33 PM

All replies

  • The Android emulator and Hyper-V cannot be running at the same time.

    The Android emulator uses qemu and acts like a hypervisor, needing direct access to the virtualizaton extensions of the chipset, just like Hyper-V.

    To use the Android emulator you have to boot your system with Hyper-V off.  And vice-versa.

    The Hyper-V Administrators group is created when the Hyper-V Role is enabled.  You cannot create it and expect it it to function in the same way.  They way to have it is to remove the Hyper-V Role and then re-add it.

    In regards to the blog articles you reference for permissions - the permissions model changed with 2012 R2.  Authorization Manager is no longer used.  So the initialStore.xml is essentially null and void. 


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.


    • Edited by BrianEhMVP Thursday, August 13, 2015 2:48 PM
    Thursday, August 13, 2015 2:47 PM
  • Visual Studio emulator uses Hyper-V this is main reason why i'm using it.

    https://www.visualstudio.com/en-us/features/msft-android-emulator-vs.aspx

    As i wrote before Hyper-V Role is enabled i can manage and run vm's etc. Visual Studio Emulator for Android can't create hyper-v  VM, Virtual Bridge etc. There is no Hyper-V Administrator group in my system. 


    Friday, August 14, 2015 5:43 AM
  • Sorry, overlooked that you were using the VS emulator in the subject line, and not the android provided emulator. I see folks complain about that one all the time.

    I can tell you that you are not alone from what I have seen.

    I have been made aware of a windows 10 bug that might be the root, but I don't know enough details.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Friday, August 14, 2015 1:03 PM
  • there was one thread that I helped someone with where they rebuilt wmi, and that fixed their issues.

    They had found some rebuild script to do I. I am not finding the reference at the moment.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Friday, August 14, 2015 1:16 PM
  • Hi Mateusz Przybylski,

    From the literal meaning of  the error it must your current account not have the local administrator permission,  You have to be a member of the local Hyper-V Administrators group when you use the emulator, more details please refer the following KB:

    System Requirements for the Visual Studio Emulator for Android

    I’m glad to be of help to you!


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Wednesday, August 19, 2015 8:51 AM
  • Windows 10 Hyper-V Role does not create the local hyper-v admin group, andcreating it manually does not work. There are a couple of azman scripts out there, but windows 10 client hyper-V doesn't have the initialstore XML.

    windows mobile 10 emulators work fine without the group, but the android emulator is adamant that the non-existent group is needed.  this seems like something the emulator team has to fix.

    Friday, August 21, 2015 9:33 AM
  • @Tim - I have kept it here on purpose.  And I keep trying to get the attention of the correct MSFT folks.

    Most likely it is rooted in changes that have been made to either Hyper-V, Windows10, the core networking stack, or a number of other moving targets. 

    Not to leave out, the Visual Studio team not updating things in lock step with the platform changes.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Friday, August 21, 2015 2:59 PM
  • The authorization manager initialStore.xml dependency was fully removed in 2012 R2 / Win 8.1 (partially there in 2012 / 8).

    The Hyper-V Administrators local security group should still be present.    ( lusrmgr.msc should show it )


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Friday, August 21, 2015 3:05 PM
  • Group does not exist, even after clean installing, as well as removing and adding Hyper-V.

    I'll try to add/remove again.

    Windows phone emulators and other VMs work fine, its just the android emulator.

    @Tim Cerling - I asked on Visual studio section, they pointed me to the hyper-V forums.

    Friday, August 21, 2015 3:50 PM
  • Hi,

    I have the same Problem and can't find any solution.

    Did you solve it?

    Wednesday, September 2, 2015 3:28 PM
  • windows 10 Education has been problem! Using Windows 10 Pro or Windows 8.1 pro Solve the probleor!

    Final Fantasy-B

    • Proposed as answer by Fhnrjds Monday, September 21, 2015 3:18 AM
    Monday, September 21, 2015 3:18 AM
  • windows 10 Education has been problem! Using Windows 10 Pro or Windows 8.1 pro Solve the probleor!

    Final Fantasy-B


    No, I have Windows 10 Pro and that doesn't address the issue. It runs fine on my Windows 8.1 Pro machine, but my Windows 10 machine is a dud.
    Thursday, December 3, 2015 3:56 PM
  • Hi there, 

    I'm having the same issue, did anyone found a solution ?

    Regards, 


    Kevin BEAUGRAND, Modis FRANCE
    Merci de bien vouloir "Marquer comme réponse", les réponses qui ont résolu votre problème.

    Friday, February 19, 2016 8:44 PM
  • Is there a working solution for this issue?
    Sunday, April 10, 2016 6:47 PM
  • I'm looking for a solution too.  I just re-installed Windows 10 and enabled Hyper-V and I got this error when trying to run an Android Emulator.  I worked before I reinstalled Windows.  One interesting thing is I installed Windows and attached my account to my Enterprise Azure AD account.  Would this have an effect on my permissions?  I looked in Computer Management and my account says I am an Administrator.  I launched VS as an Admin and it still doesn't work.

    -bmm

    Sunday, April 17, 2016 6:17 PM
  • I finally got it to work.  It looks like the Enterprise SKU does not setup the Hyper-V Administrators group properly which prevents the Android Emulator from working.  I installed Windows 10 Pro and when I enabled Hyper-V I noticed the Hyper-V Administrators group was created.  After I installed the emulator it worked.  For now use Windows 10 Pro until Microsoft fixed the Education and Enterprise SKUs.

    -bmm

    Tuesday, April 19, 2016 3:50 AM
  • FYI - the Education SKU has never supported / included Hyper-V.  I don't know if it ever will.

    Hyper-V (to date) has been restricted to Pro and Enterprise.

    I have seen the Hyper-V Administrators security group issue with the Enterprise LTSB, but not with the standard Enterprise SKU.

    Do you recall which version of Enterprise you had installed where you did not get the Hyper-V Administrators security group?


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Tuesday, April 19, 2016 1:10 PM
  • I just got a new Lenovo T460. I enabled Hyper-V and installed Visual Studio 2015 and Xamarin. I get the (Unable to add user to the Hyper-V Administrators groupExit code 2220) same error and there is no Hyper-V Administrators group on my machine. I do have other Hyper-V VMs that run fine, so I am sure Hyper-V is working correctly.

    I ordered the machine with Win10 Pro (x64) (I never switched editions) and I’m sure many other devs will be doing the same.

    It works flawlessly on my desktop machine with VS2015 and Xamarin and I'd really like to get it working on my laptop (because it is really a great feature).

    I'd rather not have to reinstall Windows 10.

    Thanks!

    Thursday, April 28, 2016 12:28 PM
  • I am facing the same issue. I am not sure if it is because I originally had the windows 10 Home version installed on this laptop (Dell XPS 13 9350) and I upgraded to the pro without reinstalling.

    I have tried uninstalling and reinstalling the Hyper-V from the windows features list, from powershell, and using dism. None of these methods have created the Hyper-V user group. And just to be clear, Hyper-V works, and the windows phone emulators work, it is only the Android emulator from Visual Studio 2015 that is not working.

    Can I get confirmation on whether the user group is supposed to show up in the first place? Hyper-V is installed and working but the group isn't there.

    Monday, May 9, 2016 3:57 AM
  • I have been informed that the fix for this issue is currently available in Insider builds.

    That said, I have no idea when the rest of the world might see the fix.

    The "Hyper-V Administrators" security group should be there.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Monday, May 9, 2016 3:33 PM
  • I have the same issue.. Have you got a solution or an information from Microsoft about a patch ?

    Thank you in advance

    Thursday, May 12, 2016 1:12 PM
  • Solution :

    Run Visual Studio as an administrator and will not have that problem.

    I hope to work with you.

    Regards.

    Jose Poma

    Thursday, May 19, 2016 3:00 AM
  • Jumping in with an official answer for the thread:

    1 - What is the problem?

    The problem is that if you are running a version of Windows that does not support Hyper-V - and you upgrade to a version that does support Hyper-V - we fail to create the Hyper-V administrators group.  Home --> Edu and Home --> Pro are the two common paths here.

    2 - What can you do about this?

    Well, you can't just create a Hyper-V admins group.  Sorry - it is special.  There are, however, a couple of options.

    a) You can do a clean install of Pro or Edu without an upgrade.  Painful but viable.

    b) You can run Visual Studio "as administrator"

    c) You can join the Windows Insiders - this bug has been fixed in the latest flight of Windows


    This posting is provided AS IS with no warranties, and confers no rights. You assume all risk for your use.

    • Proposed as answer by Tim CerlingMVP Saturday, May 21, 2016 12:38 PM
    • Marked as answer by BrianEhMVP Monday, May 23, 2016 3:07 PM
    Friday, May 20, 2016 11:33 PM
  • 2 - What can you do about this?

    Well, you can't just create a Hyper-V admins group.  Sorry - it is special.  There are, however, a couple of options.

    a) You can do a clean install of Pro or Edu without an upgrade.  Painful but viable. - Development machines usually have other tools installed and this option is almost impossible to be taken.

    b) You can run Visual Studio "as administrator" - Does not work!

    c) You can join the Windows Insiders - this bug has been fixed in the latest flight of Windows - Actually development machines are not recommended to be used with windows insider program.


    For people who must keep existing Windows 10 OS installed, the slow android emulators (under Android Emulator Manager) can be used or just use a mac machine for android development.



    • Edited by blertonh Friday, June 3, 2016 5:17 PM
    Friday, June 3, 2016 5:16 PM
  • I purchased a Win 10 Pro licence just for this, but if you upgrade you can't get it to work.

    What I ended up doing was running the setup from the command line as follows:

    setup.exe /auto clean /pkey xxxxx-xxxxx-xxxxx-xxxxx-xxxxx

    this worked for me, but you do end up with a fresh install OS

    Thursday, July 28, 2016 10:13 AM
  • I purchased a Win 10 Pro licence just for this, but if you upgrade you can't get it to work.

    What I ended up doing was running the setup from the command line as follows:

    setup.exe /auto clean /pkey xxxxx-xxxxx-xxxxx-xxxxx-xxxxx

    this worked for me, but you do end up with a fresh install OS

    So this is a clean install? Applications/data etc are removed?
    Tuesday, August 2, 2016 9:24 PM
  • I'm having the same problem.  I purchased the upgrade to Windows 10 Pro from home just so that I could run the Visual Studio android emulator.  Running a clean install is not an option.  Running VS in admin mode does not help.  I really prefer not to install the insider build on my laptop, but I may image it and give it a try just to see if it works.

    Is there any idea when a fix will be released for this?

    Thursday, August 25, 2016 2:23 AM
  • Hmmm.... So the official answer is to clean install a PRO even if we dont have it ?

    I'm looking in my MSDN subscription and when I use the Multiple edition ISO, I'm never ask to pick and choose an edition. It installs the Home and then I have to type in my Pro Activation code for the upgrade to take place! Which creates the bug!

    I dont see a "pro" ISO... Only Enterprise and multiple!

    There's is no patch that Microsoft provides to just create the group and stuff ?


    Wednesday, August 31, 2016 2:15 PM
  • hi, there are possibilities to solve this problem without having to reinstall a new edition of Windows 10 pro
    Friday, September 16, 2016 7:57 AM
  • Hi! 

    I'm having the exact same problem as OP. 
    When will the fix in option c be released for regular users? 


    Tuesday, October 4, 2016 8:13 PM
  • Can Microsoft give it's official guidelines if it is possible to solve the problem without full reinstall Windows 10 Professional which is together with other tools, like VS2015 takes a long time:

    - Originally Windows successfully upgraded from Home to Professional edition

    - Visual Studio Emulator for Andoird cannot start the emulator with error:

    Unable to add user to the Hyper-V Administrators group. Exit code 2220.

    Thanks

    Mike

    Thursday, October 6, 2016 5:34 PM
  • "Can Microsoft give it's official guidelines if it is possible to solve the problem "

    You might want to ask over in a Visual Studio forum.  This forum is designed more for general questions around Windows Server Hyper-V, not Windows 10 Hyper-V.  Besides, it is not so much an issue of Hyper-V as it is of what Visual Studio is doing.  Not all applications handle upgrades gracefully.  It is the responsibility of the team that develops the product, in this case Visual Studio Emulator for Android, to ensure their product works on the hypervisor, not the other way around.


    . : | : . : | : . tim


    • Edited by Tim CerlingMVP Thursday, October 6, 2016 10:03 PM
    • Proposed as answer by j longo Monday, October 17, 2016 10:03 PM
    • Unproposed as answer by j longo Monday, October 17, 2016 10:03 PM
    Thursday, October 6, 2016 10:03 PM
  • It looks like there problem is related to installing Windows from MSDN OR upgrading it from retail home.

    The full "User and Group" sub-system is missing/disabled if you install from MSDN multiple editions (the only thing available) then activate it with a PRO key. Old install had full User and Group system available.

    I am really frustrated as this started with a reinstall of VS2015, morphed into a reinstall of the OS, had to learn ISO's are incompatible with GPT,  discovered a bug with the "username when installing, etc.... Am now on day 4 and am trying mmillar answer.

    If that works then OS guys, this is your breakage not the dev team.



    • Edited by j longo Monday, October 17, 2016 10:09 PM
    Monday, October 17, 2016 10:07 PM
  • Hi bmmathe, I wonder how you were able to setup Hyper-V Administrator group in Windows 10 pro as I was trying to run VS Android Emulator I got the same error until now. Waiting for your response !!!

    Thank you in advance

    Tuesday, October 18, 2016 2:26 PM