none
IE 10 for Vista RRS feed

  • Question

  • I am looking for the IE10 download for Vista, as some websites tell me they do not support older versions of IE.

    Can anyone point me in the right direction or offer advive please?

    Thanks in advance.

    Saturday, October 29, 2016 4:40 PM

Answers

  • IE9 was the last release of IE suitable for Windows Vista.
    IE10/IE11 are not available for Windows Vista.

    You can:

    - upgrade your Windows from Vista to a newer version (if your computer hardware is suitable)
    - upgrade your computer hardware / replace your computer
    - choose an alternative browser (other than IE, e.g. Google Chrome or Mozilla Firefox, etc) if you can't upgrade/replace your computer/Windows


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Sunday, October 30, 2016 12:24 AM
  • Hi Mike,

    Vista comes with IE 7. If we install the SP2, we could use IE 9. Unfortunately the requirements for IE 10, it isn’t support Vista. We could upgrade the system to use the IE 10. Or you could try use the other browser to check.

    Please note: Microsoft has stopped the support for the Vista.

    Best regards,

    Carl


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 31, 2016 5:59 AM
    Moderator

All replies

  • IE9 was the last release of IE suitable for Windows Vista.
    IE10/IE11 are not available for Windows Vista.

    You can:

    - upgrade your Windows from Vista to a newer version (if your computer hardware is suitable)
    - upgrade your computer hardware / replace your computer
    - choose an alternative browser (other than IE, e.g. Google Chrome or Mozilla Firefox, etc) if you can't upgrade/replace your computer/Windows


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Sunday, October 30, 2016 12:24 AM
  • Hi Mike,

    Vista comes with IE 7. If we install the SP2, we could use IE 9. Unfortunately the requirements for IE 10, it isn’t support Vista. We could upgrade the system to use the IE 10. Or you could try use the other browser to check.

    Please note: Microsoft has stopped the support for the Vista.

    Best regards,

    Carl


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 31, 2016 5:59 AM
    Moderator