none
Two Updates Failed, One is Security Update for Adobe Flash (critical), other is Security Monthly Quality Rollup (no info).

    Question

  • Hi.

    Thank you for all your support and security updates for my two Surface RTs.  They’re great and I don’t want to see them go.  A quick aside… It would be nice for my two Surface RTs and me, if Microsoft had a change of heart and decided to port Windows 10 RT with Office RT for Surface RT and get a few more years support.  Anyway.

    Today one of my Surface RT 8.1 provided the option on shut down, to update and restart, which I did.  It said it was installing 4 updates.  When rebooted, I went to view update history and found two failed updates and three successful ones for a total of five.  The first one in the list that failed is this one here below.

    Then to get more information, I clicked the link shown there for 4048958 to learn more.  That took me to the Microsoft Security Update Guide, where I searched for 4048958 and was provide two links for RT 8.1.  Both links, one for IE11 and one for RT 8.1, go to the KB 4048958 article, which says to get more information, go to the Security Update Guide, which of course takes one back to the KB.  Not very informative loop I guess.

    The second update that is on the list above showing as failed, is the one for Adobe to prevent remote code execution.  When I am in Windows Update and double-click the failed entry for Adobe, and then click the link for more information, it takes me to a URL that does not show a KB number and provides a link for more information as you see here below.

    During the first time I clicked that link my RT was being sluggish that for about 3-5 minutes, every click or letter I type took about 15-30 seconds to get processed.  Eventually I right-clicked and waited about 30 seconds or more and then selected open in new window from the pop-up menu.  Then after another long wait of maybe 20-30 seconds, I got the message you see here below.  As I’m running a Surface 8.1 RT, there probably is not an Itanium 64 processor inside.  :-)  Right?

    After this error screen showed up, my sluggish extremely slow performance went back to normal faster speed and the link “ADV170019” worked as one would expect, and took me to the URL here below.

    On that URL I scrolled down to the Windows RT 8.1 platform in the table and then over to the download column and clicked “Security Update” and was given the same error message screen shown earlier here in this email, that it has been detected that I am using an Itanium 64 processor and it is not compatible with the URL.

    Is it possible someone with Itanium 64 processor is on our connection?  Is it just a scripting error on the Microsoft URL?  Can I get the update?  I’m sure Microsoft is already working on this, but wanted to be sure.

    Kinda frustrating.  Please advise.

    Thanks for listening.

    Chris


    Christopher Jay Wolff

    Wednesday, November 15, 2017 4:15 PM

All replies

  • RT updates are not provided on the Windows catalog site.  You'll have to use windows update.  What was the error message you received?

    Wednesday, November 15, 2017 9:23 PM
  • You're correct updates for RT are supposed to be only available through Windows Update.  However, in the past I have successfully downloaded and installed and run one of the ????diag.cab files from a Microsoft support URL  While that was probably about 2 years ago, and I've never seen something like that again, I was surprised it worked and never forgot to keep my mind open to the possibilities of what I could find.  After all, the link for Windows RT 8.1 is provided in the Update Catalogue URL shown above, as I described.  Just provides no helpful info.

    Yesterday after my post here, Windows Update did successfully install the two failed updates.  I will see over the next day or two if I still have issues like I had yesterday described above where I was told I have an Itanium 64 processor.  I will also see if the other problem shown in my other post which can be seen here below, persists.

    https://social.technet.microsoft.com/Forums/ie/en-US/fa9a359a-38ca-4b92-957d-0f61fabeb744/two-different-surface-81-rt-machines-share-ie11-connection-info?forum=ieitprocurrentver#fa9a359a-38ca-4b92-957d-0f61fabeb744

    If you want the error messages I received pertaining to this thread on Updates, they are shown and described in my original post above.


    Christopher Jay Wolff

    Thursday, November 16, 2017 11:09 AM