locked
activesync recover password not working for iphone RRS feed

  • Question

  •  Hi I have exchange 2007 sp1 rollup 3. I am currently testing activesync. I have two users, one has a pocketpc and the feature 'recover password' works for him. He is able to reset his device password through OWA and also when executing the followign command get-activesyncdeviceStatistics -mailbox:"mailbox" -ShowREcoveryPassword:$true I can see that the field 'recoverypassword' for the mailbox gets populated with a numeric string. For example

    RecoveryPassword      : 12602793591063171406 

    My second user is using an iphone software version 2.2 (5g77). For this user, when logged in to OWA, the 'display recovery password' is empty. Message 'no password is available' displays when clicking on that link. Both users are using the same EAS policy that enables feature 'recoverypassword':

    AllowNonProvisionableDevices             : True
    AlphanumericDevicePasswordRequired       : False
    AttachmentsEnabled                       : True
    DeviceEncryptionEnabled                  : True
    RequireStorageCardEncryption             : True
    DevicePasswordEnabled                    : True
    PasswordRecoveryEnabled                  : True
    DevicePolicyRefreshInterval              : 06:00:00
    AllowSimpleDevicePassword                : False

    for the iphone I have tried the powershell command to enable 'showrecoverypassword' but it doesn't have any effect. At this point I am wondering if this feature is supported at all for the iphone. MS documentation only mentions how to enable this feature or how to use it but doesn't mentioned if it is device dependent. I will appreciate if somebody can provide an answer to this question.
    Wednesday, January 21, 2009 2:19 AM

All replies

  •  

    Hi,

     

    I don’t have a iphone at hand, so I can’t test it for you.

     

    Regarding this issue, you need to contact Apple for this problem to see if they have included the feature in iphone.

     

    Forums: Apple.com > Support > Discussions > Using iPhone > Mail, Contacts and Calendar

    http://discussions.apple.com/forum.jspa?forumID=1144

     

    Thanks,

     

    Elvis

     

     

    Thursday, January 22, 2009 10:22 AM
  • did u get an answer to this?
    Tuesday, January 19, 2010 7:38 PM
  • Try this link, I'm running into the same issue and I don't see an option for the password recovery in here.  But if someone stumbles on something I would love to know.

    http://manuals.info.apple.com/en_US/Enterprise_Deployment_Guide.pdf
    Tuesday, February 9, 2010 5:40 PM
  • Finally received word from an Apple Engineer that the Password Recover option in EAS will not work with the iPhone.

    Later,

    Jason
    Thursday, February 11, 2010 7:33 PM