locked
Excel deletes the query tables automatically on reopening the file. RRS feed

  • Question

  • Hi,


    Issue recreation Steps:

    1. I created a simple table and created a simple query from that table and loaded the results to the another sheet.

    2. Then I saved it and closed it.

    3. When I opened it and closed it again, it asked me to save the changes even though I didn't make any changes to the excel.

    4. If I save it or edit anything in the excel and save it, it’s getting saved successfully.(But something is happening while saving it)

    5. When I reopen this saved file again, it shows me this error "We found a problem with some content in this file, do you want us to recover as much as we can", If I give yes, It says this "Excel was unable to  open the file by repairing or removing the unreadable content,Removed Part: /xl/queryTables/queryTable1.xml part.  (External data range)" and removed all my connections between the tables and the queries.

    Due to this, I can’t continue to work on it. Because, whenever I edit, save, close and open, I lose the connections between the queries and the tables.

    Things I tried:

    1. I have sent this file to others and checked, it is working fine for them. When they close the file, it is not asking them to Save, Even if they save the file, there is no issues when reopening the file.
    2. I have uninstalled MS office and installed it again.
    3. I tried one excel hotfix for the similar error, but the issue was not exactly correct, so it didn’t fix it.

    These didn’t solve the issues, Can anyone help me to resolve the issues?

    Thank you.


    Monday, July 3, 2017 2:00 AM

Answers

  • Hi Yuki,

    The issue is resolved!

    Uninstalled that BI tool

    Uninstalled Office using the 2nd option in this link

    https://support.office.com/en-us/article/Uninstall-Office-from-a-PC-9dd49b83-264a-477a-8fcc-2fdf5dbf61d8?ui=en-US&rs=en-US&ad=US

    Installed both office and BI tool, I couldn't recreate the issue now.

    Its resolved.

    Thanks,

    Priya.

    Wednesday, August 16, 2017 6:56 AM

All replies

  • Hi Priya,

    Regarding the hotfix you mentioned above, based on my research, it is applied to Excel 2007. Are you also running Office 2007? 
    If not, could you please collect the detailed version information of both Office and Windows system then we can do further research on this?

    Besides, to help narrow down the issue, please try to perform a clean boot in Windows, then have a try and see if issue persists. This helps eliminate whether the issue was caused by any software conflicts:
     
    https://support.microsoft.com/en-us/kb/929135

    Any updates, please feel free to post back.

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, July 5, 2017 9:52 AM
  • Hi Yuki,

    Many thanks for your reply.

    I have this issue with MS Excel 2016 and my OS is Windows 10.

    I tried to perform a clean boot and tried to recreate the issue, but the issue is still there. I have installed a BI tool which will work with Excel, I am going to uninstall both the BI tool and MSOffice and try to install again and see whether the issue is recreated or not. Please advise me if you have any more ideas on this.

    Thank you

    Priya

    Wednesday, August 16, 2017 2:50 AM
  • Hi Yuki,

    The issue is resolved!

    Uninstalled that BI tool

    Uninstalled Office using the 2nd option in this link

    https://support.office.com/en-us/article/Uninstall-Office-from-a-PC-9dd49b83-264a-477a-8fcc-2fdf5dbf61d8?ui=en-US&rs=en-US&ad=US

    Installed both office and BI tool, I couldn't recreate the issue now.

    Its resolved.

    Thanks,

    Priya.

    Wednesday, August 16, 2017 6:56 AM
  • Hi Priya,

    Great to hear that! And many thanks for sharing your resolution with us :)

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, August 16, 2017 8:23 AM