none
"compile error in hidden module:link" on mac 365

    Question

  • Every time I open and close MS Word with the current version of 365 (July 2016), I get the following error message:

    "compile error in hidden module:link"

    Once launched MS Word functions as usual. It is annoying to see the error. Suggestions on how to fix this. I've looked through the forums and have only found Windows related solutions and those back to MS Word 2013.

    Thank you…


    Wednesday, July 13, 2016 3:52 PM

Answers

  • I HAVE THE ANSWER!

    Well, this worked for me, anyway.

    Since I updated to Word version 15.24 recently, when I either start up or quit Word, I get the error describe: "compiler error in hidden module: link".

    The reply given above by Steve Fan is what led me to find the solution, but didn't work in itself. The path describe above simply doesn't lead to the described content. However, having previously found (with great difficulty) Outlook's new location for storing its email database, I had a clue where to start looking.

    So basically, the path that Steve Fan should have quoted is as follows:

    ~/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word/

    I.e. start tunnelling down from your home folder (~), not the root of the startup disk.

    Inside the above Word folder I found a new file (dated 30 Jun 16) called "linkCreation.dotm". Promising, I thought, given the 'link' reference in the name and in the error message.

    I moved this file out of the folder and tried loading and quitting Word again. This time it worked fine, without the error message. Solved!

    For what it's worth, I also had another file called "Bookends.dot" in the above folder alongside the problem file. I left that in place, and it isn't causing a problem.

    Hope that helps someone else…

    Thursday, July 14, 2016 5:02 PM

All replies

  • Seeing the same error, also with Word 15.25 (160707) on macOS.
    Wednesday, July 13, 2016 7:52 PM
  • Hi,

    Please check if you have anything in the Word startup folder. This is usually located at /Library/Application Support/Microsoft/Office365/User Content/Startup/Word. If there is anything in the folder, try moving the file to another location and then start Word to see if this issue continues.

    Please let me know the result.

    Regards,

    Steve Fan
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    • Proposed as answer by davidbaliles Wednesday, September 07, 2016 5:21 PM
    Thursday, July 14, 2016 8:30 AM
    Moderator
  • Hello Steve,



    For me, there is no subfolder 

    Office365/User Content/Startup/Word, sorry...


    Thursday, July 14, 2016 8:33 AM
  • I found the folder at /Applications/Office/Startup/Word

    This contained a file called Link.md

    I deleted the file but it hasn't made any difference.

    Thursday, July 14, 2016 12:38 PM
  • I HAVE THE ANSWER!

    Well, this worked for me, anyway.

    Since I updated to Word version 15.24 recently, when I either start up or quit Word, I get the error describe: "compiler error in hidden module: link".

    The reply given above by Steve Fan is what led me to find the solution, but didn't work in itself. The path describe above simply doesn't lead to the described content. However, having previously found (with great difficulty) Outlook's new location for storing its email database, I had a clue where to start looking.

    So basically, the path that Steve Fan should have quoted is as follows:

    ~/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word/

    I.e. start tunnelling down from your home folder (~), not the root of the startup disk.

    Inside the above Word folder I found a new file (dated 30 Jun 16) called "linkCreation.dotm". Promising, I thought, given the 'link' reference in the name and in the error message.

    I moved this file out of the folder and tried loading and quitting Word again. This time it worked fine, without the error message. Solved!

    For what it's worth, I also had another file called "Bookends.dot" in the above folder alongside the problem file. I left that in place, and it isn't causing a problem.

    Hope that helps someone else…

    Thursday, July 14, 2016 5:02 PM
  • Thank you Richard for your post. I had the exact same issue, and your solution worked. It's frustrating that updating Office 365 actually "breaks" the app.
    Thursday, July 14, 2016 6:47 PM
  • Awesome!! Thank you for sharing your experience here, Richard. @Jonathan, please check if the solution provided by Richard works for your situation. If you need further assistance, please feel free toe let me know.

    Regards,

    Steve Fan
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    Friday, July 15, 2016 1:21 AM
    Moderator
  • Yep.  That did it.  Thanks.

    Friday, July 15, 2016 8:03 PM
  • Richard, this worked for me, thanks!
    Saturday, July 16, 2016 12:29 AM
  • Genius.  It worked.  Thank you!
    Saturday, July 16, 2016 12:58 PM
  • Bless you Richard.  I had the same issue and your brilliant I HAVE THE ANSWER! solved my problem.  Send me a bill.  :-)
    Saturday, July 16, 2016 6:12 PM
  • Thanks, fix the annoying error
    Sunday, July 17, 2016 3:08 PM
  • Thanks Richard, worked perfectly.

    I think it is due to MS going from a 32-bit system to a 64-bit one with the latest 15.25 release - orphaned file.

    regards

    rob

    Sunday, July 17, 2016 4:49 PM
  • I had the exact same issue and the solution you suggested worked so I am very happy.
    Monday, July 18, 2016 8:07 AM
  • This answer did not work for me.

    First, I do not have the path you mentioned (~Library/Group Containers...) but I did find the file "linkCreation.dotm."

    I found it in ~Applications/Office/Startup/Word. 

    I deleted it but still have the same problem... every start and stop I get error: "compile error in hidden module:link"

    .... STILL frustrated!

    Tim G.


    • Edited by tagrant60 Monday, July 18, 2016 3:54 PM
    Monday, July 18, 2016 3:46 PM
  • Premature Post earlier!  

    I kept digging for a few minutes... I finally found the path Richard mentioned and there it was. Deleted... problem solved.  

    I just did not dig back far enough the first time. my apologies!

    Tim G

    Monday, July 18, 2016 3:54 PM
  • This one worked for me too, thanks!
    Wednesday, July 20, 2016 11:23 PM
  • I HAVE THE ANSWER!

    Well, this worked for me, anyway.

    Since I updated to Word version 15.24 recently, when I either start up or quit Word, I get the error describe: "compiler error in hidden module: link".

    The reply given above by Steve Fan is what led me to find the solution, but didn't work in itself. The path describe above simply doesn't lead to the described content. However, having previously found (with great difficulty) Outlook's new location for storing its email database, I had a clue where to start looking.

    *** START

    So basically, the path that Steve Fan should have quoted is as follows:

    ~/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word/

    *** END 

    I.e. start tunnelling down from your home folder (~), not the root of the startup disk.

    Inside the above Word folder I found a new file (dated 30 Jun 16) called "linkCreation.dotm". Promising, I thought, given the 'link' reference in the name and in the error message.

    I moved this file out of the folder and tried loading and quitting Word again. This time it worked fine, without the error message. Solved!

    For what it's worth, I also had another file called "Bookends.dot" in the above folder alongside the problem file. I left that in place, and it isn't causing a problem.

    Hope that helps someone else…

    Thank you Richard Hallas for saving me TONS of aggravation & endless cases of punching my desk every freakin' time I opened & closed Word 2016 (or whatever version I'm using with my Mac Office 365).

    I should also note to anyone that may be discouraged by your lengthy explanation NOT TO PANIC - Richard's steps are VERY EASY TO FOLLOW:

    1. From FINDER, go to the GO menu.
    2. Select 'Go to folder'
    3. Paste EXACTLY what Richard had included in his very helpful post. (starting from ~/Library... and don't worry, the folder is there if you were affected by the update; the lengthy numbered folders aren't specific to Richard's machine; they are on yours too. Delete the file inside that folder.
    4. Thank him for his very informative explanation as to how Microsoft F'ed up and why Richard is doing their job yet I'm still paying them.
    • Proposed as answer by M Fish Thursday, July 21, 2016 3:36 AM
    Thursday, July 21, 2016 3:36 AM
  • Dude! Gold Star for the day. 

    Richard Hallas - you rock! 

    Friday, July 22, 2016 3:46 PM
  • Worked, thank you!
    Tuesday, July 26, 2016 3:06 PM
  • Worked for me too. Thank you!
    Wednesday, July 27, 2016 10:41 PM
  • Same problem for me - started with 15.25

    Fixed by deleting the "linkCreation.dotm" file that I found at ~/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word/

    Cheers guys!!!

    Thursday, July 28, 2016 12:58 AM
  • Thanks so much, I eliminated 

    linkCreation.dotm

    related to word and it was fine!! Not more problems

    I found it with with an excellent program that I use the most of the times, looking for hidden files

     
    Friday, July 29, 2016 4:19 PM
  • Great! This worked using the GO menu cut and paste method.

    Thanks to all.

    Friday, July 29, 2016 9:41 PM
  • Richard, this worked for me, thanks!
    Friday, July 29, 2016 10:27 PM
  • "Inside the above Word folder I found a new file (dated 30 Jun 16) called "linkCreation.dotm". Promising, I thought, given the 'link' reference in the name and in the error message.

    I moved this file out of the folder and tried loading and quitting Word again. This time it worked fine, without the error message. Solved!"

    I coudn't find it via the folder trail you listed, but I just did a search for this file.  I found one in my old Word 2011 folder and one in the Word 2016. 

    I, too, removed this file, started Word again, and quit, and the message went away. 

    Just find that one file.  It's all you need to know. 

    Thank you!

    Sunday, July 31, 2016 5:11 PM
  • Worked for me! Thanks!!
    Monday, August 01, 2016 1:29 PM
  • THANK YOU, Richard. It worked for me, too. I had two files with the same name, created on two different days. I deleted both, and now I don't have the problem.

    Stephen

    Monday, August 01, 2016 5:58 PM
  • Thank you!! I was bothered by this for weeks and was very relieved to find this in the Google Search results for the issue. Cheers!
    Monday, August 01, 2016 6:49 PM
  • Thanks Richard, this also fix my annoying error every open and close MS word 365. Thanks
    Monday, August 01, 2016 11:42 PM
  • I had the same problem, and this totally worked for me. Still having a problem with the Custom Dictionary. I have recreated the dictionary from a basic text file and still unable to access it through Word.
    Thursday, August 04, 2016 12:35 AM
  • Just used my mac spotlight and searched for linkCreation.dotm created on 6/30 and showed all in finder.  Deleted the file and all better!!!

    Thanks so much!

    Thursday, August 04, 2016 4:59 AM
  • yeah, that worked Richard. I don't know how you got there but I'm glad you did your awesomeness!

    Thursday, August 04, 2016 4:32 PM
  • That was VERY helpful!  Thank you so much!
    Thursday, August 04, 2016 9:08 PM
  • I HAVE THE ANSWER!

    Well, this worked for me, anyway.

    Since I updated to Word version 15.24 recently, when I either start up or quit Word, I get the error describe: "compiler error in hidden module: link".

    The reply given above by Steve Fan is what led me to find the solution, but didn't work in itself. The path describe above simply doesn't lead to the described content. However, having previously found (with great difficulty) Outlook's new location for storing its email database, I had a clue where to start looking.

    So basically, the path that Steve Fan should have quoted is as follows:

    ~/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word/

    I.e. start tunnelling down from your home folder (~), not the root of the startup disk.

    Inside the above Word folder I found a new file (dated 30 Jun 16) called "linkCreation.dotm". Promising, I thought, given the 'link' reference in the name and in the error message.

    I moved this file out of the folder and tried loading and quitting Word again. This time it worked fine, without the error message. Solved!

    For what it's worth, I also had another file called "Bookends.dot" in the above folder alongside the problem file. I left that in place, and it isn't causing a problem.

    Hope that helps someone else…

    Worked for me.  Had to use Spotlight to find the files.  I had 2 of them.  Just sent them straight to the trash.  One of them required me to enter my Admin password, the other did not.

    Closed Word and restarted without incident.

    Thanks.

    Monday, August 08, 2016 3:30 AM
  • This worked and thank you,  but I'm wondering when you say you "moved this file out of the folder" where did you move it to? I moved mine to the desktop - do I need to leave it there? HB
    Tuesday, August 09, 2016 11:27 AM
  • Thank you Richard Hallas for saving me TONS of aggravation & endless cases of punching my desk every freakin' time I opened & closed Word 2016 (or whatever version I'm using with my Mac Office 365).

    I should also note to anyone that may be discouraged by your lengthy explanation NOT TO PANIC - Richard's steps are VERY EASY TO FOLLOW:

    1. From FINDER, go to the GO menu.
    2. Select 'Go to folder'
    3. Paste EXACTLY what Richard had included in his very helpful post. (starting from ~/Library... and don't worry, the folder is there if you were affected by the update; the lengthy numbered folders aren't specific to Richard's machine; they are on yours too. Delete the file inside that folder.
    4. Thank him for his very informative explanation as to how Microsoft F'ed up and why Richard is doing their job yet I'm still paying them.
    This is what you need to know to solve the problem easily. Thank you M Fish and Richard  ;)
    Wednesday, August 10, 2016 1:06 PM
  • Thanks - this worked for me too!
    Thursday, August 11, 2016 3:44 PM
  • great! 

    it worked also for me!

    Thanks!!

    Thursday, August 11, 2016 4:26 PM
  • This worked for me - thanks Steve and Richard!  My question now is - can I now delete the linkCreation.dotm from my desktop, or do I have to leave it there?

    Thanks!

    Karen

    Thursday, August 11, 2016 5:23 PM
  • Thank you for saving my sanity. Worked like a charm.

    Friday, August 12, 2016 2:20 PM
  • This also worked for me.
    Monday, August 15, 2016 5:56 AM
  • Thanks that worked for me too
    Monday, August 15, 2016 8:42 AM
  • It was the same for me.  I found LinkCreation.dotm in the same path, removed it, and am still having the same problems.



    Monday, August 15, 2016 9:27 AM
  • Thks this worked for me (Office 15.11.2) I kept the file "just in case.." but so far so good!
    Tuesday, August 16, 2016 12:42 AM
  • Worked for me. Hint: use your search tool on the Mac. Just enter: linkCreation.dotm and delete the file. If you have a Word doc open you may have two files. Delete them. You will get the error message when you close Word but when you re-open everything is perfect. 
    Tuesday, August 16, 2016 5:47 AM
  • That worked for me thank you
    Tuesday, August 16, 2016 6:19 PM
  • Thanks! This worked for me.
    Wednesday, August 17, 2016 5:48 AM
  • Richard:  You deserve all those points.  This was easy to find with your direction.  I moved the "linkCreation.dotm" file and my problem also appears to be solved!  Thank you!

    Wednesday, August 17, 2016 2:07 PM
  • It worked perfectly for me.

    Thanks Very Much.

    Regards

    M

    Sunday, August 21, 2016 2:19 AM
  • Thank you Richard. Worked perfectly. Remove that file and you're away. Mac OS 10.11.12  Word 15.17.1.
    Monday, August 22, 2016 3:26 AM
  • Removing linkCreation.dotm worked for me! Thanks for sharing the answer.
    Monday, August 22, 2016 6:37 PM
  • This worked for me too - thanks
    Tuesday, August 23, 2016 1:26 AM
  • I remove a file (linkCreation.dotm) folder (~/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word/) and the problem was solved


    Wednesday, August 24, 2016 8:43 AM
  • Thankyou for sharing the answer Richard, this worked for me!
    Wednesday, August 24, 2016 11:23 PM
  • I had the same problem with Word version 15.25.  

    I performed the same action as Richard Hallas.  It worked for me.  I've moved the file linkCreation.dotm out of the folder (onto my desktop for now) and the application is back to normal functionality.  The problem started with I updated yesterday with microsoft's autoupdated.  As stated elsewhere in these posts, thanks Microsoft for taking something that was working and breaking it.  I only lost about an hour of my time today fixing it.

    In any event, it seems to be working now.  Do I dare delete the file from my desktop?


    Thursday, August 25, 2016 6:55 PM
  • I did a search for the file using spotlight, found it easily, moved it to my desktop.  I couldn't find it using the long address.

    BUT I still can't shut down word.  I keep getting the error message.  How do I shut down?

    Friday, August 26, 2016 12:28 PM
  • This worked for me, as well! The sudden appearance of that crazy problem was driving me nuts. THANK YOU!

    Patrick

    Sunday, August 28, 2016 12:30 PM
  • This worked for me as well on 8-29-16. Brilliant! Fyi, I moved the "linkCreation.dotm" file from the "Word" folder to the folder immediately above it, the "Startup" folder in Richard's post above. Thanks again!
    Tuesday, August 30, 2016 3:21 AM
  • Thank you. Solved. It helped me. I used the SPOTLIGHT, simply found the file: linkcreation.dotm and deleted it. Now Word works fine.
    Tuesday, August 30, 2016 2:39 PM
  • M Fish & Richard Hallas,

    Thank you for the great answers. I was stuck on the path until M Fish showed the easiest way to access the location.

    Works 100% - Great Job!
    Tuesday, August 30, 2016 5:34 PM
  • I did a search for the file using spotlight, found it easily, moved it to my desktop.  I couldn't find it using the long address.

    BUT I still can't shut down word.  I keep getting the error message.  How do I shut down?

    I have the same problem here..even i deleted the file, the error message is still on my screen after I OK it. What worse is that i can't open any other word doc. because of the error message on the screen. how do i do now? thank you.
    Wednesday, August 31, 2016 2:46 AM
  • Thank you for your solution. i deleted the file but the error message is still on my screen.I can't close it by click OK and because of this i can't open any word doc. further. I tried to restart my Mac after deleting it, then it didn't let me, saying i have to quit word first. Now i'm stuck-- don't know what to do.... Man I get your suggestion? Thank you!

     
    Wednesday, August 31, 2016 3:07 AM
  • Thank you for posting this explanation. I was getting this annoying error, and it is now resolved thanks to you. 
    Wednesday, August 31, 2016 1:23 PM
  • Worked perfectly - thank you!!
    Thursday, September 01, 2016 12:59 AM
  • Cheers! Works like a champ!
    Wednesday, September 07, 2016 5:22 PM
  • Thank you!
    Wednesday, September 07, 2016 7:44 PM
  • Thanks.

    I got it.

    Wednesday, September 07, 2016 8:03 PM
  • I HAVE THE ANSWER!

    Well, this worked for me, anyway.

    ...snip...

    So basically, the path that Steve Fan should have quoted is as follows:

    ~/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word/

    I.e. start tunnelling down from your home folder (~), not the root of the startup disk.

    Inside the above Word folder I found a new file (dated 30 Jun 16) called "linkCreation.dotm". Promising, I thought, given the 'link' reference in the name and in the error message.

    ... snip ...

    For what it's worth, I also had another file called "Bookends.dot" in the above folder alongside the problem file. I left that in place, and it isn't causing a problem.

    Hope that helps someone else…

    Indeed, that was a great help! I did find the file as mentioned here. Anyway, I wonder what it was all about? I mean that 'link' file? What purpose it supposed to serve?
    Thursday, September 08, 2016 1:35 AM
  • Brilliant!, thanks Richard.  I have been trying to fix that tedious little problem for ages.  Much appreciated

    Philip

    Thursday, September 08, 2016 3:14 PM
  • It Worked!

    THANKS Richard. Would be great if Microsoft actually fixed the bug, but your solution worked great.


    Friday, September 09, 2016 6:39 PM
  • Thanks for the extra pointer using the "Go to folder" option.  I had deleted the link creation file but was still having the problem.  I couldn't see the "Group Containers" as I guess it is a system folder and hidden by default.  Using "Go to folder" I was able to see the folder contents.  I still had "Mendeley-word2016-1.16-dev2.dot" in there.  I deleted that (as I don't use the Mendele add-in any more) and it fixed it.

    Thanks to everyone for the help.

    Monday, September 12, 2016 10:11 AM
  • Worked well, for me. 
    Monday, September 12, 2016 12:23 PM
  • THANK YOU !!! IT WORKED FINE !!!
    Monday, September 12, 2016 3:06 PM
  • This worked!!!! Thank you so much!
    Tuesday, September 13, 2016 3:16 PM
  • Richard Hallas... you are awesome! Instantly fixed, thanks!!!
    Tuesday, September 13, 2016 5:14 PM
  • I am confirming this worked for me as well.  This error persisted after several Office updates that I hoped would solve the problem.  All it took was manually deleting this single file. ~/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word/linkCreation.dotm

    Thanks for posting this fix.

    Wednesday, September 14, 2016 12:58 PM
  • Amazing Richard! It did work for me. Thanks a lot!
    Wednesday, September 14, 2016 4:13 PM
  • M Fish: thanks for the additional info. Got to the folder, deleted the linkCreation.dotm file which solved the problem. And thanks Richard!
    Thursday, September 15, 2016 5:54 AM

  • I did find the "linkCreation.dotm" file in Applications/Office/Startup/Word

    When I moved this out of the folder, I still had the error.

    I couldn't find the location you mentioned but searched my computer for the linkCreation.dotm file and found the location. It worked when I moved it out of the folder. Thank you!


    Friday, September 16, 2016 2:26 PM
  • You're a lifesaver. Just deleted this file and the problem is solved. Thank you!
    Friday, September 16, 2016 10:24 PM
  • I just used your directions and removed the "linkCreation.dotm" and it worked great. Thank you!!!!!
    Saturday, September 17, 2016 5:18 AM
  • You are awesome!!

    Monday, September 19, 2016 9:46 PM
  • Worked like a champ! Thanks!!
    Thursday, September 22, 2016 8:30 PM
  • You are a genius! Worked perfectly! Thank you for making it so simplel I hate microsoft. 
    Friday, September 23, 2016 7:31 PM
  • Richard,

    This problem recently popped up for me and your fix worked. Thanks so much!

    What is that "linkCreation.dotm" file for anyway?

    Monday, September 26, 2016 12:19 AM
  • Hi I was wondering if you have found a solution? I did exactly what was told in previous talks but I still get the same problem. Please help me
    Monday, September 26, 2016 10:02 PM
  • I HAVE THE ANSWER!

    Well, this worked for me, anyway.

    Since I updated to Word version 15.24 recently, when I either start up or quit Word, I get the error describe: "compiler error in hidden module: link".

    The reply given above by Steve Fan is what led me to find the solution, but didn't work in itself. The path describe above simply doesn't lead to the described content. However, having previously found (with great difficulty) Outlook's new location for storing its email database, I had a clue where to start looking.

    So basically, the path that Steve Fan should have quoted is as follows:

    ~/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word/

    I.e. start tunnelling down from your home folder (~), not the root of the startup disk.

    Inside the above Word folder I found a new file (dated 30 Jun 16) called "linkCreation.dotm". Promising, I thought, given the 'link' reference in the name and in the error message.

    I moved this file out of the folder and tried loading and quitting Word again. This time it worked fine, without the error message. Solved!

    For what it's worth, I also had another file called "Bookends.dot" in the above folder alongside the problem file. I left that in place, and it isn't causing a problem.

    Hope that helps someone else…

    Work for me too.

    Thanks!!!!

    Tuesday, September 27, 2016 4:14 AM
  • Freaking awesome solution. Worked perfectly. Also, SUPER annoying that this is even a thing.
    Tuesday, September 27, 2016 5:45 PM
  • Thanks Richard, you guided me correctly through the maze, and your solution worked!
    Friday, September 30, 2016 9:47 PM
  • Oh, wow! Thank you co much Richard. I'm still puzzled by the fact that Microsoft did nothing to fix this issue for  MAC users until now. 
    Saturday, October 01, 2016 5:42 PM
  • Thank you... solved my same problem.
    Wednesday, October 05, 2016 2:48 PM
  • That worked! thanks! 
    Wednesday, October 05, 2016 5:07 PM
  • That is the answer. Thanks!
    Thursday, October 06, 2016 5:44 PM
  • Maybe due to a preference change or another update, but after having used this answer as the solution it cropped up again at ~/Library/Group Containers/UBF8T346G9.Office/User Content.localized/Startup.localized/Word
    Wednesday, October 12, 2016 12:16 AM
  • This worked for me, thank you very much.

    Thursday, October 13, 2016 9:01 AM
  • Thanks for this information.  When I tried to drag linkCreation.dotm to another location I was not able to move it.

    Suggestions?

    Thanks in advance.

    Saturday, October 22, 2016 3:49 PM
  • Hi Steve,

    Just wondering why I have to do this - is it s glitch with microsoft products on some Macs? My Mac at work doesn't have this issue. BTW I have the latest MacBook Pro.

    Cheers,

    Sunday, October 23, 2016 6:30 AM
  • This worked for me! Thank you!
    Tuesday, October 25, 2016 6:33 PM
  • Thank you!!!
    It worked!!!!!
    Friday, October 28, 2016 11:38 AM
  • THANK YOU!
    Friday, October 28, 2016 7:01 PM
  • that worked for me. Now that I have moved the file out of the folder, can I delete it?

    Thanks

    Monday, October 31, 2016 12:18 AM
  • This worked for me, thanks!
    Monday, October 31, 2016 12:09 PM
  • Thank you very much. I wish somehow the reply can be pinned to the top of the thread. I made an account just so I can vote for this explanation!
    Tuesday, November 01, 2016 1:19 AM
  • Thanks Richard. I simply searched for "linkCreation.dotm" in spotlight and found it in the Word folder. After deletion everything worked fine.
    Wednesday, November 02, 2016 6:13 PM
  • Fixed the problem!  Thanks
    Wednesday, November 02, 2016 6:57 PM
  • I have this problem as well on my mac.  I've removed the files referenced below and it still happens and it takes forever to even launch the programs.  It's ridiculous.  I also have tremendous problems with Outlook and email.  It constantly asks for passwords and rejects my passwords even though it's the right password.  I'm thoroughly tired of having to "fix" these problems.  Do you have any words to help resolve these issues I am having with Office 365 and the Mac?

    Thanks.

    Not so pleased.

    Cheryl

    Wednesday, November 02, 2016 8:15 PM
  • Also, once it launches and I can work in the program, it shuts down.  For instance, when I'm editing in ppt, it will just drop out and relaunch.  Now that's super frustrating and annoying because there's a lot of work going into a ppt and suddenly it just fails.  Again, I default back to my PC systems to edit, but I can't always do that.  Oh, and one more thing, it seems to ONLY do this on my iMac, not my laptops.

    Thanks

    Cheryl

    Wednesday, November 02, 2016 8:17 PM
  • One more thing, it does it when I close the programs as well.
    Wednesday, November 02, 2016 8:20 PM
  • Thank you!  It worked for me, I no longer receive the error message!
    Friday, November 04, 2016 6:05 PM
  • Hi worked perfectly, just copy/pasted file name in your post into search in finder, found it straight away, sent to trash...no issues, cheers Richard.
    Monday, November 07, 2016 6:13 AM
  • Why is this happening repeatedly?
    Thursday, November 10, 2016 11:59 AM
  • I HAVE THE ANSWER!

    Well, this worked for me, anyway.

    Since I updated to Word version 15.24 recently, when I either start up or quit Word, I get the error describe: "compiler error in hidden module: link".

    The reply given above by Steve Fan is what led me to find the solution, but didn't work in itself. The path describe above simply doesn't lead to the described content. However, having previously found (with great difficulty) Outlook's new location for storing its email database, I had a clue where to start looking.

    So basically, the path that Steve Fan should have quoted is as follows:

    ~/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word/

    I.e. start tunnelling down from your home folder (~), not the root of the startup disk.

    Inside the above Word folder I found a new file (dated 30 Jun 16) called "linkCreation.dotm". Promising, I thought, given the 'link' reference in the name and in the error message.

    I moved this file out of the folder and tried loading and quitting Word again. This time it worked fine, without the error message. Solved!

    For what it's worth, I also had another file called "Bookends.dot" in the above folder alongside the problem file. I left that in place, and it isn't causing a problem.

    Hope that helps someone else…

    The folder library located in home folder is hidden by default, so you need:

    - a secondary click in home folder

    - choose Show view options

    - select Show library folder

    Now you'll be able to see the folder and follow Richard and Steve steps.

    Monday, November 14, 2016 12:21 PM
  • Hi,

    I had the same issue, and when I looked at the startup file I found a file.dotm for add-in program I used called Mendeley. I have just updated Mendeley and it works find, no more massages appears.

    Tuesday, November 15, 2016 4:56 PM
  • Thank you for helping me fix this annoying problem!!!!  Very much appreciated!
    Thursday, November 17, 2016 4:54 PM
  • In Word:
    1. Open Tools>Templates and Add-ins, click on linkCreation.dotm and make a note of the path to the file.
    2. Close Word.
    3. Hold down the Alt key while clicking on the Go menu and choosing Library. Your user Library folder opens.
    4. Navigate to the path you wrote down and drag linkCreation.dotm to your desktop.
    Friday, November 18, 2016 3:36 PM
  • In Word:
    1. Open Tools>Templates and Add-ins, click on linkCreation.dotm and make a note of the path to the file.
    2. Close Word.
    3. Hold down the Alt key while clicking on the Go menu and choosing Library. Your user Library folder opens.
    4. Navigate to the path you wrote down and drag linkCreation.dotm to your desktop.
    Friday, November 18, 2016 3:37 PM
  • I HAVE THE ANSWER!

    Well, this worked for me, anyway.

    Since I updated to Word version 15.24 recently, when I either start up or quit Word, I get the error describe: "compiler error in hidden module: link".

    The reply given above by Steve Fan is what led me to find the solution, but didn't work in itself. The path describe above simply doesn't lead to the described content. However, having previously found (with great difficulty) Outlook's new location for storing its email database, I had a clue where to start looking.

    So basically, the path that Steve Fan should have quoted is as follows:

    ~/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word/

    I.e. start tunnelling down from your home folder (~), not the root of the startup disk.

    Inside the above Word folder I found a new file (dated 30 Jun 16) called "linkCreation.dotm". Promising, I thought, given the 'link' reference in the name and in the error message.

    I moved this file out of the folder and tried loading and quitting Word again. This time it worked fine, without the error message. Solved!

    For what it's worth, I also had another file called "Bookends.dot" in the above folder alongside the problem file. I left that in place, and it isn't causing a problem.

    Hope that helps someone else…

    Thank you! It worked for me as well! I had 3 of these files, found them with Spotsearch, deleted all. Problem disappeared.
    Saturday, November 19, 2016 1:25 AM
  • Find: linkCreation.dotm

    Delete

    Success

    Wednesday, November 23, 2016 6:39 AM
  • This helped perfectly! I searched for the document titled "linkCreation.dotm" in my Finder and moved it to the trash and then emptied my trash. Then, I quit Word and when i re-opened it again, the problem was solved! THANK YOU!
    Friday, November 25, 2016 4:09 AM
  • For me the folder had .localized on them. I went in terminal and used

    rm  ~/Library/Group\ Containers/UBT346G9.Office/User\ Content.localized/Startup.localized/Word/linkCreation.dotm

    Worked like a charm. Thanks

    Tuesday, December 06, 2016 6:56 PM
  • Thank you, Richard.  This worked for me as well!
    Thursday, December 15, 2016 5:00 PM
  • Thanks ! Worked for me :)

    Monday, December 19, 2016 10:07 AM
  • Thank you Richard. I had to do a find to get to the folder "Group Containers" and then click on that to get to the path.  When I would look into my home account the Library wouldn't show up.  And when I looked in the main Library folder "Group Containers" wouldn't show up.  When I did a search in the finder it came up.  I click on the icon and it lead me to the path.  Works great.  Happy Holidays!!
    Saturday, December 24, 2016 3:35 PM
  • Thank you very much for documenting the fix for this! I was tired of dealing with that error message.  Your solution worked! 

    Monday, January 02, 2017 10:54 AM
  • Worked perfectly. Took a while to work out how to find that folder, but someone else posted a solution thankfully!
    Monday, January 09, 2017 7:49 PM
  • Richard, thank you so much for your post! Worked for me. The annoying error message at start and close of Word is gone!

    One recommendation: search your mac for file linkCreation.dotm 

    I was having hard time finding the group containers file - I guess it is hidden on my mac. however, searching for actual flie name worked beautifully.

    thanks again.


    • Edited by olandr Thursday, January 12, 2017 4:33 PM
    Thursday, January 12, 2017 4:32 PM
  • Thank you thank you thank you!!
    Wednesday, January 25, 2017 7:14 PM
  • As a Dutch user, I had to translate the '/User Content/Startup/Word/' part. But you earned my 5 points as well
    Sunday, February 12, 2017 9:55 AM
  • Thank you.  That worked for me too.
    Thursday, March 16, 2017 5:30 AM
  • Thanks, this is still working in 2017, although I do have to repeat the process after each upgrade  

    Pity Microsoft haven't fixed it yet

    Thursday, March 30, 2017 9:22 AM
  • Worked for me.

    Went in finder typed "linkCreation.dotm" in search. Trashed it. loaded Word again and the error message was gone.

    Thanks.

    Monday, May 08, 2017 12:52 PM
  • Thank you Richard, even a year after your post you are still helping people. The fix worked for me.
    Sunday, July 16, 2017 8:43 PM
  • I already thanked Richard, but without your guide into Finder, I would not have known where to look. Both of you helped and I an grateful.

    Sunday, July 16, 2017 8:45 PM
  • You sir, are a genius. And I thank you!!! Totally fixed the issue for me as well. 
    Thursday, August 03, 2017 4:38 PM
  • Thanks 

    Worked a treat

    Tuesday, August 29, 2017 8:01 PM
  • Trashing the linkCreation.dotm worked for me
    Wednesday, August 30, 2017 4:47 AM
  • Works!

    I search for the folder: UBF8T346G9.Office/User Content/Startup/Word/

    then removed the linkCreation.dotm

    Saturday, September 16, 2017 11:11 AM
  • This one worked for me - thanks!
    Monday, September 25, 2017 11:37 PM
  • thanks man its really working 
    Wednesday, October 18, 2017 3:55 AM