locked
Problem with Autodiscover on Exchange 2007 RRS feed

  • Question

  • We have an Exchange 2007 box sitting behind a TMG 2010 firewall.  OWA works a treat as do the other services except Autodiscover.

    The rule in TMG allows HTTPS traffic and listens for the public IP address of autodiscovery.culford.co.uk.  All ticks are green when the rule is tested including the link to //autodiscover.culford.co.uk:443/autodiscover

    When we test using testexchangeconnectivity.com we get an error telling us ISA denied the URL

    ExRCA is attempting to retrieve an XML Autodiscover response from URL https://autodiscover.culford.co.uk/AutoDiscover/AutoDiscover.xml for user xxx@culford.co.uk
      ExRCA failed to obtain an Autodiscover XML response.
       <label for="testSelectWizard_ctl12_ctl06_ctl00_ctl01_ctl04_ctl00_tmmArrow">Tell me more about this issue and how to resolve it</label>
     
    Additional Details
      An HTTP 403 error was received because ISA Server denied the specified URL.

    When we browse //localhost/autodiscover on the exchange box it changes the address to //localhost/owa/autodiscover which of course does not exist in IIS.

    It is looking for the correct location above for the xml file, but why does IIS translate the link URL?

    Tuesday, June 21, 2011 2:01 PM

Answers

  • Hello,

     

    How did you publish the autodiscover service via TMG. Also, do you configure the redirection on the autodiscover VD?

     

    Please also collect the information about the autodiscover VD by:

     

    Get-AutodiscoverVirtualDirectory |FL

     

    Thanks,

    Simon

    Thursday, June 23, 2011 3:19 AM
    Moderator

All replies

  • Hi,

    Can you verify external URL in autodiscover virtual directry and EWS. it shouldnot be null. Also do you see any error related certificates.

    Please run the get-WebServicesVirtualDirectory |fl and post the output to check here.


    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com
    Tuesday, June 21, 2011 3:19 PM
  • Hello,

     

    How did you publish the autodiscover service via TMG. Also, do you configure the redirection on the autodiscover VD?

     

    Please also collect the information about the autodiscover VD by:

     

    Get-AutodiscoverVirtualDirectory |FL

     

    Thanks,

    Simon

    Thursday, June 23, 2011 3:19 AM
    Moderator